Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VLAN with Sonicwall & 2970G

 

   Having a strange problem which this setup has always worked before. I have a sonic wall with vlan 1 and vlan 30 and I've got a couple ports with access vlan 30 on them but its not pulling dhcp from vlan 30 from the sonicwall. Attached is my config. I've taken this setup to other switches different models and brands and everything works fine so I know the Sonicwall side is setup right.

 

Here's my Trunk port

 

!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1-500
 switchport mode trunk
!

 

My Access port

!
interface GigabitEthernet0/3
 switchport access vlan 30

Then my vlans

 

!
interface Vlan1
 ip address 192.168.50.249 255.255.255.0
 no ip route-cache
!

interface Vlan30
 ip address 192.168.30.254 255.255.255.0
 no ip route-cache
!

Pretty straight forward setup or so I thought. Any help on where to look would be great! Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

did you create the layer-2

did you create the layer-2 vlan

config t

vlan 30

name firewall-vlan

exit

does "sh vlan summary" show vlan 30 and port gi0/3 active in it?

sh vlan summary

or

sh vlan id 30

 

 

7 REPLIES
VIP Super Bronze

If vlan 1 needs to get IP

If vlan 1 needs to get IP from vlan 30, than you need to add "ip helper-address 192.168.30.xx command under vlan 1 interface.

This is assuming the vlans are in up and up mode and so are the physical interfaces.

HTH

New Member

Nope vlan 30 is getting dhcp

Nope vlan 30 is getting dhcp from dhcp running on vlan30 on the sonicwall. dhcp on vlan1 is coming from the windows environment.

VIP Super Bronze

Do you have default-gatway or

Do you have default-gatway or default route on the switch pointing to the firewall (vlan 30)?

 

 

New Member

 Nope. There is no default

 

Nope. There is no default gateway for vlan30 and shouldn't be that would be on the clients. Which I do have set. I can't even ping the default gateway on the vlan so the vlan traffic isn't going from the access port to the trunk port. 

VIP Super Bronze

did you create the layer-2

did you create the layer-2 vlan

config t

vlan 30

name firewall-vlan

exit

does "sh vlan summary" show vlan 30 and port gi0/3 active in it?

sh vlan summary

or

sh vlan id 30

 

 

New Member

That was it! Thanks

That was it! Thanks

New Member

I've also tried static and

I've also tried static and ping the vlan 30 gateway from the access port vlan 30 which its not passing the traffic to the sonicwall

87
Views
0
Helpful
7
Replies
CreatePlease to create content