Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vlans not able to accessing internet

Dear All,

We have cisco 3550 switch i have configured 3 vlans in this switch vlans are not able to accessing internet

Please find the attached configuration

Everyone's tags (1)
7 REPLIES

vlans not able to accessing internet

Hi Narsimha,

A very obvious question first, are you able to ping your gateway IP address ??

If yes, that can you share the config of your gateway device...

Also, as seen in attached diagram, you haven't configured any port for any specific vlan, so by default all the vlans would be in Vlan 1...

Regards,

Smitesh

New Member

vlans not able to accessing internet

Hi Smitesh,

I have configure 3 ports for vlans port no 0/5,0/6/,0/7  i have given route to gateway 192.168.2.1 but vlans  not able to accessing internet

nterface FastEthernet0/1

no switchport

ip address 192.168.2.2 255.255.255.0

!

interface FastEthernet0/2

switchport mode access

!

interface FastEthernet0/3

switchport mode dynamic desirable

!

interface FastEthernet0/4

switchport mode dynamic desirable

!

interface FastEthernet0/5

switchport access vlan 100

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 200

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 300

switchport mode access

!

vlans not able to accessing internet

Hi Narsimha,

Did you add routes to those VLANs in your gateway? If you didn't then your gateway would not know how to return traffic to computers in those three VLANs.

To verify whether it's the case, run below pings from your 3550:

ping 192.168.2.1 source 172.16.17.1

ping 192.168.2.1 source 172.16.18.1

ping 192.168.2.1 source 172.16.19.1

Hope it helps.

New Member

vlans not able to accessing internet

Hello friends

Gateway should have these statements

ip route 172.16.17.0 255.255.255.0 192.168.2.2

ip route 172.16.18.0 255.255.255.0 192.168.2.2

ip route 172.16.19.0 255.255.255.0 192.168.2.2

interface FastEthernet0/1

no switchport

ip address 192.168.2.2 255.255.255.0

Be sure you can ping outside from  source fa0/1

Regards

Sabby

New Member

vlans not able to accessing internet

Hi,

Thanks for replay  I have configured default route in switch

ip route 0.0.0.0 0.0.0.0 192.168.2.1

switch able to accessing internet but vlan user not able to accessing Internet  vlans are communicating   each other & ableto ping 192.168.2.2 also

Regards

Narsimha

New Member

vlans not able to accessing internet

Reviewed your attached zip file for your config.

I assume that the 3550 switch is connected to a router (i.e., your default gateway), though this isn't stated in your description.

You have 3 different VLANs on int fa0/5, fa0/6, and fa0/7, respectively.

I do not see your config setup for InterVLAN routing; thus you would require one of your interfaces to be setup as a trunking port --->  this should be the interface that connects to your router (i.e., default gateway).

Simple test:  workstation on int fa0/5 cannot ping workstation on int fa0/6 or int fa0/7 since each of these interfaces are in different VLANs.  To pass traffic amongst different VLANs, one requires a trunking port; this holds true to also reach your default gateway. 

Another approach is to setup InterVLAN routing since the 3550 is a Layer 3 switch.

vlans not able to accessing internet

Hi,

Your router connected to switch should have below routes as Sarbjit mentioned

ip route 172.16.17.0 255.255.255.0 192.168.2.2

ip route 172.16.18.0 255.255.255.0 192.168.2.2

ip route 172.16.19.0 255.255.255.0 192.168.2.2

and make sure you have proper Nat statements for all 172.16.x.x networks on the gateway router...

HTH

Hitesh Vinzoda

Pls rate useful posts

6179
Views
0
Helpful
7
Replies
CreatePlease login to create content