Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VMs & CAM Table Updates

We are currently experiencing an issue with VMs and CAM table updates with a Cisco 2960G (Stack) which is prompting a unicast flood to take place (observed via packet sniffer software).

Cisco 2960 Configuration (L2)

IOS: 15.0(1) SE2

VLANs

10 - Port-Group 1

20 - Port-Group 2

Port-Group 1 (Host A)

interface GigabitEthernet1/0/1

description Port-Group 1

switchport access vlan 10

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

interface GigabitEthernet2/0/1

description Port-Group 1

switchport access vlan 10

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable


Port-Group 2 (Host A)

interface GigabitEthernet1/0/2

description Port-Group 1

switchport access vlan 20

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

interface GigabitEthernet2/0/2

description Port-Group 1

switchport access vlan 20

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

Port-Group 1 (Host B)

interface GigabitEthernet1/0/3

description Port-Group 1

switchport access vlan 10

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

interface GigabitEthernet2/0/3

description Port-Group 1

switchport access vlan 10

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable


Port-Group 2 (Host B)

interface GigabitEthernet1/0/4

description Port-Group 1

switchport access vlan 20

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

interface GigabitEthernet2/0/4

description Port-Group 1

switchport access vlan 20

switchport mode access

switchport nonegotiate

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

VM Host configuration (network)


Port-Group: 1

2 x Physical Interfaces (Per Port Group)
Notify Switches: Yes
VLAN ID: 0 (None)

NIC 1: Active

NIC 2: Standby

Port-Group: 2

2 x Physical Interfaces (Per Port Group)

Notify Switches: Yes

VLAN ID: 0 (None)

NIC 1: Active

NIC 2: Standby

VM Guest configurations (network)

2 x VNICs

VNIC 1: 172.16.x.x/16 (Default Gateway Assigned)  / Port-Group: 1

VNIC 2: 172.17.x.x/16 / Port-Group: 2

Start of MAC: 00:50:56
VNIC Types: Flexible / E1000

Issue

When a VM guest is migrated between VM host A to B, we observe a number of reverse ARP / gratuitous ARP packets being submitted by the VM host A and VM host B.


When running the debug arp on the Cisco 2960 we observe the following, so know that the switch is receiving the reverse ARP / gratuitous ARP requests.

RARP: Rcvd RARP req for <VNIC 1 MAC ADDRESS>

RARP: Rcvd RARP req for <VNIC 2 MAC ADDRESS>


When reviewing the MAC address table we can see that interface Gi1/0/3 has the MAC address of VNIC 1 associated with it, but the MAC address of VNIC 2 doesnt appear to have been registered within the CAM cable. This then prompts a unicast flood to take place for traffic destined to this interface. The MAC address for VNIC 2 never seems to appear even when checking hours later.

Just wondered if anyone else has experienced a similar issue

This issue appears to be intermittent.

Everyone's tags (2)
117
Views
0
Helpful
0
Replies
CreatePlease login to create content