Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Voice & Data VLAN Configuration

Greetings, We had a vendor install all our switches and I've found that the switch configurations for voice & data are a little different. They are configured either as (where vlan 10 = data, vlan 172 =voice):

interface FastEthernet0/2
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode access
switchport voice vlan 172
mls qos trust dscp
spanning-tree portfast

OR....

interface GigabitEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 172
mls qos trust dscp
spanning-tree portfast

I've also see the voice configured as:

switchport access vlan 172

And some ports (that are not connected to 'static' devices such as a router) configured with switchport mode trunk, and also had voice running on it.

I'm trying to get all configurations consistent across the board. Can anyone tell me if there is a best way to approach this? Is one configuration going to give better performance than another?

Thanks,

Chris

P.S. The switches are Catalyst 3650, running 12.2 (35)SE5 IOS.

1 REPLY
VIP Super Bronze

Re: Voice & Data VLAN Configuration

Hi Chris,

For your first solution, Cisco calls this a Multi-Vlan access port, and NOT a trunk port. But we all know if you have more then one vlan on the port then it is trunk.  I would go with your second option:

interface GigabitEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 172
mls qos trust dscp
spanning-tree portfast

https://supportforums.cisco.com/thread/1003209?tstart=30

HTH

Reza

632
Views
0
Helpful
1
Replies
CreatePlease login to create content