Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Voice QoS Sanity Check

Greetings, attached is a simplified diagram of our network. The issue im having is increased jitter on voice calls when both data and voice is traversing our leased line. When no data is passing jitter is reduced by approx 70%

Ive applied auto qos to both the fast ethernet interface on the Cisco 2811 running CME 4.3 and the serial wic on the 1841. No policies have been configured on the firewall.

What im looking for is really a confirmation that i have applied qos on the correct interfaces, any recommendation for additional configuration would be appreciated.

Regards

6 REPLIES

Re: Voice QoS Sanity Check

can u post qos config for each device

Community Member

Re: Voice QoS Sanity Check

Cisco CME

policy-map AutoQoS-Policy-UnTrust

class AutoQoS-VoIP-RTP-UnTrust

priority percent 70

set dscp ef

class AutoQoS-VoIP-Control-UnTrust

bandwidth percent 5

set dscp af31

class AutoQoS-VoIP-Remark

set dscp default

class class-default

fair-queue

!

interface Loopback0

description Loopback For UnityExpress

ip address 10.10.10.2 255.255.255.252

!

interface FastEthernet0/0

description Voice

ip address 172.28.255.4 255.255.255.0

duplex full

speed 100

auto qos voip

service-policy output AutoQoS-Policy-UnTrust

!

interface FastEthernet0/1

description Access

ip address 172.29.255.4 255.255.255.0

duplex full

speed 100

!

ip access-list extended AutoQoS-VoIP-Control

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

permit tcp any any eq 2428

permit tcp any any range 2000 2002

permit udp any any eq 1719

permit udp any any eq 5060

ip access-list extended AutoQoS-VoIP-RTCP

permit udp any any range 16384 32767

!

Cisco 1841

class-map match-any AutoQoS-VoIP-Remark

match ip dscp ef

match ip dscp cs3

match ip dscp af31

class-map match-any AutoQoS-VoIP-Control-UnTrust

match access-group name AutoQoS-VoIP-Control

class-map match-any AutoQoS-VoIP-RTP-UnTrust

match protocol rtp audio

match access-group name AutoQoS-VoIP-RTCP

!

policy-map AutoQoS-Policy-UnTrust

class AutoQoS-VoIP-RTP-UnTrust

priority percent 70

set dscp ef

class AutoQoS-VoIP-Control-UnTrust

bandwidth percent 5

set dscp af31

class AutoQoS-VoIP-Remark

set dscp default

class class-default

fair-queue

!

ip access-list extended AutoQoS-VoIP-Control

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

permit tcp any any eq 2428

permit tcp any any range 2000 2002

permit udp any any eq 1719

permit udp any any eq 5060

ip access-list extended AutoQoS-VoIP-RTCP

permit udp any any range 16384 32767

!

interface Serial0/0/0

bandwidth 2048

ip unnumbered FastEthernet0/0

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation ppp

no ip mroute-cache

no cdp enable

service-policy output AutoQoS-Policy-UnTrust

I was considering putting a priority queue on the firewall to see if it made a difference.

Regards

Community Member

Re: Voice QoS Sanity Check

Which way is having the quality problem? IP side or PSTN side? or both?

Community Member

Re: Voice QoS Sanity Check

The quality problem occurs on the return RTP stream, there have been issues where by the called party can here the calling party but not the other way arround, during these cases jitter jumps to approx 3000ms.

We use SIP for voice services provided by an external proxy which sits outside the 1841.

Community Member

Re: Voice QoS Sanity Check

.

Super Bronze

Re: Voice QoS Sanity Check

It's unclear from your diagram, what's on the other side of the cloud, and what the cloud represents. Generally, you want to first place QoS on both ends of your WAN (leased line) link since it's often has the least available bandwidth (compared to typical LAN links).

394
Views
0
Helpful
6
Replies
CreatePlease to create content