Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

voice vlan cat-2950

I have 2 vlans on a 2950, one for data and one for voice. vlan 100 data. vlan 200 voice. when I no shut the vlan 200 interface, vlan 100 interfaces gets shut down. Same thing happens when I no shut the 100 int.

any ideas?

7 REPLIES

Re: voice vlan cat-2950

2950 is a layer2 switch and you can have only one VLAN interface active at any given time. The VLAN interface in 2950 is meant for switch management only and does not handle user traffic.

You need to setup another layer 3 capable switch or router configured with dot1q sub-interfaces to pass inter-VLAN traffic.

HTH

Sundar

Hall of Fame Super Silver

Re: voice vlan cat-2950

Shaun

I believe that Sundar is correct in identifying the problem as being that the 2950 as a layer 2 switch can have only a single VLAN "interface" active at a time.

This does not mean that the switch can have only a single VLAN active at a time, the restriction is only on VLAN interface. I find that frequently people do not understand well the distinction between having a VLAN on a switch and having a VLAN interface on a switch. The VLAN is used by the switch as part of doing the layer 2 forwarding of frames and the switch is capable of having multiple VLANs with no problem. The VLAN interface is used, as Sundar explains, for management purposes. A layer 2 switch can have only a single active VLAN interface. (A layer 3 switch can have multiple active layer 3 interfaces which it uses as part of doing its layer 3 forwarding).

So your 2950 with data VLAN and voice VLAN should be just fine. And both VLAN 100 and 200 can be used for layer 2 forwarding just fine. But it can have only 1 VLAN interface active.

HTH

Rick

New Member

Re: voice vlan cat-2950

I see, I have been confused on the limitation of Vlans vs. Vlan interfaces. Thanks for your help, if you would can you please have a look at my previous reply that contains some of my config, I think I am having a problem with dhcp helper.

New Member

Re: voice vlan cat-2950

Thanks for your reply.

I'm in a bit of a bind, I have a router on a stick scenario. I have a Phone and a PC on the 2950. I cant get the phone to get an address. Origionaly I was going to put ip helper on int vlan 100 and on int vlan 200.... I see that this will not work...

router config:

interface FastEthernet0/0

ip address 10.50.100.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/0.200

encapsulation dot1Q 200

ip address 10.50.200.1 255.255.255.0

switch config:

!

vlan 100,200

!

interface FastEthernet0/1

switchport access vlan 100

switchport trunk native vlan 100

switchport mode trunk

switchport voice vlan 200

spanning-tree portfast

!

interface RANGE FastEthernet0/2 - 24

switchport access vlan 100

switchport voice vlan 200

spanning-tree portfast

!

interface Vlan100

ip address 10.50.100.2 255.255.255.0

ip helper-address 10.1.1.13

no ip route-cache

!

Re: voice vlan cat-2950

You put the ip-helper command on the subinterface of the router. This will direct the dhcp requests to the server.

Interface should not have an ip on it

Do a no ip on the fa0/0 and then create the below config.

interface FastEthernet0/0.100

ip address 10.50.100.1 255.255.255.0

encapsulation dot1Q 100

duplex auto

speed auto

ip helper-address x.x.x.x

interface FastEthernet0/0.200

encapsulation dot1Q 200

ip address 10.50.200.1 255.255.255.0

ip helper-address x.x.x.x

Please rate helpful posts!

Hall of Fame Super Silver

Re: voice vlan cat-2950

Shaun

I find that many people do not have a good understanding of the difference between having a VLAN on a switch and having a VLAN interface on the switch. I am glad that you understand it better now.

As far as your config is concerned I have a couple of comments or suggestions:

- if the DHCP server is at 10.1.1.13 then you do need ip helper-address to forward the DHCP requests.

- you need the ip helper-address command for both VLANs. And it can be done if you put it on the router. So I suggest that you move the ip helper-address command from the switch and put it under both VLANs on the router.

- it may work to have the native VLAN configured as the physical interface on the router. But I would prefer to see it configured as a VLAN subinterface. So I would suggest that you configure this on the router:

interface FastEthernet0/0.100

encapsulation dot1Q 100 native

then move the ip address from the physical interface to the subinterface 100. And put ip helper-address under both of the subinterfaces on the router.

HTH

Rick

New Member

Re: voice vlan cat-2950

Thank you very much for your help. I moved the ip helper to the sub interface on the router and the phone is now working as well as the PC. I will take your advice and set up both sub interfaces.

thanks again.

163
Views
10
Helpful
7
Replies
CreatePlease to create content