Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Voice vlan issue in cisco 3524 switch with IOS 12.0(5)XU

Hi Folks,

I'm using CISCO 3524 switch as access switch and trying to enable voice vlan in fast eth ports as below.

L3 vlans are created in core switches which is cisco 6509

vlan 1 - data vlan

vlan 2 - voice vlan

in cisco 3524

-----------------

int fa0/1

switchport access vlan 1

switchport voice vlan 2

speed 100

duplex full.

if i use the above configs, the phone which is connected to interface fa0/1 is not taking ip from dhcp server. even it didn't work with static configs.

while troubelshooting, i have configured as below and it's started working..

int fa0/1

switchport acces vlan 2

speed 100

duplex full.

in this case i can't use this port for data connectivity where as it's required for data too. can anyone help me to understand? also please help me to overcome this issue.

Thanks..!

3 REPLIES
New Member

Voice vlan issue in cisco 3524 switch with IOS 12.0(5)XU

If i'm not wrong your switch doesn't support voice vlan, try to configure interface as trunk dot1q, and set data vlan as native. I suggest you as cisco best practice to don't use vlan 1 due to security reasons.

Let us know if it was usefull.

Fabio

Green

Voice vlan issue in cisco 3524 switch with IOS 12.0(5)XU

Hi,

Can you try this config on the 3524 interface

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport mode trunk

switchport voice vlan 203

spanning-tree portfast

no shut

!

HTH

Alex

Regards, Alex. Please rate useful posts.
New Member

Use this config on switch

Use this config on switch 3524:

 

!To create vlan

Switch#vlan database

Switch(vlan)#vlan 10 name Data

Switch(vlan)#vlan 100 name Voice

 

!To assign aport to voice vlan

interface FastEthernet0/1

 switchport access vlan 10

 switchport trunk encapsulation dot1q

 switchport mode trunk

 switchport voice vlan 100

!

911
Views
0
Helpful
3
Replies