Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Voice VLAN

Hi All,

I'm having a litle difficulty with setting up a (working) voice VLAN on a Cat 2960-24PC using Avaya 9630 phones.

My port config is:

***

interface FastEthernet0/12

description ### VOIP Test ###

switchport access vlan 211

switchport mode access

switchport voice vlan 213

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

spanning-tree portfast

end

***

The phone powers up no problem, but then sits waiting for DHCP and VLAN info.

If I configure the port without the voice vlan it works, in that the phone gets a DHCP ip address (as expected really, but this proves DHCP and trunking from my switch to router is working) config below.

***

interface FastEthernet0/12

description ### VOIP Test ###

switchport access vlan 213

switchport mode access

spanning-tree portfast

end

***

Router on a stick config

***

interface FastEthernet0/1.213

description ### To XXX Voice ###

encapsulation dot1Q 213

ip address 172.21.3.1 255.255.255.0

ip helper-address 172.21.1.10

ip nat inside

ip virtual-reassembly

zone-member security Inside

ip tcp adjust-mss 1412

***

My setup is a a 1841 configured as a router on a stick with VLANs 1,211,212 and 213 trunked to the 2960. Sh int trunk confirms that this is working. Putting a Windows XP DHCP client onto VLAN 213 proves that the IP Helper on the subinterface on the 1841 is working.

I have setup a debug ip packet on the router (with an ACL) to see if there is any DHCP type traffic with the voice vlan configured and I can't see any.

I have the same config on my Cat6509-E's on a different site and they all work perfectly with the first config.

Any suggestions?

Thanks

Kevin

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: Voice VLAN

Hello Kevin.. Not sure if you got this resolved or not but basically when the Avaya phone is connected initially it has no idea what vlan it is connected to. It sends a DHCP request, which the helper forwards to the dhcp server. The dhcp server should be configured with option 242 (under the data vlan scope options) which is used to provide the phone with its correct VLAN ID. The Avaya phone recieves the response and then then sends another DHCP request, this time using the correct VLAN ID.

It could be that the DHCP server you are using is not setup correctly with option 242, therefore the phone does not know to tag its traffic with VLAN ID 213.

Also, the Avaya phone (afaik) by default sets the COS value to 6. You may want to trust COS (not DSCP) on the access port and re-mark the COS to value 5.

Let me know if this helps

Thanks,

Ray

10 REPLIES
Hall of Fame Super Silver

Re: Voice VLAN

Hello Kevin,

the standard configuration with voice vlan is for Cisco IP phones that exchange CDP messages with the switch port.

You should look for the standards based LLDP to play the role of CDP on your device.

Or you dedicate the port to the phone using access vlan=213 but this means no pc downstream the avayas phone.

see

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst2960/software/release/12.2_50_se/configuration/guide/swlldp.html

or

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_50_se/configuration/guide/swlldp.html

the chapter about LLDP in config guide.

you may need an IOS upgrade on your device to support it.

Hope to help

Giuseppe

Community Member

Re: Voice VLAN

Hi Giuseppe,

Thank you for your reply, I will read up on LLDP.

I'm still confused though as to why this same config works on 6509-E's on a different site. LLDP is not enabled on them.

Thanks

Kevin

Hall of Fame Super Bronze

Re: Voice VLAN

Kevin,

interface FastEthernet0/1.213

description ### To XXX Voice ###

encapsulation dot1Q 213

ip address 172.21.3.1 255.255.255.0

ip helper-address 172.21.1.10

ip nat inside

ip virtual-reassembly

zone-member security Inside

ip tcp adjust-mss 1412

What's being translated?

How is your zone security configured?

It can potentially affected the phone from getting its information from TFTP after getting its IP from the data Vlan.

__

Edison.

Community Member

Re: Voice VLAN

Hi Edison,

That was me being lazy and doing a copy and paste from sub-if fa 0/1.211 (Which has access to the internet via a NAT pool)

I've cleaned up the config, it now is:

***

interface FastEthernet0/1.213

description ### To XXX Voice ###

encapsulation dot1Q 213

ip address 172.21.3.1 255.255.255.0

ip helper-address 172.21.1.10

ip virtual-reassembly

zone-member security Inside

ip tcp adjust-mss 1412

***

Community Member

Re: Voice VLAN

Hello Kevin.. Not sure if you got this resolved or not but basically when the Avaya phone is connected initially it has no idea what vlan it is connected to. It sends a DHCP request, which the helper forwards to the dhcp server. The dhcp server should be configured with option 242 (under the data vlan scope options) which is used to provide the phone with its correct VLAN ID. The Avaya phone recieves the response and then then sends another DHCP request, this time using the correct VLAN ID.

It could be that the DHCP server you are using is not setup correctly with option 242, therefore the phone does not know to tag its traffic with VLAN ID 213.

Also, the Avaya phone (afaik) by default sets the COS value to 6. You may want to trust COS (not DSCP) on the access port and re-mark the COS to value 5.

Let me know if this helps

Thanks,

Ray

Community Member

Re: Voice VLAN

Hello Kevin.. Not sure if you got this resolved or not but basically when the Avaya phone is connected initially it has no idea what vlan it is connected to. It sends a DHCP request, which the helper forwards to the dhcp server. The dhcp server should be configured with option 242 (under the data vlan scope options) which is used to provide the phone with its correct VLAN ID. The Avaya phone recieves the response and then then sends another DHCP request, this time using the correct VLAN ID.

It could be that the DHCP server you are using is not setup correctly with option 242, therefore the phone does not know to tag its traffic with VLAN ID 213.

Also, the Avaya phone (afaik) by default sets the COS value to 6. You may want to trust COS (not DSCP) on the access port and re-mark the COS to value 5.

Let me know if this helps

Thanks,

Ray

Community Member

Re: Voice VLAN

Hi Ray,

You steered me in the right direction!

I have made a mistake with the L2QVLAN and PHY2VLAN tags on the DHCP server.

Thank you!

For information, the final working config on the switchport was

***

interface FastEthernet0/12

description ### VOIP Test ###

switchport access vlan 211

switchport mode access

switchport voice vlan 213

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

spanning-tree portfast

***

and on the DHCP server I needed the following in option 242 along with the MCIP. "L2Q=1,L2QVLAN=213,PHY2VLAN=211"

In summary it was an Avaya problem rather than a Cisco one.

Thanks all, this really is a great forum.

Cheers

Kevin

Hall of Fame Super Silver

Re: Voice VLAN

Hello Ray,

very good note so there is an alternate way to communicate vlan-id to avaya phone at the DHCP level.

good to know

Best Regards

Giuseppe

Community Member

Re: Voice VLAN

No problem guys, i use this forum quite a lot for obtaining information, its good to provide some for a change!

Regards,

Ray

Community Member

Re: Voice VLAN

Hello Kevin.. Not sure if you got this resolved or not but basically when the Avaya phone is connected initially it has no idea what vlan it is connected to. It sends a DHCP request, which the helper forwards to the dhcp server. The dhcp server should be configured with option 242 (under the data vlan scope options) which is used to provide the phone with its correct VLAN ID. The Avaya phone recieves the response and then then sends another DHCP request, this time using the correct VLAN ID.

It could be that the DHCP server you are using is not setup correctly with option 242, therefore the phone does not know to tag its traffic with VLAN ID 213.

Also, the Avaya phone (afaik) by default sets the COS value to 6. You may want to trust COS (not DSCP) on the access port and re-mark the COS to value 5.

Let me know if this helps

Thanks,

Ray

1076
Views
5
Helpful
10
Replies
CreatePlease to create content