Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Voice VLAN

Hi,

I wanna clarify few things on the voice vlan;

1) I am going to use 1000+ phones on my new work and my current configuration is;

interface GigabitEthernet0/1

description PHONE D104

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

speed 100

duplex full.

The native VLAN is for the PC. But is it a good configuration. Now i am planning to put voice vlan.

Which configuration will be good, trunk or voice.

3 REPLIES

Re: Voice VLAN

Hi

i think it will be good to define seprate vlans for both data and voice.And in u r above config u havent defined the voice vlan.

intergace gig/0/1

switchport mode access

switchport access vlan 4

switchport voice vlan 10

spanning-tree portfast

Thanks

Mahmood

New Member

Re: Voice VLAN

Thanks mahmood,

My current setup is not having a voice VLAN as it is configuring on the phone. (specifying the vlan on phone).

But now i am planning to put the voice vlan, does a mls qos is necessary for IP phones.

Re: Voice VLAN

Hi Drnteam,

You should definately use Voice vlan's. If you don't you will most likely have voice quality issue's.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_se/configuration/guide/swvoip.html

Just add this to your config on your interfaces if you are using Cisco IP Phones.

Make note of the prompt #.

Config#mls qos

interface FastEthernet1/0/4

description IP Phone/Data Port

switchport access vlan xx

switchport mode access

switchport voice vlan xx

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

HTH, Please rate

Regards,

Justin Brenton

258
Views
5
Helpful
3
Replies