Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

voice vlan

Hello, I manage a network consists of 29 cisco catalyst platform 4507, 2960, 2950, under a VTP domain, is being implemented voice over IP and I have problems with the network to be set up for that purpose.

The solution is the manufacturer for ericsson and have phones with port SW, computers that connect to this port left in the administrative network but the voice does not reach its VLAN, I have tested with this command swport voice lvan (the number of the voice Vlan) but not yet achieving the transit of voice packets.

what configuration I recommend?

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: voice vlan

The "switchport voice vlan" command uses CDP to both communicate the proper VLAN to the phone and to set the port to a limited trunking mode when an IP phone is detected as a CDP neighbor.

This works with Cisco phones and also with Polycom phones. It is not likely to be supported by Ericsson or other IP phone manufacturers that don't do CDP.

In this case, you'll have to configure the switch port and the phone manually for the voice VLAN.

On the switch, assuming VVV is the voice vlan and DDD is the data vlan:

interface f0/xx

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan DDD

switchport trunk allow vlan DDD,VVV

---(appropriate qos configuration)---

You will need to read the Ericsson phone documentation to determine how to program the phone to use the assigned voice VLAN.

5 REPLIES
Silver

Re: voice vlan

Here is the URL for the configuration for the Voice VLAN which will help you :

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_44_se/configuration/guide/swvoip.html

New Member

Re: voice vlan

hi this configuration works, for telephone device Linksys

interface FastEthernet0/23

switchport access vlan 2

switchport voice vlan 4

mls qos trust device cisco-phone

spanning-tree portfast

an this one, for other Manufacturer;

interface FastEthernet0/21

switchport access vlan 4

switchport mode trunk

Heiber

New Member

Re: voice vlan

hi this configuration works, for telephone device Linksys

interface FastEthernet0/23

switchport access vlan 2

switchport voice vlan 4

mls qos trust device cisco-phone

spanning-tree portfast

an this one, for other Manufacturer;

interface FastEthernet0/21

switchport access vlan 4

switchport mode trunk

Heiber

New Member

Re: voice vlan

The "switchport voice vlan" command uses CDP to both communicate the proper VLAN to the phone and to set the port to a limited trunking mode when an IP phone is detected as a CDP neighbor.

This works with Cisco phones and also with Polycom phones. It is not likely to be supported by Ericsson or other IP phone manufacturers that don't do CDP.

In this case, you'll have to configure the switch port and the phone manually for the voice VLAN.

On the switch, assuming VVV is the voice vlan and DDD is the data vlan:

interface f0/xx

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan DDD

switchport trunk allow vlan DDD,VVV

---(appropriate qos configuration)---

You will need to read the Ericsson phone documentation to determine how to program the phone to use the assigned voice VLAN.

Re: voice vlan

Ericsson IP Phones can use Voice VLANs and it can all be automatic, you do however have to 'provision' things. Out of the box an Ericsson IP Phone will use DHCP and request Vendor Option 43 to discover the Voice VLAN. Your DHCP Server needs to respond with Option 43 which can tell it the Voice VLAN Tag and the Software Server IP address where it's configuration file is held (you can also optionally use Option 43 to tell the Phone its Telephony Domain Name, a Proxy Server IP Address and Proxy TCP Port no).

If you have access to the Ericsson ALEX documentation it is all detailed in there.

HTH

Andy

327
Views
0
Helpful
5
Replies
CreatePlease to create content