Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VPN setup in a ASA 5505

Im trying to set up a VPN in a 5505 ASA. The host is a ASA 5510. The connection is a DSL with a static IP. This is the config I have in the 5505.

hostname landfill
domain-name default.domain.invalid
enable password 8WchzxzEGYY00Jo0 encrypted
passwd DdwidD3e3hOlIuQu encrypted
names
name 10.0.0.0 Chester
name 10.20.0.0 ChesterGov
name 10.200.4.0 Landfill

interfaced Vlan1

nameif inside

  security-level-100

ip address 10.200.4.1


interface Vlan2
nameif inside
security-level 100
ip address 204.116.85.166 255.255.255.0


!
interface Ethernet0/0
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7


ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list outside_1_cryptomap extended permit ip Landfill 255.255.255.0 Chester 255.0.0.0
access-list inside_nat0_outbound extended permit ip Landfill 255.255.255.0 Chester 255.0.0.0
pager lines 24
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside Chester 255.0.0.0 207.144.35.1 1
route outside 0.0.0.0 0.0.0.0 207.144.35.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http Chester 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 64.53.58.229
crypto map outside_map 1 set transform-set ESP-DES-MD5
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 86400
telnet ChesterGov 255.255.0.0 inside
telnet timeout 5
ssh 64.53.58.229 255.255.255.255 outside
ssh 68.115.233.128 255.255.255.224 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd dns 10.20.50.12 97.107.96.139
dhcpd wins 10.20.50.12
dhcpd ping_timeout 750
dhcpd domain chester.local
!
dhcpd address 10.200.10.10-10.200.10.41 inside
dhcpd enable inside
!

tftp-server inside 10.20.50.12 building-confg
tunnel-group 204.116.85.166 type ipsec-l2l
tunnel-group 204.116.85.166 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:87752a68b46be0350d19a1a4afcf8fc7

Does anybody see any issues with this?

1 REPLY

VPN setup in a ASA 5505

Can you add this:

tunnel-group 64.53.58.229 type ipsec-l2l

tunnel-group 64.53.58.229 ipsec-attributes

pre-shared-key

Another thing i have noticed is the disconnect between the WAN IP (VLAN 2) and default gateway next hop IP address.

nterface Vlan2

nameif inside

security-level 100

ip address 204.116.85.166 255.255.255.0

!

route outside 0.0.0.0 0.0.0.0 207.144.35.1 1

Please rate replies and mark question as "answered" if applicable.

Please rate replies and mark question as "answered" if applicable.
69
Views
0
Helpful
1
Replies
CreatePlease to create content