Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VRF Issue

I'm just testing this out. I have configured two VRF instance. And I'm exporting and importing vrf table from Cust-A to vice versa.

ip vrf Cust-A

rd 1:1

route-target export 1:1

route-target import 1:1

route-target import 2:2

!

ip vrf Cust-B

rd 2:2

route-target export 2:2

route-target import 2:2

route-target import 1:1

interface FastEthernet0/1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

load-interval 30

full-duplex

no cdp enable

!

interface FastEthernet0/1/0.1

encapsulation dot1Q 99

ip vrf forwarding Cust-A

ip address 10.192.168.1 255.255.255.0

no cdp enable

!

interface FastEthernet0/1/0.2

encapsulation dot1Q 169

ip vrf forwarding Cust-B

ip address 10.192.169.1 255.255.255.0

no cdp enable

If I do show ip route vrf Cust-A or Cust-B ..

show ip route vrf Cust-B

10.0.0.0/24 is subnetted, 1 subnets

C 10.192.169.0 is directly connected, FastEthernet0/1/0.2

show ip route vrf Cust-A

Routing Table: Cust-A

10.0.0.0/24 is subnetted, 1 subnets

C 10.192.168.0 is directly connected, FastEthernet0/1/0.1

If i'm importing and exporting route target from both VRf than both VRF should exchange routing table and I must see Cust-A routes in Cust-B VRF table and vice versa..

what i'm doing wrong here...

Second, what if i want my Cust-B users to access internet while internet default route is in global table?

Note: I'm not gonna use any routing protocol for this lab. I just wana use static routing...

1 REPLY

Re: VRF Issue

I think you have posted the same question in the WAN forum too.

AFAIK, you would require BGP to import the vrfs. You need not do any peering but just enable BGP and respective address families on this switch.

I have done this in my lab and it works out perfectly. I had posted the BGP configs in the WAN forum

HTH

Narayan

Please rate all useful posts

90
Views
0
Helpful
1
Replies