Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

VRF-lite

Hello

I have a question about VRF-lite and RIP. I asked our consultant from Cisco he said that we could use VRF with static route or with RIP with our image. I have done this with OSPF and there is no problem. But I dont find any command to use with RIP. Does anyone know how to use RIP with VRF?

2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Re: VRF-lite

Here's an example..

router rip

version 2

!

address-family ipv4 vrf vrf101

version 2

network xx.xx.0.0

no auto-summary

exit-address-family

Re: VRF-lite

Well RIP uses address-families just like BGP or EIGRP. A sample config for two different VRFs:

ip vrf Cust1

rd 65000:11

ip vrf Cust2

rd 65000:12

interface Serial1/1

ip vrf forwarding Cust1

ip address 10.1.11.1 255.255.255.252

interface Serial1/2

ip vrf forwarding Cust2

ip address 10.2.12.1 255.255.255.252

router rip

version 2

!

address-family ipv4 vrf Cust1

version 2

network 10.0.0.0

no auto-summary

exit-address-family

address-family ipv4 vrf Cust2

version 2

network 10.0.0.0

no auto-summary

exit-address-family

For the address-family you can use pretty much any command, which is used with normal RIP.

Hope this helps! Please use the rating system.

Regards, Martin

3 REPLIES
New Member

Re: VRF-lite

Here's an example..

router rip

version 2

!

address-family ipv4 vrf vrf101

version 2

network xx.xx.0.0

no auto-summary

exit-address-family

Re: VRF-lite

Well RIP uses address-families just like BGP or EIGRP. A sample config for two different VRFs:

ip vrf Cust1

rd 65000:11

ip vrf Cust2

rd 65000:12

interface Serial1/1

ip vrf forwarding Cust1

ip address 10.1.11.1 255.255.255.252

interface Serial1/2

ip vrf forwarding Cust2

ip address 10.2.12.1 255.255.255.252

router rip

version 2

!

address-family ipv4 vrf Cust1

version 2

network 10.0.0.0

no auto-summary

exit-address-family

address-family ipv4 vrf Cust2

version 2

network 10.0.0.0

no auto-summary

exit-address-family

For the address-family you can use pretty much any command, which is used with normal RIP.

Hope this helps! Please use the rating system.

Regards, Martin

New Member

Re: VRF-lite

Thanks

Works great!

320
Views
4
Helpful
3
Replies
CreatePlease to create content