Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VRF question

Hello !!

We have decided to run the central firewall for our customers using VRF. So below I have posted the VRF config for one company, this config is on our PPPoE Router.

Our PPPoE Router is connected to an Cisco ASA 5540, and the ASA nat`s the customers to the internet.

ip vrf Company1

rd 65520:1400

route-target export 65520:1400

route-target import 65520:1400

!

interface FastEthernet0/0.210

description Company1

encapsulation dot1Q 210

ip vrf forwarding Company1

ip address 192.168.5.10 255.255.255.0 secondary

ip address 10.16.1.40 255.255.255.248

no snmp trap link-status

!

address-family ipv4 vrf Company1

redistribute connected

redistribute static

no auto-summary

no synchronization

exit-address-family

!

ip route vrf Company1 0.0.0.0 0.0.0.0 10.16.1.41

ip route vrf Company1 192.168.5.10 255.255.255.128 10.18.2.1

So the question now is :

1. is this configuration correct on the PPPoE Router ?? something I missed ??

2. now the question is, which parameters I need to configure in the radius server so the customers Router-Modem can receive it after he connect it to the pppoe router, usually the RADIUS gives the ip address to the customer, but in this case there is more info that RADIUS needs to assign to the customers router such as VRF info. So could someone please explain this to me ?? some example too ?

Thank You !!

Best regards

James

2 REPLIES
Bronze

Re: VRF question

To configure a VPN routing and forwarding (VRF) instance and enter VRF configuration mode, use the vrf command in router configuration mode. To remove the VRF instance from the configuration file and restore the system to its default condition, use the no form of this command.

vrf vrf-name

no vrf vrf-name

To use this command, you must be in a user group associated with a task group that includes the proper task IDs. For detailed information about user groups and task IDs.

Use the vrf command to configure a VRF instance. A VRF instance is a collection of VPN routing and forwarding tables maintained at the provider edge (PE) router.

New Member

Re: VRF question

Hello !!

Thank You for raply, but I think You misunderstod my question ?, I need to find out which parameters and which config the CUSTOMERS router should receive from our RADIUS server, because usually the customers receives the ip address from the RADIUS server when they connects to the our RADIUS, but now in case VRF they need more parameters, but which ???

Thank You

Best regards

James

166
Views
0
Helpful
2
Replies
CreatePlease to create content