Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VSS configurations

We have 2 core switches 4500 series. Am going to configure first time VSS configurations. When i entering first command for creating domain ,  but command not recognizing switches. 

"sw1(config)#switch virtual domain 9
^
% Invalid input detected at '^' marker.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi

Hi

It seems that you're running IOS XE 3.6 with lanbase features. However, to get VSS you need at least IP Base and/or Enterprise services:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/release/note/OL_32143-01.html

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/release/note/ol-37xe-4500e.html

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

Hi

Hi

You have to go on cisco website:

http://www.cisco.com/go/license

It will ask your CCO ID and then you have to enter you PAK with switch serial. At the end of the process you'll get a lic file. 

With ftp or tftp you can copy it to your switch and then with license install command you can install it on the switch(install and activate). You need to reboot the switch. 

Before you reboot the switch, with show version command, you will be able to see the license on next reboot has to be IP Base. 

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
12 REPLIES

Hi

Hi

It seems that you're running IOS XE 3.6 with lanbase features. However, to get VSS you need at least IP Base and/or Enterprise services:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/release/note/OL_32143-01.html

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/release/note/ol-37xe-4500e.html

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Community Member

HI,

HI,

Thanks your support . We have PAK for C4500E-IPB-S and how can i get it license file . Also how can i load load this license file to our switche. Please help me 

Hi

Hi

You have to go on cisco website:

http://www.cisco.com/go/license

It will ask your CCO ID and then you have to enter you PAK with switch serial. At the end of the process you'll get a lic file. 

With ftp or tftp you can copy it to your switch and then with license install command you can install it on the switch(install and activate). You need to reboot the switch. 

Before you reboot the switch, with show version command, you will be able to see the license on next reboot has to be IP Base. 

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Community Member

HI,

HI,

Please help me  for configurations also , Once i receive the license file we are going to configure the VSS configurations , We have 2 core switches same series C4500. please provide me VSS configurations. we need only simple VSS configurations. i created sample configurations. Please confirm it correct or not ? or need more command ....

SW1(config)#switch virtual domain 10
SW1(config-vs-domain)#switch 1
SW1(config-vs-domain)#exit
SW1(config)#
SW1(config)#int port-channel 5
SW1(config-if)#switchport
SW1(config-if)#switch virtual link 1
SW1(config-if)#no shut
SW1(config-if)#exit
SW1(config)#int range gig7/3 - 4
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#channel-group 5 mode on
WARNING: Interface GigabitEthernet7/3 placed in restricted config mode. All extraneous configs removed!
WARNING: Interface GigabitEthernet7/4 placed in restricted config mode. All extraneous configs removed!
SW1(config-if-range)#exit
SW1#switch convert mode virtual


SW2(config)#switch virtual domain 10
SW2(config-vs-domain)#switch 2
SW2(config-vs-domain)#exit
SW2(config)#
SW2(config)#int port-channel 10
SW2(config-if)#switchport
SW2(config-if)#switch virtual link 2
SW2(config-if)#no shut
SW2(config-if)#exit
SW2(config)#
SW2(config)#int range gig4/45 - 46
SW2(config-if-range)#switchport mode trunk
SW2(config-if-range)#channel-group 10 mode on
WARNING: Interface GigabitEthernet4/45 placed in restricted config mode. All extraneous configs removed!
WARNING: Interface GigabitEthernet4/46 placed in restricted config mode. All extraneous configs removed!
SW2(config-if-range)#exit
SW1#switch convert mode virtual

Hi

Hi

If I remember good, this is the exact configuration example from Cisco Community when they've launched VSS on 4500.

4500 can support VSS with 1G or 10 G VSL links.

The configuration looks like correct. What issue are you facing?

You need to switch convert mode virtual/ On your last row, you've done it again on SW1

Provide output of :

- sh switch virtual

- sh switch virtual role

There are more commands like (sh switc virtual port-ch,....)


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Community Member

Hi,

Hi,

Thanks your support . Still not yet configured. Just I prepared the configuration before going to the site.

Switch Show run command is ws-x45-sup8-E license level LAN base. I have PAK key for ipbase. Is it enough for configuring VSS for our core switches

Community Member

HI.

HI.

As per the manual VSS configurations IPbase will support only SUP7E , What about WS-X45-SUP8-E .

VSS is supported by SUP8-E

VSS is supported by SUP8-E with IP Base.

Check this link : http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/release/note/ol-37xe-4500e.htm

- go on Table 5 LAN Base, IP Base, and Enterprise Services Image Support on Cisco Catalyst 4500E Supervisor Engine 7-E, Supervisor Engine 7L-E, and Supervisor Engine 8-E

- search VSS and you will see that SUP8-E is OK with IP BASE.

Do you have any issues?


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Community Member

HI,

HI,

VSS successfully configured and tested . When i turned off the main switch   second  switch will come up main switch . But i when turned on the switch still second switch active. how can set priority. 

Hi

Hi

There is no preempt on VSS by default as not recommended by Cisco.

If you really want to test preemption then you have a Cisco documentation that tells you how to do that (very very simple):

http://www.cisco.com/c/en/us/td/docs/solutions/Enterprise/Campus/VSS30dg/campusVSS_DG/VSS-dg_ch2.html#wp1056474

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Community Member

Hi, Thanks your supports.

Hi, Thanks your supports..Please give some more ideas and configurations about  Dual Link Detection on VSS

You have 2 ways: Fast Hello

You have 2 ways: Fast Hello or Enhanced PaGP.

For PaGP, you'll need a another switch that will give you the possibility to leverage PAGP protocol. In that case, you need to be aware that PAGP port-channel as to be terminated on the same switch. You can't use a stack and split links form the port-channel to terminate on different members.

The fast hello is simplest as you don't need any addon switches. A simple fiber link between the 2 VSS chassis. You can even use the 1G link from the supervisor card if you don't have any 1G free ports on other linecards.


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
158
Views
0
Helpful
12
Replies
CreatePlease to create content