Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VTP (revision numbers) and one client not getting updates

Hello.

Somewhere along the line one of our switches (3750x) got messed up. Once they were finally configured about 6 months ago we never touched them again.

I noticed yesterday when I created a new vlan it was not getting populated to one of our switches. For some reason I did not notice that the domain name on the switch not receiving updates was not our domain.

 

So I switched the domain on this switch to the correct domain and it still does not show any updates and also has a revision # of 7.


So on this switch I then unplugged all trunk ports and did "vtp mode transparent". I then switched it back to "vtp mode client vlan".
It still showed revision 7.

 

So I tried "vtp domain bogus" and "vtp mode transparent" and then did "vtp domain mydomain" and "vtp mode client vlan".
It still showed revision 7.
 

So I tried "vtp domain bogus" and "vtp mode transparent vlan" and then did "vtp domain mydomain" and "vtp mode client vlan".
It still showed revision 7.

I am at a loss as to how to fix this problem other than rebuilding the switch. I have a vtp server at revision 10 and two other switches also at revision 10 that are getting updates from the vtp server. Only one switch is not.  Please note that this one switch that is not working at some point did since it has all the vlans we created on our initial installation.

-- Thanks

 

 


// GOOD switch
GOODSWITCH#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 3
VTP Domain Name                 : mydomain
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 7426.acad.de00

Feature VLAN:
--------------
VTP Operating Mode                : Client
Number of existing VLANs          : 15
Number of existing extended VLANs : 6
Maximum VLANs supported locally   : 1005
Configuration Revision            : 10
Primary ID                        : b838.61aa.5880
Primary Description               : lab-desk
MD5 digest                        : 0xB8 0x3E 0x2C 0xB7 0x85 0xB5 0x5D 0xA6
                                    0x4A 0x4E 0xFC 0x5E 0x5A 0xA1 0xAF 0xCC


Feature MST:
--------------
VTP Operating Mode                : Transparent


Feature UNKNOWN:
--------------
VTP Operating Mode                : Transparent

 

// BAD switch
BADSWITCH#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 3
VTP Domain Name                 : mydomain
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 7426.acad.ee80

Feature VLAN:
--------------
VTP Operating Mode                : Client
Number of existing VLANs          : 12
Number of existing extended VLANs : 6
Maximum VLANs supported locally   : 1005
Configuration Revision            : 7
Primary ID                        : b000.b4b0.f200
Primary Description               : lab-desk
MD5 digest                        : 0x7A 0x5C 0x2E 0x05 0xF2 0x80 0x6F 0x2F
                                    0x4E 0xE1 0x34 0x07 0x01 0x7F 0xB9 0x2B


Feature MST:
--------------
VTP Operating Mode                : Transparent


Feature UNKNOWN:
--------------
VTP Operating Mode                : Transparent

 

 

 

 

 

  • LAN Switching and Routing
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

HelloJust clarify the current

Hello

Just clarify the current VTP server is running in version 3 and is presently promoted a the vtp primary?

Are all the other clients even the one that isnt getting the DB synchronised are all running vtp 3?

Have you tried forcing the exisitng vtp server primary again?

#vtp primary force


Please note the following

if you change the vtp3 domain name AFTER promoting the switch to a primary server  then you will need to re-promote it again

:
Vtp3 server ( promoted to a primary can ONLY change vtp database)
Only one vtp primary per vtp domain

Any other vtp 3 server cannot change vtp database unless its promoted to vtp primary ( either by force or checking for other vtp 3 switches ( server/primarys

 

Add vtp 3 switch as a Client
--------------------------------------------------------
1.    Choose switch to become vtp 3 client ( making suee the revison number is 0 ( change to transparent back to client)
2.    Change vtp ver to 3 (one attached this will initiate a synchronization of the switche vtp DB to that of the new vtp3 priamry server vtp D/B -  As long as the password /domain are the same)
3.    Change password to be hidden ( optonal)

Attached to network.

res

Paul



 

Please don't forget to rate any posts that have been helpful. Thanks.
21 REPLIES
New Member

Hello,Do you have any vtp

Hello,

Do you have any vtp server configured? did you check if there is any password configured?

Regards,

New Member

I do have a vtp server

I do have a vtp server configured.. there is no password.

yesterday i added in three vlans to our vtp server switch and 2 out of the 3 switches got the vlan updates.

the third one did not.

thanks

 

lab-desk#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 3
VTP Domain Name                 : mydomain
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : b838.61aa.5880

Feature VLAN:
--------------
VTP Operating Mode                : Primary Server
Number of existing VLANs          : 15
Number of existing extended VLANs : 6
Maximum VLANs supported locally   : 1005
Configuration Revision            : 10
Primary ID                        : b838.61aa.5880
Primary Description               : lab-desk
MD5 digest                        : 0xB8 0x3E 0x2C 0xB7 0x85 0xB5 0x5D 0xA6
                                    0x4A 0x4E 0xFC 0x5E 0x5A 0xA1 0xAF 0xCC


Feature MST:
--------------
VTP Operating Mode                : Transparent


Feature UNKNOWN:
--------------
VTP Operating Mode                : Transparent

 

lab-desk#show vtp password
The VTP password is not configured.

 

New Member

Can you show the output of

Can you show the output of the "show interfaces trunk" and "show spanning-tree interface <the interface that has the trunk>" ?

New Member

Output from the switch NOT

Output from the switch NOT getting updates.

// we have three trunk lines
-----------------
TenGigabitEthernet1/1/1
TenGigabitEthernet1/1/2
TenGigabitEthernet2/1/1


// #show interfaces trunk
----------------

Port        Mode             Encapsulation  Status        Native vlan
Te1/1/1     on               802.1q         trunking      1
Te1/1/2     on               802.1q         trunking      1
Gi2/0/31    auto             n-802.1q       trunking      1
Gi2/0/46    auto             n-802.1q       trunking      1
Te2/1/1     on               802.1q         trunking      1

Port        Vlans allowed on trunk
Te1/1/1     1-4094
Te1/1/2     1-4094
Gi2/0/31    1-4094
Gi2/0/46    1-4094
Te2/1/1     1-4094

Port        Vlans allowed and active in management domain
Te1/1/1     1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224
Te1/1/2     1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224
Gi2/0/31    1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224
Gi2/0/46    1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224
Te2/1/1     1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224

Port        Vlans in spanning tree forwarding state and not pruned
Te1/1/1     1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224
Te1/1/2     1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224
Gi2/0/31    6,12,100,125-126,129,1032,1096,1128,1160,1192,1224
Gi2/0/46    1,6,12,100,125-127,129,1032,1096,1128,1160,1192,1224
Te2/1/1     none

 

----------------


show spanning-tree interface TenGigabitEthernet1/1/1

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Root FWD 2         128.53   P2p
VLAN0006            Root FWD 2         128.53   P2p
VLAN0012            Root FWD 2         128.53   P2p
VLAN0100            Root FWD 2         128.53   P2p
VLAN0125            Root FWD 2         128.53   P2p
VLAN0126            Root FWD 2         128.53   P2p
VLAN0127            Root FWD 2         128.53   P2p
VLAN0129            Root FWD 2         128.53   P2p
VLAN1032            Root FWD 2         128.53   P2p
VLAN1096            Root FWD 2         128.53   P2p
VLAN1128            Root FWD 2         128.53   P2p
VLAN1160            Root FWD 2         128.53   P2p
VLAN1192            Root FWD 2         128.53   P2p
VLAN1224            Root FWD 2         128.53   P2p


show spanning-tree interface TenGigabitEthernet1/1/2

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Desg FWD 2         128.54   P2p
VLAN0006            Desg FWD 2         128.54   P2p
VLAN0012            Desg FWD 2         128.54   P2p
VLAN0100            Desg FWD 2         128.54   P2p
VLAN0125            Desg FWD 2         128.54   P2p
VLAN0126            Desg FWD 2         128.54   P2p
VLAN0127            Desg FWD 2         128.54   P2p
VLAN0129            Desg FWD 2         128.54   P2p
VLAN1032            Desg FWD 2         128.54   P2p
VLAN1096            Desg FWD 2         128.54   P2p
VLAN1128            Desg FWD 2         128.54   P2p
VLAN1160            Desg FWD 2         128.54   P2p
VLAN1192            Desg FWD 2         128.54   P2p
VLAN1224            Desg FWD 2         128.54   P2p


show spanning-tree interface TenGigabitEthernet2/1/1

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Altn BLK 2         128.109  P2p
VLAN0006            Altn BLK 2         128.109  P2p
VLAN0012            Altn BLK 2         128.109  P2p
VLAN0100            Altn BLK 2         128.109  P2p
VLAN0125            Altn BLK 2         128.109  P2p
VLAN0126            Altn BLK 2         128.109  P2p
VLAN0127            Altn BLK 2         128.109  P2p
VLAN0129            Altn BLK 2         128.109  P2p
VLAN1032            Altn BLK 2         128.109  P2p
VLAN1096            Altn BLK 2         128.109  P2p
VLAN1128            Altn BLK 2         128.109  P2p
VLAN1160            Altn BLK 2         128.109  P2p
VLAN1192            Altn BLK 2         128.109  P2p
VLAN1224            Altn BLK 2         128.109  P2p

 

New Member

I´m assuming that you have

I´m assuming that you have the VTP server on the root switch. The config imo looks good at least to me.

like kevin said i dont get why the revision number didnt restart from zero when you changed from transparent to client mode. Also the MD5 shows are different.

Maybe you can try to debug the vtp messages: debug sw-vlan vtp (events, packet, pruning etc) and create a vlan in the server to see if it sends any messages.

New Member

I did the following.debug sw

I did the following.

debug sw-vlan vtp events
debug sw-vlan vtp packets
debug sw-vlan vtp pruning
debug sw-vlan vtp redundancy
debug sw-vlan vtp xmit

 

I created a vlan (000182 message) and then deleted a vlan (000183) message.

I waited a few minutes and then some debug messages appeared.

----------

 

000182: Mar 30 02:25:42.711: VTP LOG RUNTIME: VTP3: dropping the packet 1

000183: Mar 30 02:26:22.565: VTP LOG RUNTIME: VTP3: dropping the packet 1

000184: Mar 30 02:27:06.681: VTP LOG RUNTIME: VTP3VLAN: tx vtp summary, domain mydomain, rev 7 window 100

000185: Mar 30 02:27:07.646: VTP LOG RUNTIME: VTP3VLAN: tx vtp summary, domain mydomain, rev 7 window 100

000186: Mar 30 02:27:08.652: VTP LOG RUNTIME: VTP3VLAN: tx vtp summary, domain mydomain, rev 7 window 100

000187: Mar 30 02:27:09.139: VTP LOG RUNTIME: VTP3VLAN: tx vtp summary, domain mydomain, rev 7 window 100

and after many minutes more some of these.

000201: Mar 30 02:42:23.103: VTP LOG RUNTIME: VTP3VLAN: received summary advertisement packet

000202: Mar 30 02:42:23.111: VTP LOG RUNTIME: VTP3: dropping the packet 1 ---

 

New Member

Ok, just a brief question.

Ok, just a brief question. You really need to use vtp v3? i think that you might resolve the issue changing to vtp v2. I think the problem might be related to the vlan support int vtp v3.

New Member

Hi.Well I think 3 is best

Hi.

Well I think 3 is best since it will help limit any accidentally blowing away all vlans.

Why do you suggest it is v3 being the problem. I have other switches that work and this one did work at some point.

Thanks

New Member

Sure that´s a good point it

Sure that´s a good point it was just a suggestion but if you want that feature its ok. Discard the vlan related issue mentioned before.

 

My last try to not make you waste your time would be to check in the running. If the password is hidden it should be there in a hexa value (in the server or client.) Since md5 is not matching i dont know what else can be. I know that you said that there isnt a password but maybe it was configured as hidden.

Best Regards

 

815
Views
0
Helpful
21
Replies