Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VTP transparent mode

Hello,

I have setup a 2 switches as a trunk in VTP server mode all workes well, VLAN's can route between each other.

I have set up VTP server/client mode as well, and all works.

The only scenario I haven't tried is VTP transparent mode, what is this? Do bother switches have to be in tranparent mode?

I'm not sure how to configure this and just wondered if someone could give me an example?

5 REPLIES
Purple

Re: VTP transparent mode

Both sides should be in transparent mode , just makes things easier to troubleshoot if you have a problem . In transparent mode all vlans have to manually be created on both sides of the link and the vlan database is not propagated to other switches . the only real difference between server and transparent is that on a server you can create your layer 2 vlans in a single place and all those vlans will get propagated down to all other servers and clients within the same vtp domain so you do not have to create the vlans all over . This becomes a plus if you have a large install where you have dozens of vlans within a domain .

on both sides

conf t

vtp mode transparent

to create vlans

conf t

vlan X --> do this for every vlan on both sides .

interfaces can be done in a number of ways

interface gx/x

switchport encapsulation dot1q

switchport trunk native vlan X -->must match on both sides.

switchport mode dynamic desirable -->other end can be desirable or auto

switchport trunk allowed vlan x

Note: in place of switchport mode dynamic desirable or auto you can use "switchport mode trunk also on both sides.

New Member

Re: VTP transparent mode

Thanks Glen,

Though on my VTP server mode where both are set as server I haven't set the vtp domains and works, plus I don't use the native vlan either.

I can only think this works as my 2 switches must be using a default domain on both switches. I'm not sure about this natve VLAN though.

Switch 1

!

interface Vlan1

no ip address

!

interface Vlan29

ip address 192.168.2.1 255.255.255.0

!

interface Vlan35

ip address 192.168.3.1 255.255.255.0

Switch 2

!

interface FastEthernet0/1

switchport mode trunk

interface Vlan1

no ip address

no ip route-cache

shutdown

Purple

Re: VTP transparent mode

It would work if you don't set any vtp name because they both use a null domain name. If you didn't set the native trunk then it defaults to vlan 1 so both sides would be vlan 1 as native vlan . As good practice only allow the vlans you actually need across the trunk , "switchport trunk allowed vlan X .

New Member

Re: VTP transparent mode

HI,

Switch in traspatant mode will remain aluf from your entier network, changed made in server switch will not reflact in switch with tranparent mode.

New Member

Re: VTP transparent mode

There are advantage of using a switch in a transparent mode:

i) It limits the risk of an administrator error, such as deleting a VLAN accidentally and thus impacting the entire domain

ii) There is no risk from a new switch being introduced into the network with the higher VTP revision number and overwriting the entire domain's VLAN configuration.

iii) it encourages VLANs to be pruned from trunks running to switches that do not have ports in that VLAN, thus making frame flooding more bandwidth-efficient. Manual pruning also has the benefit of reducing the spanning tree diameter.

iv) The extended VLAN range number 1006-4094 can only be configured in this way

Hope this helps.

348
Views
0
Helpful
5
Replies
CreatePlease to create content