Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

VTP version 3 and pruning

Hi,

As far as I know when using VTP v2 you just have to enable pruning in anyone of the domain's VTP servers in order to activate it too in the other VTP servers and clients. I'm deploying VTP v3 in my network but enabling pruning in one of the VTP servers doesn't enable this feature automatically in the other VTP domain members. Is this right? If you want to enable pruning in VTP v3 must you activate it manually in every switch of the VTP domain?

Regards

Everyone's tags (1)
10 REPLIES
Hall of Fame Super Blue

Re: VTP version 3 and pruning

fmpiedrafita wrote:

Hi,

As far as I know when using VTP v2 you just have to enable pruning in anyone of the domain's VTP servers in order to activate it too in the other VTP servers and clients. I'm deploying VTP v3 in my network but enabling pruning in one of the VTP servers doesn't enable this feature automatically in the other VTP domain members. Is this right? If you want to enable pruning in VTP v3 must you activate it manually in every switch of the VTP domain?

Regards

I've not heard of this before, do you have a link to any docs that state this.

If this were the case then it would kind of negate one of the main advantages of VTP pruning.

Jon

Community Member

Re: VTP version 3 and pruning

I have read some documents about VTP v3 (VTP section in some Catalyst configuration guides) but any ot them didn't say anything special about pruning, so I assume pruning behaviour remains the same, in other words, enabling pruning in the VTPv3 servers should be enough to propagate this feature across the whole network and nothing else would be necessary. I'm not sure if maybe I'm doing something wrong (most probably) and that's the cause of this missbehaviour with pruning or all my configs are OK but it's the new way pruning works in VTPv3.

Has someone tested pruning configuration in VTP v3?

Regards

Community Member

Re: VTP version 3 and pruning

I answer to myself. I found the answer reading Catalyst 3750 configuration guide 12.2(52)SE.

In VTP version 3 you have to enable pruning manually in every switch of the domain.

Enabling pruning only in a VTP server doesn't activate this feature automatically in the others switches of the domain. This is different with VTPv1 or VTPv2, where you just have to configure pruning in a VTP server in order to activate it in all domain's switches.

Regards.

Community Member

Re: VTP version 3 and pruning

Did you reset the switches when you go over from v2 to v3

I need a bigger scope for VLANs but still running v2.

Regards,

Danny

Community Member

Re: VTP version 3 and pruning

ok?

I'm running VTPv3 and using pruning. For my case it was not necessary to enable pruning on any clients.....

- do you have a link to the doc?

Community Member

Re: VTP version 3 and pruning

Hi,

here you are:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/12.2_55_se/configuration/guide/swvtp.html#wp1072526

"With VTP versions 1 and 2, when you enable pruning on the VTP server, it is enabled for the entire VTP domain. In VTP version 3, you must manually enable pruning on each switch in the domain."

Community Member

Re: VTP version 3 and pruning

Aha!

Hmm - I had pruning enabled on the server in v1! Then I migrated to version 3 for both client and server.

Apperently the enabled pruning state was kept!

I can see from the vtp status show command that pruning is enabled on the client switch!

Community Member

Re: VTP version 3 and pruning

Hi,

yes, if you enabled pruning before (for VTP v1 or v2 you only have to do it in the server side) that state is kept when you migrate to VTPv3. Maybe, using VTPv2 (if possible) during the initial deployment of switches in a new and large site is a way to save time, since if you want to use this feature you only  have to run the command in the server, and then you could migrate to VTPv3 later with no need to enter in each client switch to activate it.

Community Member

Re: VTP version 3 and pruning

ok! Nice to know

If you have time I would appreciate your comments on this:

https://supportforums.cisco.com/thread/2063818

Re: VTP version 3 and pruning

Hi mate,

Thanks for returning here and make things clear!

I hit the same scenario: connected a bunch of switches and moved them to VTP v3 at once. Next I turned VTP prunning on one server (I used VTP Primary command first), but no luck on the other switches.

Also pay attention to the following rule:

Only VLANs included in the pruning-eligible list can be pruned. By default, VLANs 2 through 1001 are pruning-eligible on trunk ports. Reserved VLANs and extended-range VLANs cannot be pruned.

Nevertheless I run a test on my lab and got some questions:

- I have 3 switches connected in a triangle:

3550-I

Fa0/23                         up             up       To-Cisco3550-II

Fa0/24                         up             up       To-Cisco3550-III

3550-I#show vtp status

VTP Version                     : running VTP2

Configuration Revision          : 30

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 9

VTP Operating Mode              : Server

VTP Domain Name                 : class.net

VTP Pruning Mode                : Enabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x0F 0x93 0xCA 0xA8 0x4E 0xD3 0x17 0x38

Configuration last modified by 172.20.20.31 at 8-20-12 09:12:28

Local updater ID is 172.20.20.31 on interface Vl16 (lowest numbered VLAN interface found)

3550-II:

Fa0/22                         up             up       To-SRW2024

Fa0/23                         up             up       To-Cisco3550-III

Fa0/24                         up             up       To-Cisco3550-I

show vtp status

VTP Version                     : running VTP2

Configuration Revision          : 30

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 9

VTP Operating Mode              : Server

VTP Domain Name                 : class.net

VTP Pruning Mode                : Enabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x0F 0x93 0xCA 0xA8 0x4E 0xD3 0x17 0x38

Configuration last modified by 172.20.20.31 at 8-20-12 09:12:28

Local updater ID is 172.20.20.30 on interface Vl16 (lowest numbered VLAN interface found)

3550-II#show spanning-tree blockedports

Name                 Blocked Interfaces List

-------------------- ------------------------------------

VLAN0001             Fa0/24

VLAN0016             Fa0/24

VLAN0123             Fa0/24

VLAN0125             Fa0/24

VLAN0333             Fa0/24

Number of blocked ports (segments) in the system : 5


3550-III:

Fa0/22                         up             up       To-3750X

Fa0/23                         up             up       To-Cisco3550-I

Fa0/24                         up             up       To-Cisco3550-II

3550-III#show vtp status

VTP Version                     : running VTP2

Configuration Revision          : 30

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 9

VTP Operating Mode              : Server

VTP Domain Name                 : class.net

VTP Pruning Mode                : Enabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x0F 0x93 0xCA 0xA8 0x4E 0xD3 0x17 0x38

Configuration last modified by 172.20.20.31 at 8-20-12 09:12:28

Local updater ID is 172.20.20.29 on interface Vl16 (lowest numbered VLAN interface found)

Spanning-tree is runing rapid-pvst mode and blocked one port on 3550-II.

Here comes the trouble:

3550-III prunes traffic to 3550-I but not to 3550-II:

3550-III#show int trunk

Port        Mode             Encapsulation  Status        Native vlan

Fa0/22      on               802.1q         trunking      1

Fa0/23      on               802.1q         trunking      1

Fa0/24      on               802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/22      1-4094

Fa0/23      1-4094

Fa0/24      1-4094

Port        Vlans allowed and active in management domain

Fa0/22      1,16,123,125,333

Fa0/23      1,16,123,125,333

Fa0/24      1,16,123,125,333

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/22      1,16,123,125,333

Fa0/23      1,16

Fa0/24      1,16,123,125,333

I can presume this is happening because 3550-II has an uplink to another switch: SRW2024.

3550-II doesn't prune anything and I presume the same reason as before.

3550-II#show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan

Fa0/22      on               802.1q         trunking      1

Fa0/23      on               802.1q         trunking      1

Fa0/24      on               802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/22      1-4094

Fa0/23      1-4094

Fa0/24      1-4094

Port        Vlans allowed and active in management domain

Fa0/22      1,16,123,125,333

Fa0/23      1,16,123,125,333

Fa0/24      1,16,123,125,333

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/22      1,16,123,125,333

Fa0/23      1,16,123,125,333

Fa0/24      none

BUT, I have no idea on 3550-I which has only TWO LIVE links to both 3550-II and 3550-III. Here's the status:

3550-I#show int trunk

Port        Mode             Encapsulation  Status        Native vlan

Fa0/23      on               802.1q         trunking      1

Fa0/24      on               802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/23      1-4094

Fa0/24      1-4094

Port        Vlans allowed and active in management domain

Fa0/23      1,16,123,125,333

Fa0/24      1,16,123,125,333

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/23      1

Fa0/24      1,16,123,125,333

It prunes traffic to 3550-III but it doesn't prune towards 3550-II. The port is blocked by 3550-II. Also here's this output:

3550-I#show interfaces pruning

Port                Vlans pruned for lack of request by neighbor

Fa0/23              16,123,125,333

Fa0/24              none

Port                Vlan traffic requested of neighbor

Fa0/23              1,16,123,125,333

Fa0/24              1,16

Why this switch is requesting all the VLANS from link Fa0/23 which points to 3550-II. There are no access ports on neither of the vlans listed:

3550-I#show vlan brief

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15

                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20, Fa0/21, Fa0/22, Gi0/1, Gi0/2

16   Management                       active   

123  Decomar                          active   

125  VLAN0125                         active   

333  dummy-vlan                       active   

1002 fddi-default                     act/unsup

1003 trcrf-default                    act/unsup

1004 fddinet-default                  act/unsup

1005 trbrf-default                    act/unsup

3926
Views
9
Helpful
10
Replies
CreatePlease to create content