Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VTPv2 Transparent Mode - Not forwarding VTP packets in different Domain

Hi All,

I'm doing some testing in the Lab and have 3 x 3750's daisy chained together running VTP, with 802.1q trunks hardcoded.

SW1 <--> SW2 <--> SW3

SW1 and SW3 are in VTPv1 domain A and are both in 'Server Mode'. However, SW2 is in VTPv2 domain B and in Transparent mode.

According to the Cisco Doc VTP Version 2 (SW2) supports only one domain, and it forwards VTP messages in transparent mode without inspecting the version and domain name.

However, I am not seeing this happen. When I increment the revision number on SW1, I am not seeing the VTP updates propagate to SW3, and vice-versa.

Has anyone experienced this behavior? Any suggestions?

Thanks in advanced.

Mario.

6 REPLIES

Re: VTPv2 Transparent Mode - Not forwarding VTP packets in diffe

Hi

Unfortunately this not going to happen,u need to have the transparent switch in the same domain then it will forward the VTP messages.

Thanks

Mahmood

New Member

Re: VTPv2 Transparent Mode - Not forwarding VTP packets in diffe

Hi Mahmood,

Thats interesting... despite what the doc CD says about v2 Transparent mode, this will not work.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_44_se/configuration/guide/swvtp.html#wp1035121

So basically the doc CD is incorrect?

Thanks.

Regards,

Mario.

Re: VTPv2 Transparent Mode - Not forwarding VTP packets in diffe

Yes it does support but only in VTP v2. Check the version of VTP you are running.

Check "VTP version2 mode" in "sh vtp status".

New Member

Re: VTPv2 Transparent Mode - Not forwarding VTP packets in diffe

Hi bvsnarayana03,

Yes SW2 is already in VTP v2 Transparent mode, and is not passing VTP messages from SW1 and SW3 on. SW1 and SW3 are in a different VTP domain.

Thanks.

Mario.

Re: VTPv2 Transparent Mode - Not forwarding VTP packets in diffe

I'm referring you to another link on similar discussion. Here it was tested & confirmed that things work as mentioned in doc.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN,%20Switching%20and%20Routing&CommCmd=MB?cmd=display_location&location=.2cbe7b75

New Member

Re: VTPv2 Transparent Mode - Not forwarding VTP packets in diffe

Hi bvsnarayana03,

Thanks for the information.

However, I still have the issue. SW2 has VTPv2 mode enabled as per 'show vtp status'. When I change the VTP domain on SW2 to A (same as SW1 and SW3), and then increase the revision number on SW1, I immediately see VTP messages propagate to SW3. I am not seeing this behavior though when SW2 is in a different domain.

As for the link you referred me too... very interesting... Unless this issue is hardware/software depended? I tried the same setup with 3560's and still get the same result.

When I get access to the lab next week, I will span the trunk port from SW2 --> SW3 and see if VTP messages are being passed on. I'll let you know how that goes.

Thanks for your help.

Regards,

Mario.

185
Views
0
Helpful
6
Replies