Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VWIC3 - 4MFT-T1/E1

I need to configure a Cisco 2911. I need to give an interface in this module (VWIC3 - 4MFT-T1/E1) an IP address. My question is, does anyone know how to assign an IP to an interface in this module.

My purpose is to get connectivity via T1 line to another router.

Ashley

Everyone's tags (4)
16 REPLIES
Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

I do not have experience with that particular card. But I have configured what I believe are similar cards on 2900 routers. The process is like this:

- use the card type command to define whether the card is to operate in T1 or E1 mode.

- this will create serial controller entries in the configuration.

- under the serial controller configure channel-group and time slots.

- this will create serial interfaces.

- under the serial interfaces configure the IP addresses as is usually done.

HTH

Rick

New Member

VWIC3 - 4MFT-T1/E1

Alright, I'll try that. Thank you.

Cheers

New Member

VWIC3 - 4MFT-T1/E1

Rick,

I was able to issue the card type command. I'm kind of  blurry on understanding the Serial Controller, as in, not sure how to  properly configure. I did the channel group (by chosing an ambiguous  number..) and the time. But, I'm not sure how to get into the serial  interfaces. Perhaps I did something wrong here, but I couldn't get into  conf -> se0/0/0 for example.

Either way, thank you very much for your input, it got me a lot further than yesterday!

Regards,

Ashley

Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

I am glad that my suggestions were helpful to you. Perhaps we can resolve a bit more of the issue. A start would be for you to tell us what you configured under the controller. In configuring the channel-group you give it a number, and that number will show up in the serial interface number. So if we knew what you used for the channel group number it might be easier to get to the serial interfaces. Also in configuring the channel-group you define time slots. Typically you would use all of the available time slots, and the number of available time slots depends on whether you are operating as T1 or as E1.

If you are not sure what the serial interface identifiers are then I would suggest that the easy way is to just do a show run and look through the configuration to find interface serial.

HTH

Rick

New Member

Re: VWIC3 - 4MFT-T1/E1

Rick,

Here is the config from yesterday:

Router(config)#controller ?

T1  T1 controller

Router(config)#controller t?

T1

Router(config)#controller t1 ?

<0-0>  Controller slot number

Router(config)#controller t1 0/0/0

Router(config-controller)#?

Controller configuration commands:

bert           Start BERT test

cablelength    Specify the cable length for a DS1 link

cas-custom     cas group customization configuration

channel-group  Specify the timeslots to channel-group mapping for an

             interface

clock          Specify the clock source for a DS1 link

crc-threshold  Specify how many CRC errors per second to be treated as

             severely errored second (SES)

default        Set a command to its defaults

description    Controller specific description

ds0            ds0 commands

ds0-group      Replacement of cas-group. Configure group of timeslots to a

             particular signaling type

exit           Exit from controller configuration mode

fdl            Specify the FDL standard for a DS1 data link

framing        Specify the type of Framing on a DS1 link

guard-timer    Guard timer (0-20) for xcsp calls - timer duration and

             accept/reject on expiry

help           Description of the interactive help system

linecode       Specify the line encoding method for a DS1 link

loopback       Put the entire T1 line into loopback

mode           Configure the controller mode

Router(config-controller)#channel-group 0/0

                                     ^

% Invalid input detected at '^' marker.

Router(config-controller)#channel-group 23

% Incomplete command.

Router(config-controller)#channel-group 23 ?

timeslots  List of timeslots in the channel group

Router(config-controller)#channel-group 23 time

Router(config-controller)#channel-group 23 timeslots ?

<1-24>  List of timeslots which comprise the channel

Router(config-controller)#channel-group 23 timeslots 1 ?

speed  Specify the speed of the underlying DS0s

Router(config-controller)#channel-group 23 timeslots 1

Router(config-controller)#

Jul 26 17:35:19.871: %LINK-3-UPDOWN: Interface Serial0/0/0:23, changed state to                                                                              up

Jul 26 17:35:20.871: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0                                                                             :23, changed state to up

Jul 26 17:35:48.871: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0                                                                             :23, changed state to down

Router(config-controller)#channel-group 23 timeslots 1 ?

speed  Specify the speed of the underlying DS0s

Router(config-controller)#channel-group 23 timeslots 1 spe

Router(config-controller)#channel-group 23 timeslots 1 speed ?

56  56 Kb/s

64  64 Kb/s

Router(config-controller)#channel-group 23 timeslots 1 speed 64 ?

Router(config-controller)#channel-group 23 timeslots 1 speed 64

Router(config-controller)#exit

Router(config)#exit

Router#wr

------------I'm not sure what timeslots are, or if it matters what speed I set it to. Even the channel group, I just chose 23, wasn't sure where to get the number from.

I'm going to see if I can give the serial interfaces ip's today. Also, do you know if it matters if I set the clock source for this?----------

Ash

New Member

Re: VWIC3 - 4MFT-T1/E1

I was able to get in and configure the interfaces, but now I cannot ping :-(

Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

I believe that we are making progress

Did you notice that when you assigned the (single) time slot for channel group 23 that it created Interface Serial0/0/0:23? If you go into config mode and go to Interface Serial0/0/0:23 you should be able to configure an IP address for it.

Now let me explain a couple of thinsg so that we can get a more effective configuration.

- the choice of number for the channel group is pretty much an arbitrary number (within a range of numbers that IOS will accept). Within that range you are free to use whatever number you want - such as 23. One thing to be aware of is that whatever number you choose for the channel group that number will turn up as part of the interface name. So we generally are motivated to use simple and easy (usually pretty low) numbers.

- time slots are effectively the channels within the T1. (a T1 has 24 channels so you can specify 1 through 24). specifying time slots gives the ability to specify several things (and probably none of them apply to you). If you had gotten a partial T1, perhaps the provider is giving you a circuit with 576K, then you would configure the serial controller and specify that you were using just 8 channels.

Or specifying time slots gives you the ability to subdivide your serial circuit. Perhaps your headquarters has 3 remote branch offices and you want a partial T1 at each of the offices (which you could achieve with a multiplexer at headquarters. So you could configure channel group 1 with 8 channels, configure channel group 2 with 8 channels, and configure channel group 3 with 8 channels and then your T1 would effectively have 3 serial interfaces and would connect to each of the remote branch offices.

Since I assume that you have just a simple full rate T1 what you want to do is to configure a single channel group and to assign time slots 1-24 to it. (right now your serial interface has only 1 channel at 64K which is not what you really want).

- similarly the ability to specify speed would give you the ability to specify that you had a 56K circuit (if that were the case). You want to just take the default of 64K.

It may matter about configuring clock source. And the right answer depends on how the provider has provisioned the T1. My advice is first to ask the provider for their advice about clock source. A lot of T1s have clock provided by the provider and so clock source line is what you want. But sometimes the provider wants you to provide your own clock. So my advice is first do not configure clock source and see if the default works (it frequently does). If the circuit does not come up then you can try configuring clock source.

So go back to the configuration and assign all 24 channels to channel group 23. And then configure an IP address on Interface Serial0/0/0:23. It should work.

HTH

Rick

Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

If you can not ping then my first guess is that it is the issue about having only 1 64K channel. Change that and try again.

If you still can not ping then I would ask that you post the output of the commands

show interface

and

show cdp neighbor detail

HTH

Rick

New Member

Re: VWIC3 - 4MFT-T1/E1

Rick,

Thank you for this. I still cannot ping. I am not sure how to correctly use the show cdp neighbors detail command, but I did try a show cdp neighbors using int se0/0/0:23, and nothing returned.

Router#show interfaces se0/0/0:23

Serial0/0/0:23 is up, line protocol is down

  Hardware is DSX1

  Internet address is 192.168.50.3/24

  MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, crc 16, loopback not set

  Keepalive set (10 sec)

  Last input never, output 00:00:05, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1152 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     25 packets output, 1500 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

Thank you,

Ashley

Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

What you have posted includes some helpful information, especially with this line

Serial0/0/0:23 is up, line protocol is down

This tells us that the router sees that something is connected but that it is not working. There are several possibilities that might produce this symptom:

- have you corrected the issue to get all 24 channels included in the time slots for the serial controller?

- it might be because of problems with clocking on the serial interface.

- it might be because of a mismatch in encapsulation on the line. In ordering the line did the provider give you any information that talked about whether to use HDLS, or PPP, or Frame Relay, or anything else about the type of connection that it would be?

You might want to check with the provider about clock source.

Posting the output of show controller serial might provide some clues about the problem.

HTH

Rick

New Member

Re: VWIC3 - 4MFT-T1/E1

Router#show controllers serial 0/0/0:23

Interface Serial0/0/0:23

Hardware is HDLC32

HDLC32 resource allocated to this interface:

Slot 0, Vic_slot 0, Port 0

HDLC32: cmd_q_full 0, cmd_out_of_sync 0

CRC on 1, idle flags 1, frame inverted 0, clocking 1

Channel-group number 23, hdlc32 channel number 0, hdlc_info 0x2B1FC334

Channel-group bitfield 0xFFFFFF00, hdlc32 quad used 0xFFFFFF hdlc_channel_bitfield 0x1

Channel HW state: 2 tx_limited 1 mci_txcount 2 txring_limit 2

Tx Q len:0 idb throttled:FALSE input_throttled:0 input_qcount:0

Sof_Sof_Errs 0 No_Sof_Errs 0 hdlc_sync_errs 0 No Buf Err 0

thrtl_int_err 0 no_eof_fse_err 3 buf_len_err 0

idb->reset = 0x212217B0

Rx BD index 45 Rx BD Addr 0xEB3316C Rx BD Val 0x88800100

Tx Head index 98, Tx Tail index 98

TX Ring:

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

data_ptr: 0x00000000, descriptor: 0x00000000

(etc)...

I believe I was able to set a clock source, I have to go back in and check that info. Also I was wondering if the line proto is down error is because of a faulty t1 line I am using (it is not a real t1, it simulates a t1). I chose to set the encapsulation to hdlc on the 2911 and my other router.

Still can't ping but feel like we are moving forward.

Ashley

Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

In looking back through this thread I notice that your drawing shows the the T1 connects to some device that is not Cisco. If this is the case then choice of HDLC may be problematic. Cisco's implementation of HDLC has some vendor specific elements and Cisco's HDLC may not be interoperable with other vendor implementation of HDLC. When connecting to non Cisco equipment choice of PPP is usually better than HDLC. So one piece of advice would be to try PPP and see if it works better.

Another question is to verify that the timeslots on the controller are right. Perhaps you could post that part of the config?

I would also ask you to tell us more about the T1 connection. If it is not a real T1 can you tell us a bit more about what it is? Many people look at the connection, see RJ45 and try to use an Ethernet cable, or recognizing that a router to router connection might need to cross between transmit and recieve they use an Ethernet cross over. However a T1 crossover is significantly different from an Ethernet crossover. So what is your T1 connection using?

HTH

Rick

New Member

Re: VWIC3 - 4MFT-T1/E1

Alright. I will go back and re-configure the other device for ppp as well as the 2911. For the controller here is the output:

Router#sho run

Building configuration...

Current configuration : 1898 bytes

!

! Last configuration change at 17:03:06 UTC Mon Jul 30 2012

! NVRAM config last updated at 17:03:06 UTC Mon Jul 30 2012

! NVRAM config last updated at 17:03:06 UTC Mon Jul 30 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

card type t1 0 0

!

no aaa new-model

no network-clock-participate wic 0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

crypto pki token default removal timeout 0

!

!

license udi pid CISCO2911/K9 sn FGL162311MY

!

!

!

!

controller T1 0/0/0

clock source internal

cablelength short 110

channel-group 1 timeslots 1-24 speed 56

!

controller T1 0/0/1

cablelength long 0db

!

controller T1 0/0/2

cablelength long 0db

!

controller T1 0/0/3

cablelength long 0db

channel-group 11 timeslots 1-24

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

ip broadcast-address 0.0.0.0

!

interface GigabitEthernet0/0

no ip address

ip broadcast-address 0.0.0.0

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

ip broadcast-address 0.0.0.0

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

ip broadcast-address 0.0.0.0

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:1

description link to Loop-IP

ip address 192.168.50.3 255.255.255.0

ip broadcast-address 0.0.0.0

!

interface Serial0/0/3:11

ip address 192.168.50.5 255.255.255.0

ip broadcast-address 0.0.0.0

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Router#

Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

Thanks for posting the new version of the config. I do see a couple of things that you might want to change.

Unless there is a particular reason to reduce the capacity of the T1 I would suggest that you change this line

channel-group 1 timeslots 1-24 speed 56

into this

channel-group 1 timeslots 1-24 speed 64

Also I notice that you have two serial interfaces and that they both have IP addresses within the same subnet. While this is technically possible it is not a common configuration. Unless you really want both serial interfaces within the same subnet I would suggest that you give them IP addresses that are in different subnets.

Also I notice this line in both serial interface configs

ip broadcast-address 0.0.0.0

that is not normally specified and unless you have a specific reason to use it I would suggest removing this line from the config.

While I believe it will be good to make these changes I do not believe that any of them are important problems in your config. I believe that there is some other issue which is producing the line protocol down symptom.

HTH

Rick

New Member

Re: VWIC3 - 4MFT-T1/E1

Hi Rick,

I was finally able to ping. You were correct. The issue was that I was using HDLC on my 2911 and my 6610, but I had to be using CHDLC (Cisco HDLC) on my 6610, since it is not a ciso device. The second part of the issue was that I had the speeds set to mismatch. For example, I had configured the controller group timesots 1-24 speed to 64k on my 2911, and the 6610 by default was set to 56k.

I went back in and made those changes, and bazinga I was able to ping and my serial interface protocol remained up. (Unlike before when it kept changing up/down/up/down).

Thank you for your help!

Warm Regards,

Ashley

Hall of Fame Super Silver

VWIC3 - 4MFT-T1/E1

Ashley

I am glad that you got it worked out and that my suggestions were helpful in this. Thank you for posting to the thread, telling us that it is now working and telling us what you had to do to get it to work. Perhaps there is something in this that will help some other reader of the forum.

HTH

Rick

4972
Views
0
Helpful
16
Replies
CreatePlease login to create content