Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Wake on Lan (Catalyst 4500)

I am trying to setup the WOL for our enterprise. We have a C4500 setup with mutliple Vlans. We are using Microsoft SCCM server to wake up workstations for security update. The workstations are on vlan190 and the Microsoft server is on vlan 441

Here's my config

the config below

interface Vlan190
ip directed-broadcast 100 (Enables the translation of a directed broadcast to physical broadcasts)


access-list 100 remark ====== Wake-On-LAN ======
no access-list 100 permit udp host 10.4.40.98 any eq 9 log
access-list 100 remark ====== End of ACL 100 ======


ip forward-protocol udp 9 (Specifies the protocol and port to be forwarded)

interface Vlan441

ip address 10.4.40.2 255.255.252.0

standby ip 10.4.40.1

standby preempt delay minimum 2

Thanks

2 REPLIES
Hall of Fame Super Silver

Wake on Lan (Catalyst 4500)

It is not clear to me how your server is set up. Is it generating directed broadcast messages to the subnet of VLAN 190? Or is it generating local broadcasts and you need an ip helper address on VLAN 441 to forward to the directed  broadcast address of VLAN 190?

Also this line is creating part of your problem

no access-list 100 permit udp host 10.4.40.98 any eq 9 log

I assume that the no in the line was done while you were testing but it needs to be removed otherwise access list 100 only has remark statements.

HTH

Rick

New Member

Wake on Lan (Catalyst 4500)

I have recently setup this up on our network using SCCM to wake up the machines.  The only thing you seem to off missed off you config is the ip helper-address commands.

Presuming vlan 441 is the subnet your server is on.

interface Vlan441

ip address 10.4.40.2 255.255.252.0

ip helper-address (the broadcast address of the target network you wish to wake up)

standby ip 10.4.40.1

standby preempt delay minimum 2

interface Vlan190

ip directed-broadcast 100

ip helper-address 10.4.40.98 (which is the address of your server)

This setup has worked for me on our all Cisco network.

1590
Views
0
Helpful
2
Replies