Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Web authentication problems in 3750G

Hi everybody, 

I am having a strange behaviour with switches 3750G in web authentication. I have upgraded IOS  c3750-ipbasek9-mz.122-55.SE9, with device manager. I have configured ip http authentication to local and the ip http server status is: 

HTTP server status: Enabled

HTTP server port: 80

HTTP server authentication method: local

HTTP server access class: 10

HTTP server base path: flash:/c3750-ipbasek9-mz.122-55.SE9/html

HTTP server help root:

Maximum number of concurrent server connections allowed: 16

Server idle time-out: 180 seconds

Server life time-out: 180 seconds

Maximum number of requests allowed on a connection: 25

HTTP server active session modules: ALL

HTTP secure server capability: Present

HTTP secure server status: Enabled

HTTP secure server port: 443

HTTP secure server ciphersuite: 3des-ede-cbc-sha des-cbc-sha rc4-128-md5 rc4-128-sha

HTTP secure server client authentication: Enabled

HTTP secure server trustpoint:

HTTP secure server active session modules: ALL

 

Anyway when I try to access web to this switch, the message returned is: 

"The server xxxx is asking for your user name and password. The server reports that it is from level_15_or_view_access." 

And although I enter user/pwd with priv 15, it is asked again until three times, and then max number of tries is got and I don't get web access. It says "Unauthorized". 

If I leave http authentication as "enable", although a graphical interface (Device Manager one) is tried to be charged, it is not. I attach a file with the web output. 

I do not know what can be the cause of this error. Could you help me, please? I need to be sure anything is being forgotten. 

Thank you very much. 

2 REPLIES
New Member

I have the same exact problem

I have the same exact problem w/ same hardware.  Basically same server status output.  I can hit SSH correctly with my admin credentials with no issue, but it will not launch the web interface via HTTP or HTTPS correctly.

I have tried purposefully entering wrong credentials, and it will redirect me to a "forbidden" page if I do so.  Only correct credentials will cause it to repeatedly ask and never authenticate!

New Member

Hi Garrett, Yes, it is quite

Hi Garrett, 

Yes, it is quite strange and leaves you confused. Have you tried to enter with http authentication in mode enable? Please, could you try? The device manager appears correctly or it is not charged? 

I ask you this because in my case the device is attempted to be charged but finally it is not completely loaded. And I do not know if this is a SW problem, more than a permissions problem. 

Anyway the other problem is the main one: why does not authenticate a user "valid", with level 15? 

If you can do the test, tell me. 

Thank you! Could anybody help us if someone else read this post? 

332
Views
0
Helpful
2
Replies
CreatePlease login to create content