Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Weird problem with HSRP in 6509

subnet used 10.1.6.128/28

top 6509
interface Vlan61
description mail-voip vlan
ip address 10.1.6.131 255.255.255.240
no ip redirects
standby 61 ip 10.1.6.129
standby 61 timers 5 15
standby 61 priority 90
standby 61 preempt
standby 61 authentication dc26

bottom 6509
interface Vlan61
description mail-voip vlan
ip address 10.1.6.130 255.255.255.240
no ip redirects
standby 61 ip 10.1.6.129
standby 61 timers 5 15
standby 61 priority 80
standby 61 preempt
standby 61 authentication dc26


top# show standby
Vlan61 - Group 61
  Local state is Active, priority 90, may preempt
  Hellotime 5 sec, holdtime 15 sec
  Next hello sent in 2.866
  Virtual IP address is 10.1.6.129 configured
  Active router is local
  Standby router is 10.1.6.130 expires in 10.156
  Virtual mac address is 0000.0c07.ac3d
  Authentication text "dc26"
  1 state changes, last state change 24w2d
  IP redundancy name is "hsrp-Vl61-61" (default)

bottom#show standby
Vlan61 - Group 61
  Local state is Standby, priority 80, may preempt
  Hellotime 5 sec, holdtime 15 sec
  Next hello sent in 3.894
  Virtual IP address is 10.1.6.129 configured
  Active router is 10.1.6.131, priority 90 expires in 11.632
  Standby router is local
  Authentication text "dc26"
  7 state changes, last state change 24w0d
  IP redundancy name is "hsrp-Vl61-61" (default)

the problem (corrected): HSRP should be using 3 ip per subnet right? one for VIP and other two for top and bottom switch.
But in my scenario when i telent to 10.1.6.143, it point to top 6509.

is there something i am missing? thanks

5 REPLIES
VIP Super Bronze

Re: Weird problem with HSRP in 6509

can you provide "sh spanning-tree vlan 61" from both switches?

it may be that connection from the edge to your top 6509 is in blocking mode

also, you wrote:

when i telent to 10.1.143, it point to bottom 6509.

I don't see this IP in your config

HTH

Reza

New Member

Re: Weird problem with HSRP in 6509

yeah, i agree. it seems a typo that he put 10.1.143 (first it is not valid ip to begin with. ) so until he can clearify that we wont be able to help.

Silver

Re: Weird problem with HSRP in 6509

Hi

It may be a typo, but You telnet to 10.1.143. That is not a correct ip address.

I have seen unixhost treating a telnet such that as 10.1.0.143.

Also if it is 10.1.6.143 you telnet to, that is the broadcast address for the subnet.

/Mikael

New Member

Re: Weird problem with HSRP in 6509

ok i am attaching the telnet to 10.1.6.143 and i also issue show ip int br command. Thats the problem guys, i even did not see the ip address in the 6509

New Member

Re: Weird problem with HSRP in 6509

Got it, in HSRP , if we telnet to broadcast ip. i will point to active router.

Thanks Guys for all your inputs.

377
Views
0
Helpful
5
Replies