Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Weird Routing problem

Hi

I can't get my head round this problem.

I have an office (Site 2) connected via WAN conneciton from a switch in site 1. Both sites are running eigrp.

In site 2 when I do a sh ip ro 10.45.61.0 I get route not found. However if I do the same in site 1 on the switch I get:

sh ip ro 10.45.61.0

Routing entry for 10.45.61.0/24

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 10.44.99.254

Route metric is 0, traffic share count is 1

My eigrp config on both sites looks like this:

Site1:

router eigrp 100

passive-interface default

no passive-interface Vlan756

no passive-interface Vlan776

no passive-interface Vlan999

network 10.10.51.92 0.0.0.3

network 10.10.51.100 0.0.0.3

Site2:

router eigrp 100

passive-interface default

no passive-interface Vlan2

no passive-interface Vlan776

no passive-interface Vlan2080

no passive-interface Vlan2083

network 10.10.51.88 0.0.0.3

network 10.10.51.92 0.0.0.3

network 10.10.51.96 0.0.0.3

network 10.10.51.100 0.0.0.3

network 10.66.1.0 0.0.0.255

network 10.66.2.0 0.0.0.255

network 10.66.50.0 0.0.0.255

distribute-list bcn-eigrp-out out Vlan776

distribute-list bcn-eigrp-out out Vlan2080

distribute-list bcn-eigrp-out out Vlan2083

distribute-list bcn-eigrp-out out GigabitEthernet1/0/48

auto-summary

Any thoughts on why it's not propgating?

Thanks

Dan

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Weird Routing problem

you should add command "redistribute static" under router eigrp 100 at site 1 (or use a network statement). see:

http://supportwiki.cisco.com/ViewWiki/index.php/How_does_EIGRP_redistribute_a_static_route_to_an_interface%3F

hth

9 REPLIES

Re: Weird Routing problem

you should add command "redistribute static" under router eigrp 100 at site 1 (or use a network statement). see:

http://supportwiki.cisco.com/ViewWiki/index.php/How_does_EIGRP_redistribute_a_static_route_to_an_interface%3F

hth

New Member

Re: Weird Routing problem

Many thanks for that.

New Member

Re: Weird Routing problem

Hi

Following on from this when I run the following:

sh ip eigrp topology | i 10.45.61

P 10.45.61.0/24, 0 successors, FD is Inaccessible

I can't see why the route is inaccessible? Would anyone have an idea why that might be?

Thanks

Dan

New Member

Re: Weird Routing problem

Hi,

To add to the above can you please explain why the route isn't being propgated by eigrp. If the static route isn't being propagated why can't the eigrp route be propagated?

Thanks

Dan

Re: Weird Routing problem

hi

are you running another routing protocol other than eigrp at site 2?

also, do you have a metric setup on site 1 for the redistributed routes? see:

http://supportwiki.cisco.com/ViewWiki/index.php/Routes_are_not_redistributed_into_EIGRP

hth

andy

New Member

Re: Weird Routing problem

Hi

Thanks for the reply. No no other routing protocols at site2. To be honest site2 is relatively simple as it's just a small office. I've included the eigrp config in my first post.

Site 1 has a few static routes. Any thoughts?

Thanks

Dan

Re: Weird Routing problem

Hi Dan

did you add the "redistribute static" command under the eigrp process on site 1 - if so, did you specify the metric?

cheers

andy

New Member

Re: Weird Routing problem

Hi

Sorry, I may have confused people. I understand that I need to add that redestribute command in.

I've been reading in the last hour on the questions I have posed and have found the following:

"when the FD is inaccessible in the EIGRP topology table, the router is not using that EIGRP route in its routing table. Usually, the route is overridden by another routing protocol that has lower administrative distance."

This explains the FD question I had. My static route is being placed in the routing table of the switch instead of the eigrp route and so eigrp topology is showing my route as inaccessible.

My guess is if I remove the static route in the switch on site 1 the route will then propagated to site 2.

I'm going to do that in the next 10 minutes and I'll report back on what I find.

Thanks for your help.

Dan

New Member

Re: Weird Routing problem

Great,

That worked, eigrp is now propagating the route.

Thanks everyone.

272
Views
0
Helpful
9
Replies