Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Weird stack issue? Conflicting after re-number

So I have 2 switches in this 3750 stack.  The 12S was switch 2 (Master) and the other is switch 3 (member).  I'm getting ready to add another 12S to the picture. I wanted to make the current switch 2, switch 1.  So I renumbered it and rebooted it.  It now has 3 switches listed.  I haven't added the 2nd Fiber switch to the stack yet until I get this cleared up.  Check out what has happened below!  Notice the conflicting information between the running config and the sh int status command! 

I wanted switch 2 to be switch 1...it seems like half of it worked!  I don't know what to even do here!  I think I might renumber switch 1 back to switch 2 and make the new fiber 12s switch1.  Any idea why this didn't just make switch 2 into switch one and take the configuration with it?  I'm so confused with the conflicting info.

Admin-SW01#sh run

switch 1 provision ws-c3750g-12s

switch 2 provision ws-c3750g-12s

switch 3 provision ws-c3750-24p

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet2/0/1

description EX

switchport access vlan 225

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet2/0/2

description JP

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet2/0/3

description MRM

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

!

interface GigabitEthernet2/0/4

description MRM

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet2/0/5

description MRM-Mine

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet2/0/6

description MRM445

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet2/0/7

switchport access vlan 753

shutdown

spanning-tree portfast

!

interface GigabitEthernet2/0/8

switchport access vlan 753

shutdown

spanning-tree portfast

!

interface GigabitEthernet2/0/9

switchport access vlan 753

shutdown

spanning-tree portfast

!

interface GigabitEthernet2/0/10

switchport access vlan 753

shutdown

spanning-tree portfast

!

interface GigabitEthernet2/0/11

switchport access vlan 753

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

spanning-tree portfast

!

interface GigabitEthernet2/0/12

switchport access vlan 753

spanning-tree portfast

!

interface FastEthernet3/0/1

description

switchport access vlan 753

shutdown

spanning-tree portfast

!

interface FastEthernet3/0/2

description

switchport access vlan 753

switchport mode access

spanning-tree portfast

ETC to port 3/0/24

MRM-Admin-SW01#sh switch detail

Switch/Stack Mac Address : 001b.8f78.e680

                                           H/W   Current

Switch#  Role   Mac Address     Priority Version  State

----------------------------------------------------------

*1       Master 001b.8f78.e680     15     0       Ready

2       Member 0000.0000.0000     0      0       Provisioned

3       Member 001a.a2a0.b580     1      0       Ready

MRM-Admin-SW01#sh int status

Port      Name               Status       Vlan       Duplex  Speed Type

Gi1/0/1                      connected    1          a-full a-1000 1000BaseLX SFP

Gi1/0/2                      connected    trunk      a-full a-1000 1000BaseLX SFP

Gi1/0/3                      connected    trunk      a-half  a-100 100BaseFX SFP

Gi1/0/4                      notconnect   1            auto   auto 1000BaseLX SFP

Gi1/0/5                      connected    trunk      a-full a-1000 1000BaseLX SFP

Gi1/0/6                      connected    trunk      a-full a-1000 1000BaseLX SFP

Gi1/0/7                      notconnect   trunk        auto   auto 1000BaseSX SFP

Gi1/0/8                      notconnect   1            auto   auto Not Present

Gi1/0/9                      notconnect   1            auto   auto Not Present

Gi1/0/10                     notconnect   1            auto   auto Not Present

Gi1/0/11                     notconnect   1            auto   auto Not Present

Gi1/0/12                     notconnect   1            auto   auto Not Present

Fa3/0/1            disabled     753          auto   auto 10/100BaseTX

Fa3/0/2              Connect notconnect   753          auto   auto 10/100BaseTX

Fa3/0/3                   Connect notconnect   753          auto   auto 10/100BaseTX

Fa3/0/4                      disabled     753          auto   auto 10/100BaseTX

Fa3/0/5                      disabled     753          auto   auto 10/100BaseTX

Fa3/0/6                      disabled     753          auto   auto 10/100BaseTX

Fa3/0/7                      disabled     753          auto   auto 10/100BaseTX

Fa3/0/8                      disabled     753          auto   auto 10/100BaseTX

Fa3/0/9                      notconnect   811          auto   auto 10/100BaseTX

Fa3/0/10                     disabled     753          auto   auto 10/100BaseTX

Fa3/0/11                     disabled     753          auto   auto 10/100BaseTX

Fa3/0/12                     disabled     753          auto   auto 10/100BaseTX

Fa3/0/13                     notconnect   753          auto   auto 10/100BaseTX

Fa3/0/14                     disabled     753          auto   auto 10/100BaseTX

Fa3/0/15                     disabled     753          auto   auto 10/100BaseTX

Fa3/0/16                     disabled     753          auto   auto 10/100BaseTX

Fa3/0/17  Connection for Key connected    753        a-half  a-100 10/100BaseTX

Fa3/0/18  Connection for Key notconnect   753          auto   auto 10/100BaseTX

Fa3/0/19   notconnect   753          auto   auto 10/100BaseTX

Fa3/0/20                       notconnect   753          auto   auto 10/100BaseTX

Fa3/0/21                       connected    753        a-full  a-100 10/100BaseTX

Fa3/0/22                  notconnect   753          auto   auto 10/100BaseTX

Fa3/0/23                      notconnect   753          auto   auto 10/100BaseTX

Fa3/0/24                 connected    753        a-full  a-100 10/100BaseTX

Gi3/0/1                      notconnect   1            auto   auto Not Present

Gi3/0/2                      notconnect   1            auto   auto Not Present

MRM-Admin-SW01#

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Weird stack issue? Conflicting after re-number

That's because your switch 1 ( ex switch 2) has a flat config.
Before renumber an active switch you have to:
- copy running config of actual switch you want renumber
- paste the config on a notepad
- modify the pasted config renumbering ports with ghe new switch number (eg.

interface Ge 2/0/1
switchport mode access
switchport access vlan 100
spanning-tree portfast

will become
interface Ge 1/0/1
switchport mode access
switchport access vlan 100
spanning-tree portfast
etc)

copy the modified config from the notepad and paste it to switch terminal session in configuration mode.

That's all.

In this way you should have the switch 1 with the exact same configutation of ex switch 2

HTH

Regards

Carlo
Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
7 REPLIES

Re: Weird stack issue? Conflicting after re-number

Hi.
In your configuration didn't exist switch 1 and related configuration for this "modue"
So this behaviour is normal.
when you renumber a switch it doesn't take it's actual config with him.
If you want the same configuration you have first to provision the switch in desired stack position and copy the config of the switch you want renumber and applying to the new module renumbering ports.


HTH
Regards

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Weird stack issue? Conflicting after re-number

Ok so what should I do to fix this?  I want this to be consistant and I want what was switch 2 (now switch 1), to have it's configuration under switch 1 of the running config.

Re: Weird stack issue? Conflicting after re-number

Hi.
As I mentionetd you have to take switch 2 interface config and edit all port configuration with 1 (eg 2/0/1 to 1/0/1)


HTH

regards
Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Weird stack issue? Conflicting after re-number

Ok I can do that but how is my switch running properly?  If I look at my running config, my port 2/0/2 was a trunk with a description, etc. But if I look at the running config of 1/0/2 it doesn't have any of that.  I really don't get how it's working if I have to enter the configuration again.  How are my other switches connected to this..still working if I have to enter the commands again on a port?

The sh int status has the right info, that it's trunked but didn't carry over the descriptions etc.  Sorry, I just don't get this at all.  I don't know how they can have them being different.

Port 1/0/1-12 have no configuration on them, but somehow they are showing trunked, etc.  So my switchport that was 2/0/1 was on vlan225, now g1/0/1 is showing vlan1, so theoretically that device is connected but on the wrong vlan?  How are the trunks still up since they have no trunk configuration on the ports?

Re: Weird stack issue? Conflicting after re-number

That's because your switch 1 ( ex switch 2) has a flat config.
Before renumber an active switch you have to:
- copy running config of actual switch you want renumber
- paste the config on a notepad
- modify the pasted config renumbering ports with ghe new switch number (eg.

interface Ge 2/0/1
switchport mode access
switchport access vlan 100
spanning-tree portfast

will become
interface Ge 1/0/1
switchport mode access
switchport access vlan 100
spanning-tree portfast
etc)

copy the modified config from the notepad and paste it to switch terminal session in configuration mode.

That's all.

In this way you should have the switch 1 with the exact same configutation of ex switch 2

HTH

Regards

Carlo
Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
Hall of Fame Super Gold

Weird stack issue? Conflicting after re-number

I want this to be consistant and I want what was switch 2 (now switch 1), to have it's configuration under switch 1 of the running config.

1.  In switch 2, enter the command "switch 2 renumber 1".

2.  Don't reboot.  Enter the next stuff:  switch 1 provision ws-c3750g-12s

3.  Copy the interface configs of switch 2, edit it to change it all to switch 1.

NOTE:  If you want to renumber switch 3 to 2, do "switch 3 renumber 1" and POWER DOWN this switch.

4.  Save the config;

5.  Make sure you HAVE NOT POWERED UP the new switch;

6.  Reboot the switch 2.

New Member

Weird stack issue? Conflicting after re-number

Steps 1 and 2 are already done, that is what I did originnally.  I just thought it would take the config with it.  The thing that confused me what things were still working (trunk wise) on switch one, with no configuration, no trunk commands.  The other switches stayed up.  So I'm thankful for that.

I think I'm going to renumber switch 1, back to switch 2..it already has the config in place, then the new switch will be switch 1 and I will enter the new configuration for it..and mount it on top..probably make the master once it joins the stack.

301
Views
0
Helpful
7
Replies