Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

What happens when voice vlan command is added to a trunk port?

Is there anyone that knows or can test in a lab what would happen if a tech mistakingly added "switchport voice vlan XX" to a trunk port? I am try to do some RCA on an issue and this has been identified as a possible cause by one of my techs.

The config is Switch1------Switch2--------Switch3 Each interswitch connection is configured as a dot1q trunk with all vlans allowed. The link between switch2 and 3 is where switchport voice vlan 10 was added. Switch1 is a 3750 and 2/3 are 3560's.

Thank you in advance.

James

Everyone's tags (4)
8 REPLIES
Silver

Re: What happens when voice vlan command is added to a trunk por

Hi,

It should not affect a trunk port because the voice vlan is configured on an access port.

Please refer to the Catalyst 3560 configuration guide:

You should configure voice VLAN on switch access ports; voice VLAN is not supported on trunk ports. You can configure a voice VLAN only on Layer 2 ports.

Note  Voice VLAN is only supported on access ports and not on trunk ports, even though the configuration is allowed.

Andras

Hall of Fame Super Gold

Re: What happens when voice vlan command is added to a trunk por

If you have, for example, the line "switchport mode trunk" (and other associated trunk commands) and then you insert the "switchport access voice vlan" command, nothing happens because the port is on trunk mode.  The "switchport mode" dictates whether the port behaves as either an access or a trunk.

New Member

Re: What happens when voice vlan command is added to a trunk por

Hello,

One of my customer has a configuration which doesnt seem very "clean":

Vlan 1: DATA

VLan 10: Voice

the link between switch is:

interface GigabitEthernet0/8

description VERS LAN D-LINK

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 10

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

So my questions:

> what happens to vlan 1 ? Tagued or Untagued ?

> what happens to vlan 10 ? tagued ou Untagued ?

Thanks to you,

Regards

New Member

Re: What happens when voice vlan command is added to a trunk por

Hello,

just a little up for the question

Thanks,

Regards,

Hall of Fame Super Silver

Re: What happens when voice vlan command is added to a trunk por

Hello Gerald,

vlan 1 frames will be untagged as no command changes the native vlan settings

vlan 10 frames are tagged

you can check this with

show interface gi0/8 switchport  ( or show interface gi0/8 trunk if supported this is platform dependent)

the configuration is strange for the commands :

switchport access vlan 10

switchport voice vlan 10

I mean the first one should be :

switchport access vlan 1

however the port is set in trunk mode so they both are not effective

to be noted all existing Vlans are permitted on the trunk not only vlan 1 and vlan 10. This may be wanted or not

Hope to help

Giuseppe

New Member

Re: What happens when voice vlan command is added to a trunk por

Hello,

Thanks a lot for your reply,

"however the port is set in trunk mode so they both are not effective" > that's was I thought and explained me behaviors of ports.

I agree with you too:

switchport access vlan 10

switchport voice vlan 10

these commands are usefull,

I just wanted to know someone else point of view

Thanks to you,

Regards,

Hall of Fame Super Gold

Re: What happens when voice vlan command is added to a trunk por

Same here.  The two lines are totally useless because the port is configured as trunk. 

New Member

What happens when voice vlan command is added to a trunk port?

The configuration is strange, but it could be very usefull for my use case. I have to migrate from Nortel IP Phone to Cisco IP Phone.

The actual configuration is static (manually configurated on the Phone IP, voice VLAN). So if the

switchport voice vlan 10 would enable the CDP negotiation for Cisco IP Phone, it would allow me to share the same configuration on the switch.

Has someone already verified?

Thanks

Domenico

6023
Views
0
Helpful
8
Replies