Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

What is the best way to use the 'network' statement?

We use eigrp and have a public class-b network that we use. All total there are about 700 /25 subnets in our network. Here is the routing statement that we have in all our routers.:

router eigrp 1

network 169.88.0.0

no auto-summary

Now we want to add VoIP onto our network and we are going to address the IP phones in another network space - the 172.28.0.0 space.

So on a router that has an access-layer vlan which has an IP phone on it, we will have this network statement:

router eigrp 1

network 169.88.0.0

network 172.28.0.0

no auto-summary

eigrp stub connected summary

I was told that it is better to be more granular with the network statment to have only the connected subnets injected into the local routing table. So if there is only one VoIP subnet, say 172.28.3.0/25, I should have this router config:

router eigrp 1

network 169.88.0.0

network 172.28.3.0 0.0.0.127

no auto-summary

eigrp stub connected summary

1. Is there an advantage to being more granular with the 'network' statements?

2. And do I have the mask correct if indeed it is better to have the more granular network statment? The vlan interface pertaining to this subnet is:

int vlan 17

ip address 172.28.3.1 255.255.255.128

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: What is the best way to use the 'network' statement?

Jim

There are a couple of possible advantages in being more granular in the network statement. Whether it would be better for you depends on your environment and your requirements.

- if you want some subnet(s) within a given network included and some subnet(s) within that network not included then the more granular network statement (with the mask) is the way to go for sure.

- if you want some subnet(s) within a given network included in one EIGRP AS and some subnet(s) within that network included in a different EIGRP AS then the more granular network statement is the way to go.

I am not sure that either of those apply to what you have described. If you want all subnets present on a given router/switch to be included in EIGRP then the more general network statement (without mask) is easier and fewer statements to type into the config.

I also note that in the second example you have coded eigrp stub connected summary. That is quite different from the question of network statement. It is appropriate (and frequently helpful) on edge routers but not to be used everywhere.

HTH

Rick

4 REPLIES
Hall of Fame Super Gold

Re: What is the best way to use the 'network' statement?

Jim

There are a couple of possible advantages in being more granular in the network statement. Whether it would be better for you depends on your environment and your requirements.

- if you want some subnet(s) within a given network included and some subnet(s) within that network not included then the more granular network statement (with the mask) is the way to go for sure.

- if you want some subnet(s) within a given network included in one EIGRP AS and some subnet(s) within that network included in a different EIGRP AS then the more granular network statement is the way to go.

I am not sure that either of those apply to what you have described. If you want all subnets present on a given router/switch to be included in EIGRP then the more general network statement (without mask) is easier and fewer statements to type into the config.

I also note that in the second example you have coded eigrp stub connected summary. That is quite different from the question of network statement. It is appropriate (and frequently helpful) on edge routers but not to be used everywhere.

HTH

Rick

Hall of Fame Super Blue

Re: What is the best way to use the 'network' statement?

Hi Jim

The network statements under EIGRP as with other IGP's are not telling the routing protocol which networks to advertise out. It is telling the router on which interfaces to start EIGRP on.

Just for reference network statements under BGP do tell the routing protocol which networks to advertise out.

HTH

Jon

**Edit - after rereading your post and Rick's i think i may have interpreted injected to mean advertised - apologies if i misunderstood **

Hall of Fame Super Gold

Re: What is the best way to use the 'network' statement?

Jon

In terms of the overall post and the general question of whether there are advantages in more granular network statements I think that my response addresses it. But in looking at this specific sentence:

"more granular with the network statment to have only the connected subnets injected into the local routing table"

I believe that your interpretation of that sentence is correct. And you are spot on that the network statement tells EIGRP what interfaces to start on and does not tell what to advertise.

So both of our responses are appropriate for parts of the original post.

HTH

Rick

New Member

Re: What is the best way to use the 'network' statement?

Thanks to both of you for your responses.

I think I will just have 'network 172.28.0.0' on the specific routers since I'm not trying to be fancy about allowing certain routes in certain AS's.

Also you are right that I have stub routing only on my edge (access-layer) routers.

140
Views
4
Helpful
4
Replies
CreatePlease to create content