Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

What is Virtual Ethernet/IEEE 802.3 interface(1)

Hi All,

Can you please give info on Vitual interface 1 and Port-channel1 on 6500 Switch.

Thank you,

9 REPLIES
Hall of Fame Super Blue

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

Virtual Interface on a 6500 switch is a L3 vlan interface. So you should see in the running config

interface vlan 1

ip address x.x.x.x

A 6500 L3 switch can have many virtual interfaces.

A port-channel is the logical link that is formed from physical links in an etherchannel. So you have multiple physical links eg.

int gi0/1

channel-group 1 mode on

int gi0/2

channel-group 1 mode on

int gi0/3

channel-group 1 mode on

using the above command "channel-group 1 mode on" creates a port-channel 1 which is used to represent the physical interfaces. You can then add configuration to the port-channel interface and it gets applied to all physical interfaces.

Jon

New Member

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

Thank you Jon, so the virtual interface is basically for remote management and the port channel is for Etherchannel.

Do you see what are all the ports are formed etherchannel,

6513-01#show ip int brief | inc up

Vlan1 192.168.30.92 YES TFTP up up

GigabitEthernet1/1 unassigned YES unset up up

GigabitEthernet1/2 unassigned YES unset up up

FastEthernet3/1 unassigned YES unset up up

FastEthernet3/2 unassigned YES unset up up

FastEthernet3/4 unassigned YES unset up up

FastEthernet3/5 unassigned YES unset up up

FastEthernet3/6 unassigned YES unset up up

FastEthernet3/9 unassigned YES unset up up

FastEthernet3/10 unassigned YES unset up up

Port-channel1 unassigned YES unset up up

Thank you,

Hall of Fame Super Blue

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

"sh etherchannel summary" will show you which ports make up each etherchannel.

The virtual interface can be used for managing the switch and on L2 switches only you are only allowed to have one virtual interface up at any one time.

The 6500 switch is a L3 switch so it can route between vlans and so you can have many virtual interfaces on this type of switch.

Jon

New Member

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

Thank you Jon, the g1/1 and 1/2 used for etherchannel.

6513-01#show etherchannel summary

Flags: D - down P - bundled in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

M - not in use, minimum links not met

u - unsuitable for bundling

w - waiting to be aggregated

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) - Gi1/1(P) Gi1/2(P)

How to find out the other end of this etherchannel?

New Member

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

I do not find the neighbor device, is that mean not connected with any device.

6513-01#show cdp neighbors port-channel 1

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID

Hall of Fame Super Blue

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

You need to use the physical interfaces with cdp ie.

sh cdp neigh gi1/1 det

should give you the details of the attached device.

Jon

New Member

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

Thank you Jon,

6513-01#show cdp neigh gigabitEthernet 1/1 detail

6513-01#show cdp neigh gigabitEthernet 1/2 detail

No output for the command, does it means no device connected?

Hall of Fame Super Blue

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

Well the etherchannel is being shown as up so it could be that you are not running CDP between this switch and the device it is connected to. Do you know what the device is meant to be ?

Could you also post output of "sh run int gi1/1"

Jon

New Member

Re: What is Virtual Ethernet/IEEE 802.3 interface(1)

Hi Jon,

6513-01#show run interface gigabitEthernet 1/1

Building configuration...

Current configuration : 149 bytes

!

interface GigabitEthernet1/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

channel-group 1 mode on

end

The port is in trunk and uses 802.1q

Thank you,

635
Views
15
Helpful
9
Replies