Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

What vlan will a dumb switch be in?

Hi,

With a Cisco2821 router configured with subinterfaces, for example:

interface GigabitEthernet0/1

no nameif

no ip address

no shut

interface GigabitEthernet0/1.100
vlan 100
nameif sound
security-level 50
ip address 10.10.100.1 255.255.255.0
!
interface GigabitEthernet0/1.200

vlan 200
nameif light
security-level 50
ip address 10.10.200.1 255.255.255.0

!

If I connect port #1 of a D-Link unmanagable dumb switch to interface GigabitEthernet0/1 of the abovementioned router,

which vlan traffic will go thru port #1 of this switch? default vlan1, or vlan 100, or vlan 200? or all three vlans? Or can we control it and HOW?

Normally we would configure the port#1 of the switch (if it was managable) as a trunk, and let all three vlans thru. But in this case, the D-Link one is not managable.

Your knowledge sharing will be much appreciated.

Many thanks

Stro

5 REPLIES
Cisco Employee

Re: What vlan will a dumb switch be in?

Hello,

Since DLINK does not understand trunking or VLAN tagging, all traffic (from

all sub-interfaces) will go to the switch and all ports connected to the

dumb switch will see the packets. Only untagged packets (native vlan) will

be delivered to intended destination.

Hope this helps.

Regards,

NT

Re: What vlan will a dumb switch be in?

hi stro,

if its a dumb switch , normally its native vlan 1

try this , should work...

interface gi 0/1.1
encapsulation dot1Q 1 native
ip adddress...etcc

if there are multiple networks on dumb switch,  use ip addresss x.x.x.x secondary  on your above interface.

actually just thinking about it, you do not need a dot1q interface at all lol , just use gi 0/1 without sub-ints  and all is good.

Community Member

Re: What vlan will a dumb switch be in?

Hi Rob,

Thanks for your reply.

If I do:

interface GigabitEthernet0/1
nameif sound
security-level 50
ip address 10.10.100.1 255.255.255.0
ip address 10.10.200.1 255.255.255.0 secondary
!
and connect the D-Link to router interface GigabitEthernet0/1,
will end users in vlan 100 (ip 10.10.100.x/24 with gateway 10.10.100.1) connecting the D-Link, be able to get to internet?
will end users in vlan 200 (ip 10.10.200.x/24 with gateway 10.10.200.1) connecting the D-Link, be able to get to internet?
I doubt they will. Because they are not in the native vlan 1. As NT in previous post said, only the untagged native vlan packets will deliver to the end users.
The router is an edge router, and connects to internet.
Can you clarify please?
Stro
Community Member

Re: What vlan will a dumb switch be in?

Hi NT,

Thanks for your reply.

So if I want the end users connecting the D-Link switch, to be in vlan 100,

I don't need to have subinterface at all. I just need to make native vlan of

interface G0/1 as vlan 100:

interface GigabitEthernet0/1

encapsulation dot1Q 100 native

nameif sound

security-level 50

ip address 10.10.100.1 255.255.255.0

!

Am I right?

If I want some end users connecting the D-Link switch to be in vlan 100,

some to be in vlan 200, what should I do? Is it possible with this D-Link

switch?

In my original config with subinterfaces, I was trying to have both vlan 100

and 200 for the end users.

Thanks for your time.

Stro

On Sat, Sep 4, 2010 at 12:10 AM, nthanthr <

Re: What vlan will a dumb switch be in?

the problem you have is that the D-link is a dumb switch

there is no vlan segregation in it, so it makes no sense to have a dot1q interface and to do subints.....

your only solution here is  to go for ...

interface GigabitEthernet0/1
nameif sound
security-level 50
ip address 10.10.100.1 255.255.255.0
ip address 10.10.200.1 255.255.255.0 secondary
both sets of people on both of these networks will be able to access the internet -- enable dhcp on the router itself to make it easy.
I garantee 100000 million percent it will work
a router interface with no subints is essentially a pipe into the native vlan of any switch, because there is no tagging
Im not sure about the vlan capability of a Dlink switch unfortunately, but the solution above should work , only caveat is that there is no security between the 2 networks  and broadcasts are not segregated, depends whether you need this up and running fast.
1213
Views
0
Helpful
5
Replies
CreatePlease to create content