Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Whats this port channel error

Hi,

I have seen this in device logs

extende: %EC-SP-5-CANNOT_BUNDLE2: Gi2/6 is not compatible with Po5 and will be suspended (vlan mask is different)
extende: %EC-SP-5-CANNOT_BUNDLE2: Gi2/7 is not compatible with Po5 and will be suspended (vlan mask is different)
extende: %EC-SP-5-CANNOT_BUNDLE2: Gi3/7 is not compatible with Po5 and will be suspended (vlan mask is different)
extende: %EC-SP-5-CANNOT_BUNDLE2: Gi3/8 is not compatible with Po5 and will be suspended (vlan mask is different)
extende: %EC-SP-5-CANNOT_BUNDLE2: Gi4/7 is not compatible with Po5 and will be suspended (vlan mask is different)
extende: %EC-SP-5-CANNOT_BUNDLE2: Gi1/6 is not compatible with Po5 and will be suspended (vlan mask is different)
extende: %EC-SP-5-CANNOT_BUNDLE2: Gi1/7 is not compatible with Po5 and will be suspended (vlan mask is different)
extende: %EC-SP-5-CANNOT_BUNDLE2: Gi2/6 is not compatible with Po5 and will be suspended (vlan mask is different)

can someone explain what does this  mean right now port channel 5 has

5      Po5(SU)         PAgP      Gi1/6(P)   Gi1/7(P)   Gi2/6(P)   Gi2/7(P)
                                 Gi3/7(P)   Gi3/8(P)   Gi4/7(P)   Gi4/8(P)
many thanks

mahesh

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Whats this port channel error

Can you check the config's again on the port-channel and the physical interfaces ? 
Specifically the "allowed VLANs" 

If it is verified, can you remove the configuration by defaulting the interfaces and just add
the "allowed VLANS" line to the port-channel directly (without going into indvidual physical 
interfaces)

Cheers,
ARjun

13 REPLIES

Re: Whats this port channel error

hi mahesh

can you post the interface configs of the both the physical interface and the port channel interface? do post both end configs.

regds

New Member

Re: Whats this port channel error

Hi all,'

here is info

interface Port-channel5
description Port-Channel Connection to  G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
switchport mode trunk
no ip address

interface GigabitEthernet2/6
description Port Channel 5  Connection to  G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
switchport mode trunk
no ip address
udld port aggressive
channel-group 5 mode desirabl

New Member

Re: Whats this port channel error

I think you forgot to include some more ports.  Port-channels usually have more than 1 port assigned to them.  And each port can have different configurations which can and will cause problems.

Can you post all the configurations for all the ports in your port-channel?

New Member

Re: Whats this port channel error

Hi

here is info

interface GigabitEthernet2/6
description Port Channel 5  Connection to G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
switchport mode trunk
no ip address
udld port aggressive
channel-group 5 mode desirable
end


Current configuration : 290 bytes
!
interface GigabitEthernet3/7
description Port Channel 5 connection to  G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
no ip address
udld port aggressive
channel-group 5 mode desirable
end

Current configuration : 290 bytes
!
interface GigabitEthernet3/8
description Port Channel 5 connection to G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
no ip address
udld port aggressive
channel-group 5 mode desirable
end


interface GigabitEthernet1/6
description Port Channel 5 connection to G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
switchport mode trunk
no ip address
udld port aggressive
channel-group 5 mode desirable
end


interface GigabitEthernet1/7
description Port Channel 5 connection to  G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
switchport mode trunk
no ip address
udld port aggressive
channel-group 5 mode desirable
end

interface GigabitEthernet2/7
description Port Channel 5 connection to  G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
switchport mode trunk
no ip address
udld port aggressive
channel-group 5 mode desirable
end

interface GigabitEthernet4/7
description Port Channel 5 connection to G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
no ip address
udld port aggressive
channel-group 5 mode desirable
end

interface GigabitEthernet4/8
description Port Channel 5 connection to G1/6-7,G2/6-7,3/7-8,4/7-8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,70,76,77,287,800,1087
no ip address
udld port aggressive
channel-group 5 mode desirable
end


5      Po5(SU)         PAgP      Gi1/6(P)   Gi1/7(P)   Gi2/6(P)   Gi2/7(P)
                                 Gi3/7(P)   Gi3/8(P)   Gi4/7(P)   Gi4/8(P)

New Member

Re: Whats this port channel error

Is that all one switch?  If so that looks ok to me.

If that is one switch it would be helpful to see the other end of the channel as well.

New Member

Re: Whats this port channel error

Can you check the config's again on the port-channel and the physical interfaces ? 
Specifically the "allowed VLANs" 

If it is verified, can you remove the configuration by defaulting the interfaces and just add
the "allowed VLANS" line to the port-channel directly (without going into indvidual physical 
interfaces)

Cheers,
ARjun

New Member

Re: Whats this port channel error

Looks as though a vlan was allowed on a specific interface in the group and not to the channel itself?

New Member

Re: Whats this port channel error

hi,

i check and pasted the config .

vlan allowed are same

New Member

Found this in a critical

Found this in a critical moment during a Police Dept upgrade.  Solved my troubles.  Thank you all.

Re: Whats this port channel error

Hi mahesh,

The probable reason of this message is different set of vlans allowed in etherchannel and port bind to EC.

If you can post config then we can conclude the exact reason of this message.

Also I would like to have a look at below post with very healthy discussion

https://supportforums.cisco.com/thread/2001537.pdf;jsessionid=3A7FF62C515F7BF502B8B99F0DD3B5B6.node0

Regards

Mahesh

Re: Whats this port channel error

Hi mahesh,

I have tried the the same and after removing below command from interface i no longer receiving such log messages

"udld port aggressive"

Also please let me know

1- is this running EC

2- r u getting this message continously

2- you got this messages when you tried to add some more ports in existing etherchannel (because few etherchannel log message look like error but it is not really error...like when you add new port to etherchannel that port first goes to suspended mode for few sec. and generate error message)

Regards

Mahesh

Cisco Employee

Re: Whats this port channel error

Hi Mahesh,

The configuration of all member ports are not the same. You could "default interface xx" and then configure all of them with rage command to make sure they have identical configure as following,

default interface int Gx/x

interface range int Gx/x, Gx/x,...

Regards,

Jack

New Member

Re: Whats this port channel error

Hi all,

issue is fixed now.

logs just showed  error once.

i remove and add the port channel config and then the message came that all is ok.

thanks for help everyone

regards

mahesh

23716
Views
5
Helpful
13
Replies