Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Why 2 ospf process ids does not work on Single Router

Hi all,

On OSPF working router i have this config

Router 1

router ospf 1

with few network commands

Router 2 

I added the new  Router 2 to existing OSPF network and did this

router ospf 100 ******************

network  x.x.x.x

Router 1

router ospf 100 ***************************

network x.x.x.x

Now this is what i found

while using router ospf 100 i do not form any nei relationship.

Also i run the debug command on both routers and found that Router 1 and Router 2 do not send any hellos.

***********************************************************************************************************************************************************

If i use the router ospf 1 on R1 and new Router 2 ospf nei relationship works fine.

I need to know  on  single router can we use more than 1 process id?

why using router ospf 100 nei relationship does not establish and no packets are send?

Thanks

mahesh

2 ACCEPTED SOLUTIONS

Accepted Solutions

Why 2 ospf process ids does not work on Single Router

Hi Mahesh,

Please check the following link:

http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094e9e.shtml

It describes -among others- the requirements for peers to become ospf neighbors.

The subnet mask you have used will probabably not help.

regards,

Leo

Hall of Fame Super Silver

Why 2 ospf process ids does not work on Single Router

Mahesh

My appoligies - when I look more closely I realize that I was mistaken, caused by the formatting of the output. I was expecting to see router ospf starting from the left margin and this is not what was in the posted config

--More--         router ospf 100

So you are correct that OSPF is configured on both devices.

To understand the issue it might be helpful if you would post the output of show interface FastEthernet0/0 (or show ip ospf interface FastEthernet0/0) from host BB. It would also help if you would post the output of show ip ospf from both devices.

HTH

Rick

18 REPLIES

Why 2 ospf process ids does not work on Single Router

Hi Mahesh,

First of all: It is possible to run more than one ospf process on a router.

The process-id does not have any significance in determining whether neigbors are established or not.

The only relevant thing in that respect is that the processes must share a common subnet and must be in the same area.

A less well-known issue is that the prefixes cannot be overlapping between different processes and this is likely your problem. If you have:

router ospf 1

network 192.168.1.0 0.0.0.255

You cannot also have:

router ospf 100

network 192.168.1.0 0.0.0.255

This is because interfaces can only be in one ospf process/area.

When your config looked similar to this, deleting ospf process 1 would have triggered neighbor relations from process 100 with router2.

regards,

Leo

New Member

Why 2 ospf process ids does not work on Single Router

Hi Leo,

I had this config

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

area 1 virtual-link 1.1.1.1

area 4 stub no-summary

passive-interface Vlan20

network 192.168.4.0 0.0.0.255 area 1

network 192.168.5.0 0.0.0.255 area 0

network 192.168.8.0 0.0.0.255 area 4

network 192.168.20.0 0.0.0.255 area 0

Router ospf 100

network 192.168.50.0 0.0.0.255 area 10

is they overlapping in this case?

Thanks

New Member

Why 2 ospf process ids does not work on Single Router

Hi leo,

subnet i am using is 255.255.255.254 in the networks

Thanks

Mahesh

Why 2 ospf process ids does not work on Single Router

Hi Mahesh,

Please check the following link:

http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094e9e.shtml

It describes -among others- the requirements for peers to become ospf neighbors.

The subnet mask you have used will probabably not help.

regards,

Leo

New Member

Why 2 ospf process ids does not work on Single Router

Hi Leo,

I read the link which u sent.

I tried with different subnet mask like 255.255.255.0  its still same thing.

Thanks for the help

mahesh

Why 2 ospf process ids does not work on Single Router

The problem you have must be a basic issue. OSPF is very reliable in many releases.

It would help lot if you provided the config of BOTH routers.

regards,

Leo

New Member

Why 2 ospf process ids does not work on Single Router

Hi Leo,

i added the config of both routers under my first post.

Thanks  for help so far.

MAhesh

Hall of Fame Super Silver

Why 2 ospf process ids does not work on Single Router

Mahesh

I have looked at the configs that you have posted. When I look in the config of router BB I see EIGRP configured but I do not see OSPF configured. If OSPF is not confitgured then there can be no OSPF neighbors.

HTH

Rick

New Member

Why 2 ospf process ids does not work on Single Router

Hi Rick,

Thanks for reply

There is OSPF  config present on BB  Router

router ospf 100

log-adjacency-changes

network 192.168.50.0 0.0.0.255 area 10.

Mahesh

Hall of Fame Super Silver

Why 2 ospf process ids does not work on Single Router

Mahesh

My appoligies - when I look more closely I realize that I was mistaken, caused by the formatting of the output. I was expecting to see router ospf starting from the left margin and this is not what was in the posted config

--More--         router ospf 100

So you are correct that OSPF is configured on both devices.

To understand the issue it might be helpful if you would post the output of show interface FastEthernet0/0 (or show ip ospf interface FastEthernet0/0) from host BB. It would also help if you would post the output of show ip ospf from both devices.

HTH

Rick

New Member

Why 2 ospf process ids does not work on Single Router

Hi Rick,

Thanks for reply.

Strange here is what i did  earlier --

I config the network 192.168.50.0 0.0.0.255 area 10 under both  3550 and BB  Routers so that OSPF can work..

Now i config them under router ospf 100    on both routers and it started to work.

I am totally surprised how it is working now!!!?

3550

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

area 1 virtual-link 1.1.1.1

area 4 stub no-summary

passive-interface Vlan20

network 192.168.4.0 0.0.0.255 area 1

network 192.168.5.0 0.0.0.255 area 0

network 192.168.8.0 0.0.0.255 area 4

network 192.168.20.0 0.0.0.255 area 0

!

router ospf 100

log-adjacency-changes

network 192.168.50.0 0.0.0.255 area 10************************

3550SMIA# sh ip ospf
Routing Process "ospf 100" with ID 192.168.50.3
Start time: 2d01h, Time elapsed: 00:19:28.352
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 1. Checksum Sum 0x009838
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
    Area 10**********************************************************************************
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:05:13.176 ago
        SPF algorithm executed 5 times
        Area ranges are
        Number of LSA 24. Checksum Sum 0x146454
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Routing Process "ospf 1" with ID 3.3.3.3
Start time: 00:00:43.528, Time elapsed: 2d02h
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 1. Checksum Sum 0x02DFD8
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 3. 2 normal 1 stub 0 nssa
Number of areas transit capable is 1
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm last executed 00:13:56.532 ago
        SPF algorithm executed 6 times
        Area ranges are
        Number of LSA 26. Checksum Sum 0x29606B
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 7
        Flood list length 0
    Area 1
        Number of interfaces in this area is 1
        This area has transit capability: Virtual Link Endpoint
        Area has no authentication
        SPF algorithm last executed 00:13:56.536 ago
        SPF algorithm executed 6 times
        Area ranges are
        Number of LSA 19. Checksum Sum 0x101BEC
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 4
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
          generates stub default route with cost 1
        Area has no authentication
        SPF algorithm last executed 00:14:38.436 ago
        SPF algorithm executed 2 times
        Area ranges are
        Number of LSA 22. Checksum Sum 0x396ABA
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

BB  Router

BB#sh ip ospf int fa0/0

FastEthernet0/0 is up, line protocol is up

  Internet Address 192.168.50.2/31, Area 10

  Process ID 100, Router ID 172.30.8.1, Network Type BROADCAST, Cost: 1

  Transmit Delay is 1 sec, State BDR, Priority 1

  Designated Router (ID) 192.168.50.3, Interface address 192.168.50.3

  Backup Designated router (ID) 172.30.8.1, Interface address 192.168.50.2

  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    oob-resync timeout 40

    Hello due in 00:00:01

  Supports Link-local Signaling (LLS)

  Index 1/1, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 1, maximum is 2

  Last flood scan time is 0 msec, maximum is 0 msec

  Neighbor Count is 1, Adjacent neighbor count is 1

    Adjacent with neighbor 192.168.50.3  (Designated Router)

  Suppress hello for 0 neighbor(s)

BB#

BB#sh int fa0/0

FastEthernet0/0 is up, line protocol is up

  Hardware is AmdFE, address is 0007.eb7d.eca0 (bia 0007.eb7d.eca0)

  Internet address is 192.168.50.2/31

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:06, output 00:00:05, output hang never

  Last clearing of "show interface" counters 01:46:31

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     1335 packets input, 167152 bytes

     Received 782 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     2253 packets output, 201658 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

BB#sh ip ospf

Routing Process "ospf 100" with ID 172.30.8.1

Start time: 2d01h, Time elapsed: 00:08:05.360

Supports only single TOS(TOS0) routes

Supports opaque LSA

Supports Link-local Signaling (LLS)

Supports area transit capability

Router is not originating router-LSAs with maximum metric

Initial SPF schedule delay 5000 msecs

Minimum hold time between two consecutive SPFs 10000 msecs

Maximum wait time between two consecutive SPFs 10000 msecs

Incremental-SPF disabled

Minimum LSA interval 5 secs

Minimum LSA arrival 1000 msecs

LSA group pacing timer 240 secs

Interface flood pacing timer 33 msecs

Retransmission pacing timer 66 msecs

Number of external LSA 1. Checksum Sum 0x009838

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Number of areas transit capable is 0

External flood list length 0

    Area 10

        Number of interfaces in this area is 1

        Area has no authentication

        SPF algorithm last executed 00:07:16.913 ago

        SPF algorithm executed 1 times

        Area ranges are

        Number of LSA 24. Checksum Sum 0x15AA02

        Number of opaque link LSA 0. Checksum Sum 0x000000

        Number of DCbitless LSA 0

        Number of indication LSA 0

        Number of DoNotAge LSA 0

        Flood list length 0

BB#sh ip ospf int fa0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.50.2/31, Area 10
  Process ID 100, Router ID 172.30.8.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 192.168.50.3, Interface address 192.168.50.3
  Backup Designated router (ID) 172.30.8.1, Interface address 192.168.50.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.50.3  (Designated Router)
  Suppress hello for 0 neighbor(s)
BB#

BB#sh int fa0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0007.eb7d.eca0 (bia 0007.eb7d.eca0)
  Internet address is 192.168.50.2/31
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:06, output 00:00:05, output hang never
  Last clearing of "show interface" counters 01:46:31
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1335 packets input, 167152 bytes
     Received 782 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     2253 packets output, 201658 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
BB#sh ip ospf
Routing Process "ospf 100" with ID 172.30.8.1
Start time: 2d01h, Time elapsed: 00:08:05.360
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 1. Checksum Sum 0x009838
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
    Area 10
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:07:16.913 ago
        SPF algorithm executed 1 times
        Area ranges are
        Number of LSA 24. Checksum Sum 0x15AA02
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Above is required info as per you request.

I tried this many times since yesterday and router ospf 100  do not work but now suddenly it worked.

i also did clear ip ospf process on both routers few times to make sure its not fluke.

but surprisingly  OSPF is working between these 2 routers now.

Regards

MAhesh

Why 2 ospf process ids does not work on Single Router

Mahesh,

Your original config actually has them configured under router ospf 100. so what have you done new?

BB Router

--More--         router ospf 100

log-adjacency-changes

network 192.168.50.0 0.0.0.255 area 10

!

3550

router ospf 100

log-adjacency-changes

network 192.168.50.0 0.0.0.255 area 10

Rgds,

Kishore

New Member

Why 2 ospf process ids does not work on Single Router

Hi Kishore,

I idid nothing new .

since yesterday OSPF was not working while using router ospf 100 on both routers

it works fine while using router ospf 1 on both routers.

Here is what i did

As it was working ok under router ospf 1  i did change to router ospf 100  to recreate the problem.

When i do this in past ospf never worked.

but this time ospf nei worked between these 2 routers.

Totally strange

Thanks

MAhesh

Why 2 ospf process ids does not work on Single Router

Mahesh,

interface FastEthernet0/13

no switchport

ip address 192.168.50.3 255.255.255.254     << please change this to .252 on both routers and test

HTH

Kishore

New Member

Why 2 ospf process ids does not work on Single Router

Hi Kishore,

Thanks for reply.

For some unknown reason it is started to work now,

Please read my last post.

Its working with 255.255.255.252 subnet mask.

Mahesh

Why 2 ospf process ids does not work on Single Router

This is what you should have :

Router 1

router ospf 100

log-adjacency-changes

network 192.168.50.0 0.0.0.3 area 10

interface FastEthernet0/0

ip address 192.168.50.2 255.255.255.252

ip ospf priority 100

duplex auto

speed auto

Router 2

router ospf 100

log-adjacency-changes

network 192.168.50.0 0.0.0.3 area 10

interface FastEthernet0/13

no switchport

ip address 192.168.50.3 255.255.255.252

ip ospf priority 150

Why 2 ospf process ids does not work on Single Router

mahesh18 wrote:

Hi Leo,

i added the config of both routers under my first post.

Thanks  for help so far.

MAhesh

Yeah,

network x.x.x.x

New Member

Why 2 ospf process ids does not work on Single Router

Hi Everyone,

Many thanks to eveyone for their help.

OSPF is working fine between two Routers.

Regards

MAhesh

2446
Views
0
Helpful
18
Replies
CreatePlease to create content