Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

why i cannot use MQC on Catatlyst 3750 or 3560 !!!!???

it's just a common qos configuration but it doesn't work, please see the detail below.

(but i use the same configuration on 2811,

it works well)

mls qos

!

class-map match-all IN_NGN_Mgt

match access-group name IN_NGN_Mgt

class-map match-all NGNSig_PSTN

match access-group name NGNSig_PSTN

!

!

policy-map test

policy-map mark-dscp

class NGNSig_PSTN

set dscp ef

class IN_NGN_Mgt

set dscp af21

class class-default

set dscp default

!

interface GigabitEthernet1/0/10

switchport access vlan 12

switchport mode access

switchport nonegotiate

service-policy input mark-dscp

speed 100

duplex full

!

interface Vlan12

ip address 192.168.4.126 255.255.255.128

!

ip access-list extended IN_NGN_Mgt

permit ip 192.168.6.0 0.0.0.255 any

permit ip 192.168.4.0 0.0.0.127 any

ip access-list extended NGNSig_PSTN

permit ip 192.168.5.0 0.0.0.127 any

permit ip 192.168.4.200 0.0.0.7 any

permit ip 192.168.4.128 0.0.0.15 any

!!!!!

lks_hwngn_02#sh policy-map int g1/0/10

GigabitEthernet1/0/10

Service-policy input: mark-dscp

Class-map: NGNSig_PSTN (match-all)

0 packets, 0 bytes

offered rate 0 bps, drop rate 0 bps

Match: access-group name NGNSig_PSTN

Class-map: IN_NGN_Mgt (match-all)

0 packets, 0 bytes

offered rate 0 bps, drop rate 0 bps

Match: access-group name IN_NGN_Mgt

Class-map: class-default (match-any)

0 packets, 0 bytes

offered rate 0 bps, drop rate 0 bps

Match: any

0 packets, 0 bytes

rate 0 bps

3 REPLIES
Super Bronze

Re: why i cannot use MQC on Catatlyst 3750 or 3560 !!!!???

A 3560/3750 is a L3 switch, not a router like the 2811. Many of the latter's features are not supported on former.

In this instance, the inbound marking policy might actually work athough the 3560/3750 won't show you the stats with a show policy. You'll need, I recall, to use some variation of, or something like, "show mls qos stats".

Re: why i cannot use MQC on Catatlyst 3750 or 3560 !!!!???

In additional to the good information from Joesph, although the interface command appears in the command line, it is in fact not supported.

Take a look at the 'show policy-map' with the command guide:-

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_44_se/command/reference/cli2.html#wp1948343

The command 'show mls qos interface statistics' will indicate both incoming and outgoing statistics for both CoS and DSCP.

Hope this helps.

Allan.

Pls rate helpful posts.

Community Member

Re: why i cannot use MQC on Catatlyst 3750 or 3560 !!!!???

Thank you so much for your reply.

I just wanna tell you that it's worked for vlan-base.

Anyway for MQC, there's nothing marked (af21).

Please see below for "show mls qos int stat"

GigabitEthernet1/0/10

dscp: incoming

-------------------------------

0 - 4 : 19988966 0 0 0 0

5 - 9 : 0 1 0 0 0

10 - 14 : 0 0 0 0 0

15 - 19 : 0 0 0 0 0

20 - 24 : 0 0 0 0 0

25 - 29 : 0 0 0 0 0

30 - 34 : 0 0 0 0 0

35 - 39 : 0 0 0 0 0

40 - 44 : 0 0 0 0 0

45 - 49 : 0 30 0 0 0

50 - 54 : 0 0 0 0 0

55 - 59 : 0 0 0 0 0

60 - 64 : 0 0 0 0

dscp: outgoing

-------------------------------

0 - 4 : 1324636 0 0 0 0

5 - 9 : 0 0 0 0 0

10 - 14 : 0 0 0 0 0

15 - 19 : 0 0 0 0 0

20 - 24 : 0 0 0 0 0

25 - 29 : 0 0 0 0 0

30 - 34 : 0 0 0 0 0

35 - 39 : 0 0 0 0 0

40 - 44 : 0 0 0 0 0

45 - 49 : 0 0 0 0 0

50 - 54 : 0 0 0 0 0

55 - 59 : 0 0 0 0 0

60 - 64 : 0 0 0 0

cos: incoming

-------------------------------

0 - 4 : 19996349 0 0 0 0

5 - 7 : 0 0 0

cos: outgoing

-------------------------------

0 - 4 : 1324797 0 0 0 0

5 - 7 : 0 0 89

Policer: Inprofile: 0 OutofProfile: 0

141
Views
3
Helpful
3
Replies
CreatePlease to create content