Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

why i cant access asa 8.4 thruogh asdm from outside interface ???

hi all ,

plz help e why i cant access asa asdm from outside interface

my puclic ip on outisde is :

x.x.55.34

i changed  portf of asdm to 65000 because i have portforward  ,

i tried to connect to my ip thriuogh asdm bu :

x.x.55.34

&

x.x.55.34:65000

but no luck ,

it succed if i try to connect locally

here is my sh run command :

====================================================

ASA5505#

ASA5505# sh run

: Saved

:

ASA Version 8.4(2)

!

hostname ASA5505

enable password qsddsEGCCSH encrypted

passwd 2KFsdsdbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

switchport access vlan 2

!

interface Vlan1

nameif ins

security-level 100

ip address 10.66.12.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 50

ip address x.x.55.34 255.255.255.248

!

boot system disk0:/asa842-k8.bin

ftp mode passive

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

object network obj_any

subnet 0.0.0.0 0.0.0.0

object network obj-0.0.0.0

host 0.0.0.0

object network localsubnet

subnet 10.66.12.0 255.255.255.0

description localsubnet

object network HTTP-Host

host 10.66.12.249

description web server

object network HTTPS-HOST

host 10.66.12.249

description Https

object network RDP-Host

host 10.66.12.122

description RDP host

object network citrix-host

host 10.66.12.249

description citrix

object service rdp

service tcp destination eq 3389

object service https

service tcp destination eq https

object service citrix

service tcp destination eq 2598

object service http

service tcp destination eq www

object network RDP1

host 10.66.12.249

object network HTTPS-Host

host 10.66.12.249

object network CITRIX-Host

host 10.66.12.249

object-group network RDP-REDIRECT

object-group network HTTP-REDIRECT

object-group network HTTPS-REDIRECT

object-group network CITRIX-ICA-HDX-REDIRECTION

object-group network CITRIX-ICA-SESSION-RELIABILITY-REDIRECTION

object-group service CITRIX-ICA-HDX

object-group service CITRIX-SR

object-group service RDP

object-group network MY-insideNET

network-object 10.66.12.0 255.255.255.0

access-list outside_in extended permit tcp any host 10.66.12.249 eq www

access-list outside_in extended permit tcp any host 10.66.12.249 eq https

access-list outside_in extended permit tcp any host 10.66.12.249 eq 2598

access-list outside_in extended permit tcp any host 10.66.12.122 eq 3389

access-list outside_in extended permit tcp any host 10.66.12.249 eq citrix-ica

access-list outside_in extended permit tcp any host x.x.55.34 eq 65000

access-list outside_in extended permit tcp any host x.x.55.34 eq https

access-list outside_in extended permit ip any any

pager lines 24

mtu ins 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-645.bin

no asdm history enable

arp timeout 14400

!

object network localsubnet

nat (ins,outside) dynamic interface

object network HTTP-Host

nat (ins,outside) static interface service tcp www www

object network RDP-Host

nat (ins,outside) static interface service tcp 3389 3389

object network HTTPS-Host

nat (ins,outside) static interface service tcp https https

object network CITRIX-Host

nat (ins,outside) static interface service tcp citrix-ica citrix-ica

access-group outside_in in interface outside

route outside 0.0.0.0 0.0.0.0 62.109.55.33 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

aaa authentication http console LOCAL

aaa authentication ssh console LOCAL

http server enable 65000

http 10.66.12.0 255.255.255.0 ins

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

telnet 0.0.0.0 0.0.0.0 outside

telnet timeout 5

ssh timeout 5

console timeout 0

management-access outside

dhcpd address 10.66.12.160-10.66.12.180 ins

dhcpd dns 212.112.166.22 212.112.166.18 interface ins

dhcpd enable ins

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

username test password P4ttSdddd3SV8TYp encrypted privilege 15

username ADMIN password 5dddd3ThngqY encrypted privilege 15

username drvirus password p03BtCddddryePSDf encrypted privilege 15

username cisco password edssdsdOAQcNEL encrypted privilege 15

!

!

prompt hostname context

call-home reporting anonymous

call-home

profile CiscoTAC-1

  no active

  destination address http https://tools.cisco.com/its/service/oddce/services/DD

CEService

  destination address email callhome@cisco.com

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly

  subscribe-to-alert-group configuration periodic monthly

  subscribe-to-alert-group telemetry periodic daily

Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e

: end

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

The "normal" way people usually do this is to set up a VPN connection and then after you connect with the VPN client you gain access to management inside.  Have you considered this as opposed to having the security headache of allowing such access from outside without requiring VPN?

9 REPLIES
New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

note that from web i can access tha page

http://x.x.55.34:65000

but when i lanuch the asdm it says connecting   and dont  connect ?

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

The "normal" way people usually do this is to set up a VPN connection and then after you connect with the VPN client you gain access to management inside.  Have you considered this as opposed to having the security headache of allowing such access from outside without requiring VPN?

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

the problem is , asa is remotely ,

and to access it and setup vpn

i need asdm console

and i cant reach asdm !!!!

i noted something

i cant reach no telnet no ssh

i just want to setup vpn , and after that i will definetly stop asa remotly configuration

plz  have a look above and tell me why t is not allowing me

regards

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

No ssh?  I wouldn't expect that to work unless you generate an RSA key pair (crypto key generate rsa modulus n) and https used by ASDM would need that also and you would need ssh 0.0.0.0 0.0.0.0 outside also.  You could just configure the VPN access via the command line or if you must use ASDM then access a system on the inside remotely (e.g. RDP, Windows Remote Assistance, Teamviewer, or VNC).

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

hi ,

i configured vpn

vpn is good ,

i can access 10.66.12x by vpn

but i still can access the asdm !!

i tried both

privta ip and publci ip of asa

with no luck

i tried with and with port 65000

can you guide me how trouble shoot this issue ??

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

For access over VPN you need:

management-access inside

and don't forget:

ssh inside

http inside

I'm guessing you forgot to grant ASDM (http/https) access to the IP addresses used by the VPN?  Can you SSH?  If not, that is your problem to solve first.

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

hi ,

plz look at image here

http://www7.0zz0.com/2014/01/24/17/237668023.png

i can access web  of asa

but cant lanuch the asdm

i did as u said ,

iput mangement inside

and added the vpn subnet to http allowed network

agian ,

can i monitors logs  and see the issue ?

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

New Member

why i cant access asa 8.4 thruogh asdm from outside interface ?

hi all ,

just want to infor you that there is no problem in my config

every thing above is correct ,

i just changed the pc with antoher pc and it worked !

it may be issue on my pc

i just posted so readers do have any conflict

again ,

config is fine

but it was issue from pc

thanks alot fot all who helped me

regards

282
Views
5
Helpful
9
Replies
CreatePlease to create content