Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

¿Why I need run ospf or another IGP, when I use iBGP reflector?

Hi

Maybe I don't understand iBGP, becouse I think that it's a IGP, like ospf, rip, and I know that evoid full mesh I can use router reflector, so I create an network with R1, R2 and R3, with R1 how router reflector and R2 -R3 how router reflector clients. but when I try to do ping from R2 to R3 don't work, and if I do sh ip route on R2/R3 they can't learn networks. I don't know what I'm wrong. ...why I need using ospf or rip or routing static for this work? I mean, I just want to use iBGP no more, not iBGP with another IGP.

R1---Router Reflector

en

conf t

hostname REFLECTOR

int fa1/0

no sw

ip add 192.168.0.253 255.255.255.252

no sh

exi

int fa1/1

no sw

ip add 192.168.1.253 255.255.255.252

no sh

exi

no router bgp 100

router bgp 100

no sync

exit

exit

R2---Router Cliente

en

conf t

hostname CLIENTE1

int fa1/0

no sw

ip add 192.168.0.254 255.255.255.252

no sh

exi

int loopback 1

ip add 192.168.0.1 255.255.255.128

no sh

exi

ip route 192.168.0.0 255.255.255.0 null0

router bgp 100

no sync

exit

exit

R3---Router Cliente

en

conf t

hostname CLIENTE2

int fa1/0

no sw

ip add 192.168.1.254 255.255.255.252

no sh

exi

int loopback 1

ip add 192.168.1.1 255.255.255.128

no sh

exi

ip route 192.168.1.0 255.255.255.0 null0

router bgp 100

no sync

exit

exit

thanks.

Everyone's tags (5)
4 REPLIES
VIP Super Bronze

¿Why I need run ospf or another IGP, when I use iBGP reflector?

Silver

Re: ¿Why I need run ospf or another IGP, when I use iBGP reflec

I dont see any neighbor or network statements under your BGP config? if you are going to use the loopback as your neighbour then you need to run an IGP routing protocol or use static route statemts between the the routers so that they will know about the loopback interface and also you need to use the next-hop self statement under your bgp config if you use the loopback as the neighbour address.

Siddhartha
New Member

¿Why I need run ospf or another IGP, when I use iBGP reflector?

sorry this is my configuration,  and don't work

R1---Router Reflector

en

conf t

hostname REFLECTOR

int fa1/0

no sw

ip add 192.168.0.253 255.255.255.252

no sh

exi

int fa1/1

no sw

ip add 192.168.1.253 255.255.255.252

no sh

exi

no router bgp 100

router bgp 100

no sync

neighbor 192.168.0.254 remote-as 100

neighbor 192.168.0.254 route-reflector

neighbor 192.168.1.254 remote-as 100

neighbor 192.168.1.254 router-reflector

exit

exit

R2---Router Cliente

en

conf t

hostname CLIENTE1

int fa1/0

no sw

ip add 192.168.0.254 255.255.255.252

no sh

exi

int loopback 1

ip add 192.168.0.1 255.255.255.128

no sh

exi

ip route 192.168.0.0 255.255.255.0 null0

router bgp 100

no sync

neighbor 192.168.0.253 remote-as 100

network 192.168.0.0 mask 255.255.255.0

exit

exit

R3---Router Cliente

en

conf t

hostname CLIENTE2

int fa1/0

no sw

ip add 192.168.1.254 255.255.255.252

no sh

exi

int loopback 1

ip add 192.168.1.1 255.255.255.128

no sh

exi

ip route 192.168.1.0 255.255.255.0 null0

router bgp 100

no sync

neighbor 192.168.1.253 remote-as 100

network 192.168.1.0 mask 255.255.255.0

exit

exit

Bronze

¿Why I need run ospf or another IGP, when I use iBGP reflector?

iBGP firstly is BGP "Internal" means - BGP inside AS, not "BGP instead IGP". It is designed for routers inside AS to talk BGP directly to each other without BGP to IGP redistribution. BGP as IGP is not a good choise because of it's very silent and slow nature.

BGP is an ip routing application that allows two routers (in theory) to exchange routes not being directly connected to each other. Therefore each route has an attribute NEXT HOP which equals to peer router's IP. For a router to use a route it must have that NEXT HOP address in it's routing table. Key thing: this attribute DOES NOT CHANGE during iBGP route exchange. It only changes in eBGP peering.

So R2 sends a route to R1 with NEXT HOP of 192.168.0.254. R1 sends this route to R3 with the same NEXT HOP. But R3 does not know how to reach the 192.168.0.254 address. Therefore it can't use this route.

You may use neighbor <...> next-hop-self command on R1 to override this behavior.

1207
Views
7
Helpful
4
Replies
CreatePlease login to create content