Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Why isn't my HSRP preemption working?

I've been playing around with a very basic HSRP Preempt configuration and I can't get my Standby switch to take over as the active. Here's the scenario:

Switch 1 is the Active, with Priority set at 105.

Switch 2 is the Standby, with Priority left at default (100). Preempt is configured on Switch 2.

When both switches are up and operational, the Standby group looks good. For example, when I do a show standby on Switch 1 I get the following:

Vlan100 - Group 1
  State is Active
    2 state changes, last state change 00:25:51
  Virtual IP address is 10.10.10.3
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.704 secs
  Preemption disabled
  Active router is local
  Standby router is 10.10.10.2, priority 100 (expires in 10.512 sec)
  Priority 105 (configured 105)
  Group name is "hsrp-Vl100-1" (default)

So if I power down Switch 1, the HSRP and the preemption that I configured on Switch 2 should cause it to take over as the Active switch, correct? But when I power down Switch 2 and then do a show standby on Switch 2, I only get the following:

Switch2#show standby
Vlan100 - Group 1
  State is Init (interface down)
    6 state changes, last state change 00:00:26
  Virtual IP address is 10.10.10.3
  Active virtual MAC address is unknown
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption enabled
  Active router is unknown
  Standby router is unknown
  Priority 100 (default 100)
  Group name is "hsrp-Vl100-1" (default)

Am I doing something wrong? Why does Switch 2 not take over as the Active switch? For your reference, here are the HSRP configs on both Switch 1 and Switch 2:

Switch 1:

interface Vlan100
 ip address 10.10.10.1 255.255.255.0
 standby 1 ip 10.10.10.3
 standby 1 priority 105

Switch 2:

interface Vlan100
 ip address 10.10.10.2 255.255.255.0
 no ip route-cache
 standby 1 ip 10.10.10.3
 standby 1 preempt

Any insight is appreciated, thanks.

 


 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

   Do you have at least one

   Do you have at least one interface in vlan 100 that is up and active on switch 2 when you power off switch one ?  The SVI will not stay up unless you do.

3 REPLIES
Purple

   Do you have at least one

   Do you have at least one interface in vlan 100 that is up and active on switch 2 when you power off switch one ?  The SVI will not stay up unless you do.

New Member

Yup, that did it! I should

Yup, that did it! I should have thought of that, really.

Thanks very much for the feedback.

HelloHow are the switches

Hello

How are the switches connected to either other - access port or trunked?

 

res

Paul

Please don't forget to rate any posts that have been helpful. Thanks.
141
Views
0
Helpful
3
Replies
CreatePlease login to create content