Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Why this BGP configuration didn't advertised routes?

hi,

I was trying to turn up our BGP session with a new provider as part of our transition to a whole nw infrastructure but after BGP session was Established, I reliased that no Prefixes have been advertised to our Peer or upstream provider!

here is my configuration, pls see if you can find any problems and advise acordingly:

router bgp xxxx

no synchronization

bgp log-neighbor-changes

network 198.x.144.0

network 216.x.192.0 mask 255.255.240.0

network 216.x.224.0 mask 255.255.224.0

network 216.x.224.0 mask 255.255.240.0

neighbor 216.x.125.241 remote-as xxxx

neighbor 216.x.125.241 prefix-list default in

neighbor 216.x.125.241 prefix-list secondblock out

no auto-summary

!

ip classless

!

no ip http server

!

!

ip prefix-list default seq 5 permit 0.0.0.0/0

!

ip prefix-list secondblock seq 10 permit 216.x.192.0/20

ip prefix-list secondblock seq 15 permit 216.x.224.0/19

I use EIGRP for iGP and when we stoped our current BGP session with the old provider to start using the new provider, I startwed seeingall those 216.x.x.x blocks (above in the network statemnet) coming to this border router as /24s.

that being said, BGP should know that it should advertise them in /20 and /19 but

i couldn't see any route or prefixes being advertised to our new provider, we though received the default routes from them but nothing out to them!!?

i tried to clear bgp soft in a soft out but made no difference.

Should the "NULL0" statemnet be also in the router configuration for BGP advertisement to work?

please advise.

Regards,

Mike

25 REPLIES

Re: Why this BGP configuration didn't advertised routes?

U need to have a route for the prefix u want to advertise, else BGP will not advertise it.

so you are correct in mentioning a null 0 static route as it would create a static route.

You are seeing /24 which you then summarize to your peering partner via network statement.

HTH

Sam

New Member

Re: Why this BGP configuration didn't advertised routes?

Sam,

can you please show me how?

I really apprecitae that as my time is very short for doing this.

Regards,

Masood

Re: Why this BGP configuration didn't advertised routes?

conf t

ip route 216.x.224.0 255.255.240.0 null 0

then verify this by doing sh ip bgp neighbor x.x.x.x advertise-routes and hopefully it wil be there.

HTH

Sam

New Member

Re: Why this BGP configuration didn't advertised routes?

Sam do I need one of these ip routes for each block thatwe have?

Do I need one for the BGP neighbore Ip address too ?

Thx,

Mike

Re: Why this BGP configuration didn't advertised routes?

yes u need it to match each network statement u have under BGP process.

no neighbor ip address is needed, just:

ip route subnet mask null0 (for the 3 prefixes).

I suggest you do one at the time to validate.

Sam

New Member

Re: Why this BGP configuration didn't advertised routes?

Thanks Sam, I will let you know the result if its OK with you. here is what I am going to add to my BGP cocnfiguration and I do the ame fo rour second provider in my yfirst router facing the second provider.

ip classless

ip route 216.x.192.0 255.255.240.0 null 0

ip route 216.x.224.0 255.255.240.0 null 0

ip route 216.x.224.0 255.255.224.0 null 0

Please advise.

Mike

Blue

Re: Why this BGP configuration didn't advertised routes?

Sam:

While using a static route pointing to null0 will work, isn't it a better approach to use a recursive static route in the event that the edge router loses connectivity to internal networks?

Just thinking out loud...

Thanks

Victor

Re: Why this BGP configuration didn't advertised routes?

Victor,

Nulled static route is just a "bate", once packets hits the peering router, you have to rely on longest from IGP for example.

And IGP would typically have redundant path.

the aim here, is to simply create an entry so BGP can advertise the summarized prefix. more specific entries will still be present.

I hope thsi clarifies it.

Sam

New Member

Re: Why this BGP configuration didn't advertised routes?

so,

these new ip route to Null0 must do the trick in my case?

here they are:

ip classless

ip route 216.x.192.0 255.255.240.0 null 0

ip route 216.x.224.0 255.255.240.0 null 0

ip route 216.x.224.0 255.255.224.0 null 0

Please advise.

Mike

Re: Why this BGP configuration didn't advertised routes?

yes !

New Member

Re: Why this BGP configuration didn't advertised routes?

Thanks very much. I will return to let you kno wthe result and also, rate the posting.

Regrads,

Mike

Cisco Employee

Re: Why this BGP configuration didn't advertised routes?

Masood,

I don't mean to rub it in but if you look at the response to your posting earlier last week, I had mention that you should have these routes in your routing table:

"Also, make sure you have routes, matching the network statements, that are installed in the RIB. "

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN%2C%20Switching%20and%20Routing&topicID=.ee71a04&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cc06535/0#selected_message

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Why this BGP configuration didn't advertised routes?

i don't see it like that at all. I must have flollowed the same posting but under pessure and datacenter down, people bagging, i kind of lost it altogether.

i fixed the netwoke statement when we spoke last but what happend is this:

Someone tripped over a wire and pulled my laptop, dropped it down form a 5 feet hight bench and machine broke. I lost all my data and configurations, then, two SUPS 720 went bad on these 6506s (they were purchased refurbished!) and I had to change the SUPS an dput new ocnfiguration on the routers, between all these incidents, the network statement and my IP routes to Null0 got lost!.

Last night, I had only 15 minutes to bring these circuits up and troublshoot as necessary given that I had to spend 5 hours troublshooting two crosse-connects just because they didn't want to invest andn buy SFps to use fiber. The media convertors form Fiber (single mode) to copper rj45 wasn't working and I had to fix those too.

so, I lost it altogether whe it came to trobleshooting the BGP. it was Established but no prefixes were geting advertised.

I still need to put these ip routes (Null0) staements and see if the problems go away.

I am sorry for not following the same posting.

(since, Masood was kind of difficult for many to pronounce, I have choosen Mike for my coworkers to call me, so, I am the same person!)

Regards,

Mike

Blue

Re: Why this BGP configuration didn't advertised routes?

Sam:

Thanks for the feedback.

I understand that the purpose of the null0 route is to place a route in the IP routing table so that BGP can advertise it. That BGP requirement has to be met...

What Im saying is that if the edge router loses connectivity to the internal network, there is no mechanism in place to keep BGP from advertising the unreachable networks and creating a blackhole. IOW, you want BGP to stop advertising the route if that network becomes unreachable. With a null0 route, the route will always be in the routing table...unconditionally.

Dont ge me wrong, Im not really advocating one method or the other. I was sort of thinking out loud and wanted your feedback, but I also wanted you to know exactly what my rationale is...

[EDIT] Im sorry, let me illustrate what Im saying. I refer to another metod, but never show it.

If the internal network is 135.10.1.0/24, a recursive static route to the effect of ip route 135.10.0.0 255.255.0.0 135.10.1.1 can be used to ensure that the route is both in the routing table, BUT also with the caveat that the edge router has connectivity to the internal network if its going to advertise it.[EDIT]

Thanks

Victor

New Member

Re: Why this BGP configuration didn't advertised routes?

Hi Victor,

Although, i screwed up in advertising out the blocks in BGP, but i welcome learning and there is no place better than this Froum!!

can both the Null 0 and the recursive static route co-exist?

in a sense one serve the idea of advertising routes for BGP and the other one, make BGP aware in the event the outer has lost connectivity to the rest of the network?

Since EIGRP has been used, there are various paths available to the border router but loss of connectivity can happen!

Please advise.

Regards,

Mike

Re: Why this BGP configuration didn't advertised routes?

Victor,

I see ur point and agree :-)

I never used this method in large ISPs as redundancy ensured your scenario never happens...or at least minimsed it.

If that happens.IMHO, Whether I stop advertising, or I blackhole is the same thing. at the end of the day the unreachable subnet will remain unreachable.

Why I preffer my suggestion ? well if peering partner uses BGP dampening I would not want to have penalties and wait even when IGP has converged.

Sam

Cisco Employee

Re: Why this BGP configuration didn't advertised routes?

Hi,

just a little suggestion, which might not be required in your case: I recommend to use floating statics to Null0:

ip route 216.x.192.0 255.255.240.0 null 0 250

ip route 216.x.224.0 255.255.240.0 null 0 250

ip route 216.x.224.0 255.255.224.0 null 0 250

which will only install the Null0 route in case the IGP does not advertise the routes required for BGP. In case the IGP ever advertises the whole address block due to aggregation, the statics will be removed and traffic follows the summary routes.

Regards, Martin

Blue

Re: Why this BGP configuration didn't advertised routes?

Samir:

Thank you, sir. As I said, I just wanted your thoughts on this matter, hence my question.

That having beeen resolved now, let me take advantage of the fact that I have the attention of two experts and pose this question to both you and Martin.

In Masood's case, BGP was not advertising the networks as expected because of the BGP synchronization rule. Why not simply disable synchronization? He is not acting as a transit AS, so is there a need for synchronization to be enabled in the first place?

Thanks

Victor

New Member

Re: Why this BGP configuration didn't advertised routes?

Here is what i don't understand and this may be due to my lack of experience on this.

the synchronization was off i.e.

no synchrpnization

why BGP needs the IP route network Null 0 statements in order to advertise netwroks?

Regads,

Masood

New Member

Re: Why this BGP configuration didn't advertised routes?

I just wanted to advertise my networks to the two upstream providers and receive partial routes form them. I did receive the partial routes but none of networks were advertised!

I really don't understand why BGP needs the ip route networs Null 0 statements?

in all the books i have read and examples I have seen, there never was any statement to say the BGP needs these statement . the "Null 0" to advertise routes outside to?

If you guys please help me understand this, then it will help me in future and will help many others on this Forum.

Regards,

Masood

Re: Why this BGP configuration didn't advertised routes?

You still need to have a an entry in routing table before BGP advertises the prefix.

I think this document will clarify things.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800945ff.shtml#topic4

HTH

Sam

Blue

Re: Why this BGP configuration didn't advertised routes?

Samir:

Thanks for that link. It cleared things up.

Victor

New Member

Re: Why this BGP configuration didn't advertised routes?

Thanks Sam,

One more thing that you guys may be able to help me with please.

1- Currently, our network goes out through one broder router and talks BGP to two different providers, one active and one back up.

2- inorder to test the new BGP, the one I am working on, we need to shut down the current BGP session over OC3 link to Savvis so that network blocks get to the two border routers (the new ones all in /24s).

3- I must know, if there is a way that i can tweak BGP (the current one to Savvis and UUnet) so I don't have to shut down the interface inorder to receive routes from my two core routers separated from me by dark Fiber IP transit (which is now lighted using MUXs)

can I keep the OC3 up except have all the network block routed to the border oruters so that I can turn up BGP to new providers?

We use EIGRP between the tw core routers 6506s in one site over to the border routers(2x6506s) in the other site and it works fine, as stated I could see all the blocks in /24s (one subnet /24 per VLAN in the datacenter on two 6509 switches connected to two core routers 6506s and then over to my two border routers).

I don't know if I was able to explain it in a way that make sense?

All I want to do, is to advertise routes through prefix-lists for my 4 network blocks which I scrwew it up not having the NUll 0 statements. now if I want to keep the other two OC3 up except have traffic move to my new border oruters over to the two new providers, what do I need to do?

can I use AS-PATH and repeat our AS# three or 4 times for the two current provider in one broder router so that that path is not preffered? and the new path be the new infrastructure as I have posted the BGP config for?

If it is easier to just turn off the current OC3 interfaces then I will do as they won't be used soon the two BGP sessions with the new providers come up.

I assume per these discussin, when I add the NUll0 statements, the our routes with get advertised by BGP to new providers?? and that is enough.

Please advise.

Regards,

Masood

Re: Why this BGP configuration didn't advertised routes?

if attributes have previously been untouched, I suggest that you use route AS path prepending outbound and inbound, to control primary and backup path.

Use route maps when advertising and when receiving.

If u are receiving a default route from backup, then it might be quicker to just admin down BGP on Primary (in service window).

HTH

Sam

New Member

Re: Why this BGP configuration didn't advertised routes?

I had synchroniozation disbaled in my BGP configuration and also I have the " no auto-Summary"

statement in my EIGRP configurations.

that being said, how else beside the Null 0 statement the BGP would have advertised my prefixes out to the providers?

Please advise,

Thx,

masood

330
Views
0
Helpful
25
Replies
CreatePlease to create content