Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Why Won't This Trunk Come Up

Hello, I'm trying to figure out wy this trunk won't come up between a Catalyst 2960 and a Catalyst 3524. I've even tried it between 2 3560s.

Switch A:

switchport mode trunk
switchport nonegotiate
speed 100
duplex full

Switch B:

duplex full
speed 100
switchport trunk encapsulation dot1q
switchport mode trunk

When I switch one side's parameters to auto, the link comes up. I'm just wondering why the link goes down when I manually set the parameters on each side, like speed and duplex.

18 REPLIES
New Member

Re: Why Won't This Trunk Come Up

what about the cable ? make sure the connection between switch is crossover cable.

New Member

Re: Why Won't This Trunk Come Up

I don't think it's the cable, because like I said, the trunk comes up when I leave the default port parameters, the link comes up.

When I set the speed on one end to auto and the speed on the other to 100Mbps, the link goes down.

When I set the duplex on one end to auto and the other to full, one switch complains that the other is in half-duplex, and when I change it to full, the link goes down.

I think I figured it out, though.

It seems like one side has to be auto, and the other has to have manual configuration of speed and duplex.

If I set bnoth sides to trunk, 100 Mbps, and full duplex, it doesn't work, I'm not sure why, maybe someone can answer this.

It looks like when I set one side to auto and the other to 100 Mbps it's telling me the port is experiencing errors now.

Anyone have a document on best practices for trunk ports?

Cisco Employee

Re: Why Won't This Trunk Come Up

Hi Nelson,

What you are experiencing is the auto-negotiation issue. I am sure which side is having the problem and it depends on the IOS being used. It might be some auto-neg bug hitting on the IOS. Either both sides have to be set to auto or hardcoded to speed/duplex on both the sides.Typically hardcoded on both the sides should work but it might be some IOS bug that you are hitting, which we need to investigate.

regards,

New Member

Re: Why Won't This Trunk Come Up

Hey, Amit, here's my config on both of the switches.

Switch A:

!
interface FastEthernet0/1
switchport mode trunk
switchport nonegotiate
speed 100
duplex full
end


Switch B:

!
interface FastEthernet0/1
duplex full
speed 100
switchport mode trunk
end

Shouldn't this work?

Shouldn't I be able to hard-code both sides instead having one side hard-coded and one side set to auto?

I tried this on two 3560s that are in my production environment because I noticed that the links were operating at 100Mbps when they should have operated at 1000Mbps. What I did was I hardcoded both sides to full duplex and 1000Mbps. I figured this would work, but instead, the trunk link went down and wouldn't come up until I set one side back to auto.

New Member

Re: Why Won't This Trunk Come Up

Also, let me add that I'm testing this between a 3524XL and a 2960 Catalyst switch.

The example I gave you of the two 3560s was what I first tried, and failed, so I switched to testing this scenario between the 3524 and 2960 so I don't disrupt my production network.

Hall of Fame Super Gold

Re: Why Won't This Trunk Come Up

Remove the duplex and speed settings.

New Member

Re: Why Won't This Trunk Come Up

I know it works when when I remove the speed and duplex settings.

My question is though, if you read my last 2 posts, is why doesn't it work when both sides are configured the exact same (Trunk, Speed, and Duplex)?

It only works when one side is Auto and the other side is Trunk

                                            Auto and the other side is speed 100

                                            Auto and the other side is duplex full

Or when both sides are auto

Why doesn't Trunk - Trunk

                    Speed 100 - Speed 100

                    Duplex Full - Duplex Full work?

Hall of Fame Super Gold

Re: Why Won't This Trunk Come Up

Do you mean the 3500XL and the 2950?  I worked with both and I can tell you the 3500XL is a different (dumb as a doorknob) beast!  "Auto" negotiation on the 3500XL is a joke.

New Member

Re: Why Won't This Trunk Come Up

Yes, I mean the 3500XL

In trying to setup a trunk between a 3500XL (Model 3524) and a 2960.

I don't think this is specific to the 3524 though as I stated before, it happens when I manually set the trunk parameters (Trunk, Speed, Duplex) between two 3560s, the trunk simply won't come up unless one side is auto, or both sides are auto.

New Member

Re: Why Won't This Trunk Come Up

If no one has an answer then that's ok, I was just curious.

It seems odd that if I set both sides to Trunk, Speed 100, and Duplex Full, the trunk doesn't come up. That's all.

Hall of Fame Super Blue

Re: Why Won't This Trunk Come Up

Nelson

What happens if you remove the trunk config and just leave the hardcoded speed and duplex ? Is the link up ?

Jon

New Member

Re: Why Won't This Trunk Come Up

Jon, I'll check this first thing in the morniung and keep you posted.

What does it mean if it does work? Doesn't?

New Member

Re: Why Won't This Trunk Come Up

Hey Jon, I tested it out and the trunk still doesn't come up.

Switch A: 2960

Speed 100

Duplex full

switchport mode dynamic auto

Switch B: 3524XL

Speed 100

Duplex full

switchport mode trunk

I even tried it with the trunk parameters off like you said and still no dice.

Will you answer this though. Shouldn't a trunk be able to be hardcoded on both sides with the same parameters and work?

Seems like these switches will only bring up a trunk link if it's auto/auto or auto/hardcoded, not hardcoded/hardcoded.

Hall of Fame Super Blue

Re: Why Won't This Trunk Come Up

Nelson

Will you answer this though. Shouldn't a trunk be able to be hardcoded on both sides with the same parameters and work?

From my experience yes you should be able to do this. The fact that even without the trunk config it still didn't work suggests as Amit said that is an auto-negotiation issue rather than a trunk issue.

The 3524XL is a very old switch now

Jon

New Member

Re: Why Won't This Trunk Come Up

I would also like to add that this config:

Switch A:

Speed auto

Duplex auto

Switchport mode dynamic auto

Switch B

Speed 100

Duplex Full

Switchport mode trunk

This config results in the 2960 staying in half duplex mode and it shoots out duplex mismatch errors.

Should I just dismiss this as a software error and move on?

New Member

Re: Why Won't This Trunk Come Up

Looks like it ONLY works when speed and duplex are auto, but manually set to trunk. That is all.

New Member

Re: Why Won't This Trunk Come Up

I've also come to realize that you can't do a vlan 100 command from global config on a 3524. You have to add through vlan database command.

I think I officially hate 3500XL switches.

The End.

Hall of Fame Super Gold

Re: Why Won't This Trunk Come Up

Like I said, the 2900XL/3500XL switches were considered as the "first generation" of switches.  The "auto" negotiation capabilities of this series is close to a joke.  And, yes, VLAN managment means you have to use the VLAN database.

2174
Views
0
Helpful
18
Replies
CreatePlease login to create content