Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

will get the crc errors due to using wan, lan in same switch (2950)

Dear Friends,

I have a wi-fi network setup

using devices are

1. cisco_,2950 to manage vlans,

2. pms server for billing and getting login page.

3. nomadix for gateway

this setup is in single rack only

My main switch (2950) having vlans 118, 109 and 40.

vlans 118, 109 are public vlans, which are comming from ISP and those are for direct internet.

and vlan 40 is local vlan to get the authentication page for intenet (40 local vlan)

every thing is working fine and

I am getting the crc error message in switch_2950's 17th and 20th ports,

17th port is connected to momadix lan port with patch card, allowed vlan is 40

20th port is connected to nomadix wan port with patch card, allowed vlan is 118

Note:-

Here i am using single switch cisco_2950 for wan (Vlans 109, 118) and lan (Vlan 40)

It means nomadix wan port is connected from cisco_2950's 20th (for wan) port and nomadix lan port is connected to again

Cisco_2950's 17th (for local) port. 

and for better understanding plz find the switch config and connectivity diagram

My suspect is I am using two networks (wan, local) for same switch, due to this reason these errors are comming?

User Access Verification

Password:

Password:

NVVB_MAINSWITCH_2950>en

Password:

NVVB_MAINSWITCH_2950#sh run

Building configuration...

Current configuration : 3407 bytes

!

! Last configuration change at 09:08:35 UTC Fri Jul 13 2012

! NVRAM config last updated at 12:25:08 UTC Fri Jun 29 2012

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

hostname NVVB_MAINSWITCH_2950

!

enable secret 5 xxxxxxxxxxxx

!

ip subnet-zero

!

no ip domain-lookup

vtp mode transparent

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

vlan 40,109,118

!

interface FastEthernet0/1

description # UP LINK TO LEVEL-0 #

switchport trunk allowed vlan 40,118

switchport mode trunk

!

interface FastEthernet0/2

description # UP LINK TO LEVEL-2 #

switchport trunk allowed vlan 40,118

switchport mode trunk

!

interface FastEthernet0/3

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/17

description ### CONNECTED TO NOMADIX LAN ###

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/18

switchport access vlan 118

switchport mode access

!

interface FastEthernet0/19

description ### CONNECTED TO PMS SERVER ###

switchport access vlan 118

switchport mode access

!

interface FastEthernet0/20

description ### CONNECTED TO NOMADIX WAN ###

switchport access vlan 118

switchport mode access

!

interface FastEthernet0/21

switchport access vlan 109

switchport mode access

!

interface FastEthernet0/22

description # CONNECTED TO ADMIN-I #

switchport access vlan 109

switchport mode access

!

interface FastEthernet0/23

description # CONNECTED TO ADMIN-II #

switchport access vlan 109

switchport mode access

!

interface FastEthernet0/24

description ### Vlan 109,118 - P2P connected to PRPuram BS ###

switchport trunk allowed vlan 109,118

switchport mode trunk

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 40,118

switchport mode trunk

!

interface GigabitEthernet0/2

description ### CONNECTED TO 3750 ###

switchport trunk allowed vlan 40,118

switchport mode trunk

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan109

ip address 115.x.x.x 255.255.255.240

no ip route-cache

!

ip default-gateway 115.x.x.x

ip http server

snmp-server community public RO

!

line con 0

line vty 0 4

password 7 1506080517260B3321353C

login

line vty 5 15

password 7xxxxxxxxx

login

!

!

end

NVVB_MAINSWITCH_2950#

Thanks & Regards, Srinivas. N.
Everyone's tags (7)
4 REPLIES
Hall of Fame Super Gold

will get the crc errors due to using wan, lan in same switch (29

Post the output to the commands:

1.  sh interface ; and

2.  sh controll e

New Member

will get the crc errors due to using wan, lan in same switch (29

Hi Leolaohoo,

Thanks for quic reply and i dont think problem with phycical layer,  is there any problem by using 2notwork in same switch, as i menctioned above.

NVVB_MAINSWITCH_2950#sh int f0/17

FastEthernet0/17 is up, line protocol is up (connected)

  Hardware is Fast Ethernet, address is 0012.0147.8991 (bia 0012.0147.8991)

  Description: ### CONNECTED TO NOMADIX LAN ###

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 100BaseTX

  input flow-control is unsupported output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:00, output hang never

  Last clearing of "show interface" counters 03:24:18

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 731000 bits/sec, 66 packets/sec

  5 minute output rate 39000 bits/sec, 46 packets/sec

     1538814 packets input, 1795079229 bytes, 0 no buffer

     Received 5 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     86 input errors, 86 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1123088 packets output, 172027332 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

NVVB_MAINSWITCH_2950#sh controllers e f0/17

  Transmit                                Receive

173014423 Bytes                       1812880179 Bytes

   1132242 Frames                         1552712 Frames

     18388 Multicast frames                    86 FCS errors

      7750 Broadcast frames                     0 Multicast frames

         0 Pause frames                         5 Broadcast frames

         0 Single defer frames                  0 Control frames

         0 Multiple defer frames                0 Pause frames

         0 1 collision frames                   0 Unknown opcode frames

         0 2-15 collisions                      0 Alignment errors

         0 Late collisions                      0 Length out of range

         0 Excessive collisions                 0 Symbol error frames

         0 Total collisions                     0 False carrier errors

         0 Control frames                       0 Valid frames, too small

         0 VLAN discard frames                  0 Valid frames, too large

         0 Too old frames                       0 Invalid frames, too small

         0 Tagged frames                        0 Invalid frames, too large

         0 Aborted Tx frames                    0 Discarded frames

  Transmit and Receive

    405097 Minimum size frames

    815073 65 to 127 byte frames

     95277 128 to 255 byte frames

     54063 256 to 511 byte frames

     45878 512 to 1023 byte frames

   1269566 1024 to 1518 byte frames

         0 1519 to 1522 byte frames

NVVB_MAINSWITCH_2950#

NVVB_MAINSWITCH_2950#sh int f0/20

FastEthernet0/20 is up, line protocol is up (connected)

  Hardware is Fast Ethernet, address is 0012.0147.8994 (bia 0012.0147.8994)

  Description: ### CONNECTED TO NOMADIX WAN ###

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 2/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 100BaseTX

  input flow-control is unsupported output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:01, output hang never

  Last clearing of "show interface" counters 03:26:32

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 61000 bits/sec, 62 packets/sec

  5 minute output rate 981000 bits/sec, 91 packets/sec

     1113631 packets input, 172645481 bytes, 0 no buffer

     Received 154 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     9 input errors, 9 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1577914 packets output, 1823525176 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

NVVB_MAINSWITCH_2950#

NVVB_MAINSWITCH_2950#sh controllers e f0/20

  Transmit                                Receive

1823388154 Bytes                        172433955 Bytes

   1577229 Frames                         1112999 Frames

      6520 Multicast frames                     9 FCS errors

       293 Broadcast frames                     0 Multicast frames

         0 Pause frames                       154 Broadcast frames

         0 Single defer frames                  0 Control frames

         0 Multiple defer frames                0 Pause frames

         0 1 collision frames                   0 Unknown opcode frames

         0 2-15 collisions                      0 Alignment errors

         0 Late collisions                      0 Length out of range

         0 Excessive collisions                 0 Symbol error frames

         0 Total collisions                     0 False carrier errors

         0 Control frames                       0 Valid frames, too small

         0 VLAN discard frames                  0 Valid frames, too large

         0 Too old frames                       0 Invalid frames, too small

         0 Tagged frames                        0 Invalid frames, too large

         0 Aborted Tx frames                    0 Discarded frames

  Transmit and Receive

    397036 Minimum size frames

    810176 65 to 127 byte frames

    108030 128 to 255 byte frames

     54510 256 to 511 byte frames

     45067 512 to 1023 byte frames

   1275409 1024 to 1518 byte frames

         0 1519 to 1522 byte frames

NVVB_MAINSWITCH_2950#

Thanks & Regards, Srinivas. N.
Hall of Fame Super Gold

will get the crc errors due to using wan, lan in same switch (29

Your "line errors" are not caused by duplex mismatch (which is good).

Instead, the line errors are caused by FCS (Frame Check Sequence).  This is bad.

There could be a possibility that you are looking at a potential cable fault.

New Member

will get the crc errors due to using wan, lan in same switch (29

Hi Leolaohoo,

Thank u very much, now i changed the both patch cards (17th, 20th ports of cisco 2950).

kept it on observation.

could you expline me what type of errors will occur in phycical layer and

when below error will occer

crc errers

fcs errors

Symbol error frames

Alignment errors

False carrier errors

Thanks & Regards, Srinivas. N.
844
Views
0
Helpful
4
Replies
CreatePlease login to create content