Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WILL SOMEBODY HELP ME GET MY 2611XM TO WORK?

So I am new to this cisco thing. I do have my network+, so I do have some solid ground on networks. So last night I finally got into my router using PuTTy. I have no idea what to do. Well when I first got the router I thought I could just plug it into my modem and my router into my HP 2610 ProCurve switch and everything just work dandy, well this isnt the case. I do have a linksys and belkin router that both work right when i plug them into my modem then the switch, so I need some help with my 2611xm. I am a TOTAL noobie when it comes to this. I will be starting my CCNA studying soon, and got this for like a home lab. Maybe some one can take over my laptop and doing the configureing slowly for me to watch and learn? I am up to all ideas to learn. Please help

          -Abraham

2 REPLIES
New Member

WILL SOMEBODY HELP ME GET MY 2611XM TO WORK?

I Have a broadband cable modem from comcast and use a straight through cable to connect it to my router (I really dont even know what port I would plug that into)

WILL SOMEBODY HELP ME GET MY 2611XM TO WORK?

The best way to learn is to do it and run into issues until you pull your hair out.

You can connect the modem directly to f0/0 and then console into the router. If you just want internet access and nothing more, then you can leave the outside (f0/0) no dhcp. It will probably pull the public address that the cable provider gives you.

Now you have to configure your inside network. Connect f0/1 to a switch. On this port, you'll need to pick your internal subnet and configure the port:

int fa0/1

ip address 192.168.1.1 255.255.255.0

speed 100

duplex full

This will put this address on your lan and it will be what you would use as your default gateway.

Do you have a dhcp server on your network? If not, you can configure it on your router as well:

ip dhcp excluded-address 192.168.1.1 192.168.1.99

ip dhcp pool LAN

network 192.168.1.0

default-router 192.168.1.1

dns-server 8.8.8.8 4.2.2.1

This would start your assignments at 192.168.1.100 - 254.

The last part is to get nat to work. Make sure that you can ping your router from a host that's connected to the same switch. If so, you won't be able to get to the internet yet until you configure natting:

ip nat inside source list 100 interface fa0/0 overload

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

int fa0/0

ip nat outside

int fa0/1

ip nat inside

When you enable nat, the router will hang for a second or two while it's doing its thing. After you get this part configured, see if you can ping one of the dns servers: 8.8.8.8 or 4.2.2.1. If you get a response, all is well and you should be able to get on the internet.

You may need a default route. You can use:

ip route 0.0.0.0 0.0.0.0 fa0/0

But, before doing that you should look at your routing table to make sure that the provider didn't assign you one. You're looking for the first line above the routing table with "Gateway of last resort" in the line. It will look like:

2(config)#do sh ip rout

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

The last resort ip is the actual default gateway that your router will send to when it needs to send traffic out of your network.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
166
Views
3
Helpful
2
Replies