Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WOL configuration on L3 Catalyst 6500 & L2 2960G

Hi..

I got problem with wake on LAN software.. The software unable to ON all pc's remotely if sitting under different vlan. Everything is ok if using the same vlan. Below are the network diagram & switch configuration.

wol.jpeg

Layer 3 switch Intervlan routing configuration

ip forward-protocol udp 7

!

interface Vlan4

description vlan Client-WOL

ip address 172.22.51.253 255.255.254.0

ip access-group Deny_HTTP_Vlan1 in

ip helper-address 172.20.1.246

ip directed-broadcast 110

glbp 4 ip 172.22.51.254

glbp 4 priority 110

glbp 4 preempt

end

!

interface Vlan3

description vlan WOL-Server

ip address 172.20.31.253 255.255.255.0

ip access-group Deny_HTTP_Vlan1 in

ip helper-address 172.22.51.255

glbp 3 ip 172.20.31.254

glbp 3 priority 110

glbp 3 preempt

end

!

!

ip access-list extended Deny_HTTP_Vlan1

permit tcp host 172.16.30.240 172.20.1.0 0.0.0.255 eq www

deny   tcp any 172.20.1.0 0.0.0.255 eq www 443

permit ip any any

!

access-list 110 permit udp host 172.20.31.12 any eq echo

!

Layer 3 Switch (DHCP Server)

ip dhcp excluded-address 172.22.50.1 172.22.50.50

ip dhcp excluded-address 172.22.51.240 172.22.51.254

!

ip dhcp pool 4

   network 172.22.50.0 255.255.254.0

   default-router 172.22.51.254

   dns-server 172.16.30.7

   domain-name ump.edu.my

   netbios-name-server 172.16.30.240

!

Layer 2 Switch

!

interface GigabitEthernet0/44

description WOL-Server port

switchport access vlan 3

switchport mode access

switchport voice vlan 200

mls qos trust cos

!

interface GigabitEthernet0/43

description Client-WOL port

switchport access vlan 4

switchport mode access

switchport voice vlan 200

mls qos trust cos

!

After configured all the switches with the above setting, the software still cannot wake all the pc's using LAN. Base on sniffing, i can't find UDP port usage by the software. Attached here with print screen from wireshark.Screenshot.png

What should i do next to tackle the problems. Please advice guys. Tq

Everyone's tags (2)
7 REPLIES
New Member

WOL configuration on L3 Catalyst 6500 & L2 2960G

Silver

WOL configuration on L3 Catalyst 6500 & L2 2960G

Hi,

Your WOL magic packet uses udp destination port number 40000 (decimal), so please adjust your configuration correspondingly.

Best regards,

Antonin

New Member

WOL configuration on L3 Catalyst 6500 & L2 2960G

Base on the packet capture above, the destination port was 40000 and the sourse port was 56690. Is that the correct port? Do we need to permit both port at layer 3 switch ?

New Member

WOL configuration on L3 Catalyst 6500 & L2 2960G

Information for the server UDP open port.

New Member

WOL configuration on L3 Catalyst 6500 & L2 2960G

Below are my finding using 2 different software to Wake Up The Lan

DCCS Software

After  taking traffic captures, we found that DCCS software(Wake On Lan Server) uses ARP to wake  up PCs, which can not be relayed between different subnets.

Using method base on Cisco documentation : FAILED

Deep Freeze Software

Deepfreez  uses standard WOL Magic packets with Ports (65535, 80, 25, 21 and port  7) which needs to modify ACL for UDP forwarding to adapt those ports.

Using method base on Cisco documentation : SUCCESS

New Member

WOL configuration on L3 Catalyst 6500 & L2 2960G

Hi.  Have you had any problems getting PCs on VLANs other than the Deep Freeze server to wake up during a scheduled wake in Deep Freeze?

Thanks.

New Member

WOL configuration on L3 Catalyst 6500 & L2 2960G

I not really sure about scheduled wake in Deep Freeze because not familiar with Deep Freeze software.

Base on testing, i just using Deep Freeze WOL function to wake all the pc's (with the same and different vlan) and everything is going fine.

Problem only with the DCCS software. It's cannot WOL pc that using different vlan.

5185
Views
0
Helpful
7
Replies
CreatePlease to create content