Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Xmodem - "Invalid Argument" on 3750

I'm trying to transfer an IOS of my machine to a 3750 switch by XModem. I type the command below and after that, I select the file in my desktop in the HyperTerminal. It returned the message "Invalid Argument".

copy xmodem: flash:c3750-ipbasek9-mz.122-44.SE2.bin

4 REPLIES
Hall of Fame Super Blue

Re: Xmodem - "Invalid Argument" on 3750

The image should end with a .bin - are you sure you are not telling xmodem to copy the toplevel directory ?

Your command should be

xmodem: flash:c3750-ipbasek9-mz.122-44.SE2.bin

but you need to work out where the .bin file is on your machine -

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_sea/configuration/guide/swtrbl.html#wp1099467

Jon

New Member

Re: Xmodem - "Invalid Argument" on 3750

Sorry Jon. I was trying to transfer the file using .bin at the end. I forgot it just on forum. It follows attached the images with .bin file on my machine.

Silver

Re: Xmodem - "Invalid Argument" on 3750

at switch:

did you gave flash_init command before copying the file.

If not try it. This command initialize the flash and make it usable.i have attached a file which gives info about that.

New Member

Re: Xmodem - "Invalid Argument" on 3750

Thanks! I was using the same commands of the guide, I changed the terminal emulation software and the trouble was resolved when I formatted the flash.

2273
Views
0
Helpful
4
Replies
CreatePlease login to create content