Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Can't add MARS device to CSM

I'm trying to add a MARS to a fresh install of CSM 3.2.0 through the CSM client.

I constantly get the message:

Connection with CS-MARS failed.

Incorrect username or password.

Make sure the CS-MARS username and password are valid.

I'm sure that the credentials are OK.

I even created a new user in MARS dedicated to CSM.

The strange thing is that MARS doesn't have any logs of these login failures.

Here's a screenshot of the error:

https://dl.getdropbox.com/u/67172/Invalid_credentials_full.PNG

10 REPLIES
Community Member

Re: Can't add MARS device to CSM

I use my pnadmin acct.

Cisco Employee

Re: Can't add MARS device to CSM

Hi

Please check the following from the screen shot I understand that you are trying to add the MARS using a Global account

1) Make sure that you are able to login to GC or LC using this account.

2) If you are trying to add the LC to CSM using the GC account, make sure the User account replicted to the LC.

3) If you are trying to add a CS-MARS using useraccount which is integrated with AAA then check for Global Controller Considerations with External AAA Servers under

http://www.cisco.com/en/US/docs/security/security_management/cs-mars/6.0/user/guide/combo/authen.html

Cisco Employee

Re: Can't add MARS device to CSM

Hi

From the screen shot I understand that you are trying to add the MARS using a Global account

1) Make sure that you are able to login to GC or LC using this account.

2) If you are trying to add the LC to CSM using the GC account, make sure the User account replicted to the LC.

3) If you are trying to add a CS-MARS using useraccount which is integrated with AAA then check for Global Controller Considerations with External AAA Servers under

http://www.cisco.com/en/US/docs/security/security_management/cs-mars/6.0/user/guide/combo/authen.html

Community Member

Re: Can't add MARS device to CSM

All credentials are local, and it's only one LC.

I was using the standard pnadmin account, and after that crated another one just to be used for CSM.

I've opened TAC but no solution so far.

Cisco Employee

Re: Can't add MARS device to CSM

Then the User Type should be "Local" should not be "Global" (Please Check the screen shot which you attached)

Global should be used only when you are using GC in your setup

Regards

R.Krishnan

Community Member

Re: Can't add MARS device to CSM

Sorry but I can't see where I can specify what kind of user I'm entering the credentials for.

Best regards,

K. Dimitrovski

Cisco Employee

Re: Can't add MARS device to CSM

Please see the attached screen shot for the option

Community Member

Re: Can't add MARS device to CSM

Krir,

could you send me the attachment agnain, maybe on email: koki @ neocom.com.mk.

The cisco forums give me the: Document does not exist! error.

Best regards

Cisco Employee

Re: Can't add MARS device to CSM

Done

Community Member

Re: Can't add MARS device to CSM

Just to inform everybody.

I solved the problem through a TAC case.

The resolution was no to use special characters in the user's password!

They sent me this as a explanation:

"Yes this is normal. During parsing of password any special character is

being phased out, since we cannot reliably encode it."

This is nonsense to me but...

279
Views
0
Helpful
10
Replies
CreatePlease to create content