Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

6500 xconnect and QinQ frames

Hi, I want to pass all vlanes from a client. I have a tunnel-port in both 3560 and then I have an mpls xconnect between 6500. The 6500's are connected with a pvc with encapsulation aal5snap. This is the schema:

3560 --Gb -- 6500 -- ATM PVC -- 6500 -- Gb 3560

The problem is that the xconnect does not carry QinQ frames, it only sends the frames from the client that are untagged.

How can I pass the QinQ frames between the 6500's?

Thanks

Everyone's tags (3)
7 REPLIES
Hall of Fame Super Silver

Re: 6500 xconnect and QinQ frames

Hello Tonio,

post the configuration of your EoMPLS setup and a show module to understand the hardware you have on the C6500

Also configuration of C3560 counts, link C3560-C6500 has to use a native vlan different from customer vlan (S-Vlan)

Hope to help

Giuseppe

New Member

Re: 6500 xconnect and QinQ frames

This is the current 6500 configuration, I have tried with the same result this configuration and other using subinterfaces. The xconnect works because I could see the untagged frame int both sites. The interface Gig1/9 from the 6500 is connected with the interface Fa0/1 from the 3560.

interface GigabitEthernet1/9
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
mtu 9216
no ip address

interface Vlan3003
description VLL_CLIENT1
no ip address
xconnect 10.0.0.3 3003 encapsulation mpls

show modules:

#sh mod
Mod Ports Card Type                              Model              Serial No.
--- ----- -------------------------------------- ------------------ -----------
  1    9  Supervisor Engine 32 8GE (Active)      WS-SUP32-GE-3B     SAL12426MVE
  2    0  4-subslot SPA Interface Processor-200  7600-SIP-200       JAE1244Z5PF

Mod MAC addresses                       Hw    Fw           Sw           Status
--- ---------------------------------- ------ ------------ ------------ -------
  1  0021.d89e.c846 to 0021.d89e.c851   4.6   12.2(18r)SX2 12.2(18)SXF1 Ok
  2  0021.a06d.fdc0 to 0021.a06d.fdff   2.303 12.2(18)SXF1 12.2(18)SXF1 Ok

Mod  Sub-Module                  Model              Serial       Hw     Status
---- --------------------------- ------------------ ----------- ------- -------
  1  Policy Feature Card 3       WS-F6K-PFC3B       SAL12405HZN  2.4    Ok
  1  Cat6k MSFC 2A daughterboard WS-F6K-MSFC2A      SAL12426HJD  4.0    Ok
2/0 2xOC3 ATM SPA               SPA-2XOC3-ATM      JAE1244Z6G2  1.1    Ok

Mod  Online Diag Status
---- -------------------
  1  Pass
  2  Pass
2/0 Not Applicable

The 3560 configuration is this:

interface FastEthernet0/1
description 6500_Uplink
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/8
description CLIENT1
switchport access vlan 3003
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
l2protocol-tunnel lldp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable

Thanks in advance

New Member

Re: 6500 xconnect and QinQ frames

Hi Tonio.

I hope al is working now, but, did you check the frame size all the path?

QinQ uses 4 bytes extra.

Hope this help

Gerardo

New Member

Re: 6500 xconnect and QinQ frames

The frame size is always greater than 1540.

I have read posts in this forums saying that only router based platforms can do xconnect with QinQ frames, but the 6500 need special cards so it can do it.I think that this is a bad issue on 6500s and we have to replace then due to this.

If someone could point me other way to do this could be very gratefull.

Thanks in advance

Cisco Employee

Re: 6500 xconnect and QinQ frames

Hi,

What is the configuration on the xconnect port on the 6500 ? Normally if you set it to trunk mode it would pass tagged frames. I used some trunk through a xconnect tunnel on a 7600 with a sup720 card, but never tried QinQ though. Anyway, if you set up a pseudowire between two routers that are at your edge, it will be transparent and you don't have to carry about customer VLANS as they won't overlap, but maybe the 3560 switches are not customer switches ?

New Member

Re: 6500 xconnect and QinQ frames

You have the configuration of the 6500 in a previus post.

However, if I set up a pseudowire between two routers that are at my edge I can only carry customer VLANS with one tag. The problem is that customer VLANS double tagged are not carried by the pseudowire.

The same configuration in a router like a 3800 or 7200 works with one-tagged and double-tagged VLANS, the problems is with the 6500 platform.

Hall of Fame Super Silver

Re: 6500 xconnect and QinQ frames

Hello Tonio,

sorry for not having followed this thread after beginning

what if you configure the ports between the C3560 and the C6500 using

switchport trunk allowed vlan 3003

to restrict what vlans can pass on the the link.

inner 802.1QinQ shouldn't be a problem if you don't need to change the inner vlan ids but just to transport them

Hope to help

Giuseppe

3386
Views
0
Helpful
7
Replies