Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Access and trunk pseudowire with L2PT

Hi all,

I've done extensive testing and I would like some confirmation regarding my conclusions:

1. rewrite ingress tag pop 1 symmetric has no effect on Layer 2 control frames (STP, CDP, etc).

2. access and trunk connections on each end of a pseudowire works fine (popping of tagged ingress data frames)

3. l2protocol tunneling is not supported (due to item 1 above)

I have the following topology - client A and client B are standard switches and SW01 and SW03 are ME3600s.

ClientA --> access int (vlan 10) --> SW01 --> Pseudowire --> SW03 --> dot1q trunk --> Client B

I observe the following log messages on ClientA:

*Oct 16 08:22:02.727: %SPANTREE-SP-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk TenGigabitEthernet2/2 VLAN10.

*Oct 16 08:22:02.727: %SPANTREE-SP-7-BLOCK_PORT_TYPE: Blocking TenGigabitEthernet2/2 on VLAN0010. Inconsistent port type.

And the following on ClientB:

*Oct 16 08:35:08.951: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on TenGigabitEthernet1/2 (1), with ClientA TenGigabitEthernet2/2 (10).

Configurations

Client A:

interface TenGigabitEthernet2/2

switchport

switchport access vlan 10

switchport mode access

SW01

interface TenGigabitEthernet0/1

switchport trunk native vlan 10

switchport trunk allowed vlan none

switchport mode trunk

service instance 10 ethernet

  encapsulation untagged

  l2protocol tunnel

  xconnect 192.1.0.3 10 encapsulation mpls

SW03

interface TenGigabitEthernet0/1

switchport trunk allowed vlan none

switchport mode trunk

service instance 10 ethernet

  encapsulation dot1q 10

  rewrite ingress tag pop 1 symmetric

  l2protocol tunnel

  xconnect 192.1.0.1 10 encapsulation mpls

ClientB

interface TenGigabitEthernet1/2

switchport

switchport mode trunk

Everyone's tags (3)
1 REPLY

Access and trunk pseudowire with L2PT

Hi Terry,

Looks like the BPDU guard kicks in on Client-A putting the access port into errdis after receiving BPDU indicating a possible loop

So you might want to change the Client-A port to trunk with native VLAN 10

Oh and if possible do “l2protocol forward” instead of the Cisco proprietary “tunnel” even though in this case it doesn’t really matter.

adam

adam
979
Views
0
Helpful
1
Replies
CreatePlease to create content