Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

CE vlan local termination in VPLS

Hi, For these configuration of 7600 Sup720-3B 12.2.18.SXF4 on PE interfaces:

l2 vfi PE1-VPLS manual

vpn id 100

neighbor 2.2.2.2 encapsulation mpls

!

Interface loopback 0

ip address 1.1.1.1 255.255.255.255

interface gigabitethernet 0/1

switchport

switchport mode dot1qtunnel

switchport access vlan 1

interface gigabitethernet 0/2

switchport

switchport mode dot1qtunnel

switchport access vlan 2

interface vlan 1

no ip adddress

xconnect vfi PE1-VPLS

interface vlan 2

no ip adddress

xconnect vfi PE1-VPLS

Is it possible to have the same "xconnect vfi PE1-VPLS" on different interface vlan?

And if it`s correct, could be reach "CE VLAN`s" in q-in-q tunnel on gi0/1 the same "CE VLAN`s" in q-in-q tunnel on gi0/2?

We have 7600 in production only, and can`t check it.

14 REPLIES

Re: CE vlan local termination in VPLS

You actually cannot create the same VPLS instance on two different vlans, as each VPLS instance is per port or per VLan by defintion.

Is redundancy of the CE your requirement?

As I see you want to connect same CE on two different interfaces.

More information would be appreciated.

HTH-Cheers,

Swaroop

Community Member

Re: CE vlan local termination in VPLS

Thanks for the answer.

Yes, we want to have redundancy and protect core from L2 issues like stp-loop.

Is it possible to have CE redunancy in VPLS for more than 1 ethernet ring?

Community Member

Re: CE vlan local termination in VPLS

In addition to previos question.

If we consider only 2 pe in vpls.

Re: CE vlan local termination in VPLS

you can provide redundancy to the customer on two levels.

1) Link Layer: FOr this you just need to trunk the same SP vlan assigned to the customer on the L2 ring. and the ring gets trunked to your PE and the SP vlan is transported to the other side using VPLS or P2P PW.

2) PE level redundancy: have a look at this thread where i have explained in detail how you can provide PE level redundancy to a plain CE switch. (CE dual homing to 2 different PE)

this is the link...

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Service%20Providers&topic=Metro&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddc4452

do let me know if i have understood your question right.

HTH-CHeers,

Swaroop

Community Member

Re: CE vlan local termination in VPLS

Hi Swaroop,

As I understood your advice, it is not solved the problem of redundancy of multiple L2 CE rings with 2 pe.

For the first suggestion, if one of pe has fail the connectivity between remote CE goes down too.

The second suggestion describe redundancy only for 1 ring.

But I`ve found solution for 3 rings and 2 pe.

See in attachment.

For this topology double CE traffic between PE can occur in worst case.

All rings pass through EoMPLS that allows to control L2 CE issues in the core.

Community Member

Re: CE vlan local termination in VPLS

Attachment

Re: CE vlan local termination in VPLS

There is considerable difference between doing Dual homing for a VPLS instance and for a normal ATOM P2P PW.

My suggestion on the solution is for VPLS and not for P2P PW. Where its not difficult for end device to break loops using STP.

For VPLS the H-VPLS dual homing is still in a evolutionary phase. So rather than getting into which PE does the MAC-Withdrawal and when, upon failure of a primary extension VC i have suggested using FlexLinks for the failover directly from the CE.

Hope it clarfies your question and answer.

HTH-Cheers,

Swaroop

Community Member

Re: CE vlan local termination in VPLS

Hi Swaroop,

As I understood flexlink feature, it is block all stp bpdu on that port. Is it true?

So, if it`s true, it mean that we must implement flexlinks on all entire L2 ethernet area and turn off stp.

It`s not acceptable for us, because our clients do not guarantee us loop free topology and can`t have flexlink feature on their own devices.

I think it is last question ;) and thank you for answers.

Kirill.

Re: CE vlan local termination in VPLS

FlexLinks avoids loops by keeping one connection primary and one backup. Thats the reason STP is not required and is disabled on the interface running flexlink.

Now its does not at all mean your customer cannot run, STP, Customer STP is totally transaprent to Service Provider STP. So effectively you are disabling STP on your side not on their side.

I hope I am clear to you. And also I am unable to understand your topology, as to how is the loop avoided. Just wanted to double check on that.

I believe its lot of information collusion leading to confusion :-).

HTH-Cheers,

Swaroop

Community Member

Re: CE vlan local termination in VPLS

I talk about situation when customer connected from one side of SP with flexlink to other side.

client <-> CE VLAN <-> flexlink (with block stp bpdu)<-> core <-> CE VLAN <-> client

In this case loop can occur if client have another link to the other side.

So, Does stp bpdu pass through flexlink or not?

Kirill.

Re: CE vlan local termination in VPLS

Ok to make your topology more clear, lets do it like this, can u name the CE switches also, like SW1 and SW2. And can u write in words the connectivty. SW1-Int1<-->PE1-Int1

something like that. As there is a confusion to understand, when your ethernet can reach the other pop(PE2), then why is the EoMPLS required through the PE.

This will also help to verify what you are implementing.

HTH-Cheers,

Swaroop

Re: CE vlan local termination in VPLS

Lets look at this below:

client <-> CE VLAN SP VLAN <-> flexlink (with block stp bpdu)<-> core <-> SP VLAN CE VLAN <-> client.

This is how it will work. The Customer CE will not participate in STP with your switch.

But his BPDU from one end switch will be carried to his other switch directly. This is how it should be done. You should always avoid participation of CE STP with SP cloud.

Now to clear things more can u explain your connectivty. Can u write in words the connectivty. SW1-Int1<-->PE1-Int1 something like that. And also mention your PE1 and PE2 are in different location of same location.

Also one more thing is if CE1 want to go to CE2, it CE1 is coming to PE1 and then going to PE2 and CE2. When you have physical link till PE2 why dont you interconnect both the CE directly. Or you actual rollout topology is different. and you are simulating this just in lab.

Need more details !!! so this can be worked out.

HTH-Cheers,

Swaroop

Community Member

Re: CE vlan local termination in VPLS

I think, now for me is clear.

It works, if we do q-in-q before flexlink.

client <-> CE VLAN SP VLAN <-> flexlink <-> PE int <-> core <-> PE int <-> SP VLAN CE VLAN <-> client

Flexlink block STP BPDU for SP Vlan but not for tunnel CE Vlans.

> You should always avoid participation of CE STP with SP cloud.

It is my primary goal.

When we do q-in-q and xconnect on the same device like in my previous configuration (VPLSnew.jpg) flexlink doesn`t help us.

If you agree with me, I haven`t any questions.

Thanks you for time spent me.

Kirill.

Community Member

Re: CE vlan local termination in VPLS

Hello Kirill, I have problems to download this picture, could you please re-post it?

Thanks a lot,

Ariel

888
Views
7
Helpful
14
Replies
CreatePlease to create content