cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6152
Views
4
Helpful
3
Replies

configuring traffic policing and shaping per vlan on ME3400E switch with MetroIPAccess image

Julie Tupling
Level 1
Level 1

How do I configure per vlan traffic policing and shaping per vlan on an ME3400E switch with MetroIP Access image?

I tried configuring a policy-map, but that can't be assigned to a virtual interface.

I have an ME3400E and currently have a router that is managing the bandwidth for one of our customers, I wanted to remove the router and configure the ME3400E to do the routing since it is a layer 3 switch, but I can't figure out how to limit the bandwidth to 15MB for vlan 301.  We have another vlan that uses the remainder (85MB) of internet access.

How can I configure the ME3400E to limit both ingress and egress bandwidth to 15MB for a specific vlan?

This is what I tried:

ME1(config-pmap)#class class-default

ME1(config-pmap-c)#police cir 15000000

ME1(config-pmap-c-police)#conform-action transmit

ME1(config-pmap-c-police)#exceed-action drop

ME1(config-pmap-c-police)#exit

ME1(config-pmap-c)#int vlan 301

ME1(config-if)#service-policy input 15MEG

Configuration failed. Policymap is not supported on virtual interfaces

Most of our ports are access ports and so I can configure the bandwidth management to the physical interface, but the port for our customers that want internet access is a trunk port and I need to be able to limit the bandwidth per vlan (so if customer a (vlan 101) pays for 10MB I can limit them to 10MB and if customer b (vlan 202) pays for 20MB, I can limit their vlan to 20MB

Any help would be greatly appreciated! Thanks in advance

Julie

3 Replies 3

Try something like this :

class-map match-any VoiceVlan

  match vlan  227

policy-map SetCosVoice

  class class-default

   set cos 5

policy-map parent-policy

  class VoiceVlan

   service-policy SetCosVoice

interface GigabitEthernet0/9

switchport trunk allowed vlan 227

switchport mode trunk

service-policy input parent-policy

Michalis,

I'm not sure I understand your example.  Say I have one customer - VLAN 301 - that is paying for 15MB of internet access and another customer - VLAN 300 - that is paying for 10MB of internet access, and they share port g0/11 - which is configured as a trunk port and allows VLANs 301 and 300.  How would I configure the switch to make sure each customer gets the bandwidth they pay for, but only what they pay for.  We are not using class of service at all.  We just want to be able to rate limit (traffic policing and shaping) the traffic per customer (VLAN).

Thanks,

class-map match-any Customer-1

  match vlan  300

class-map match-any Customer-2

  match vlan  301

policy-map Customer-1

class class-default

   police cir 15000000

   conform-action transmit

   exceed-action drop

policy-map Customer-2

class class-default

   police cir 10000000

   conform-action transmit

   exceed-action drop

policy-map parent-policy

  class Customer-1

   service-policy Customer-1

  class Customer-2

   service-policy Customer-2

interface GigabitEthernet0/9

switchport trunk allowed vlan 300,301

switchport mode trunk

service-policy input parent-policy

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: