Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

encapsulation dot1q any second any on me3600x

Hi,

we recieve a number of downstream hand-offs that are delivered as SVID/CVID ccts.  There are mixture of data, and VOIP subscribers, the only way to tell the different type of subscribers is that the all voip services are marked as cos 4.  All data subscribers are marked cos 0.  I have no control over the SVID/CVID mix, and there is no "pattern" so I cannot enter ranges.

I am wanting to deliver each subscriber type to a different bridge-domain then use xconnect to forward these so ultimately i have one bridge-domain with VOIP services, and one with data services.

on the me3600x I tried the following:

interface GigabitEthernet0/4

switchport trunk allowed vlan none

switchport mode trunk

service instance 950 ethernet

  encapsulation dot1q 1-4096 secondary 1-4096

  bridge-domain 950

service instance 951 ethernet

  encapsulation dot1q 1-4096 secondary 1-4096 cos 4

  bridge-domain 951

This seemed to work with cos 4 traffic being sent to a differnet bridge-domain than other traffic, however when i try to apply this config to more than 4 interfaces (8 bridge-domain members) i get a "command rejected" error when i enter the "encapsulation dot1q" command.  "Encapsulation deafult" is still accepted though.

can any one explain to me why there is this limitation, or if there is any way around it, or any other way to do what i am trying to do?

ta.

1 REPLY

encapsulation dot1q any second any on me3600x

Hi Mike,

I replicated your setup in the lab and it appears the problematic line causing this interesting limitation is the “encapsulation dot1q any second-dot1q any” under the “service instance 950”

Since you are not really interested in the second tag value you can leave it out of the equation using just “encapsulation dot1q any” –to match any frame (not matching any more specific service instance rules) with at least one 802.1q tag or you can use “encapsulation default” –to match any frame (not matching any more specific service instance rules)

interface GigabitEthernet0/1

switchport trunk allowed vlan none

switchport mode trunk

service instance 950 ethernet

encapsulation dot1q any

bridge-domain 950

!

service instance 951 ethernet

encapsulation dot1q any second-dot1q any cos 4

bridge-domain 951

!

c36cx#sh bridge-domain 951

Bridge-domain 951 (6 ports in all)

State: UP                   Mac learning: Enabled

Maximum address limit: 10000

   GigabitEthernet0/1 service instance 951

   GigabitEthernet0/2 service instance 951

   GigabitEthernet0/3 service instance 951

   GigabitEthernet0/4 service instance 951

   GigabitEthernet0/5 service instance 951

   GigabitEthernet0/6 service instance 951

adam

adam
879
Views
0
Helpful
1
Replies