Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

EoMPLS and VPLS on 7600

Hi all,

Appreciate any pointers on this. I have a 7609 Sup720-3BXL and uses 7600-ES20-10G3CXL or SIP-400/SPA-1x10GE for Core facing connectivity (p-pe). On the attachment circuit (AC) end, i have a WS-X6724-SFP.

Question: Is it possible to have EoMPLS:Port-mode or VLAN-mode co-existing with a VPLS setup on the same box? The EoMPLS P2P circuits are independent of the M2M VPLS VSI.

Example configuration on 7609:

EoMPLS P2P:

interface GigabitEthernet1/23.200

description P2P EoMPLS to R2

encapsulation dot1q 200

xconnect 1.1.2.2 200 encapsulation mpls

!

VPLS M2M:

interface GigabitEthernet1/24

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100-199

switchport mode trunk

!

interface Vlan100

description M2M VPLS to R3 & R4

xconnect vfi V100

!

l2 vfi V100 manual

vpn id 100

neighbor 1.1.3.3 encapsulation mpls

neighbor 1.1.4.4 encapsulation mpls

!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: EoMPLS and VPLS on 7600

Hi,

No problem for them to coexist but take care of a critical point though, because point-to-point and VPLS Layer 2 VPNs share the same Pseudowire ID space (since targeted LDP is used for both), you need to ensure that VPN IDs that are used in VPLS do not overlap with Pseudowire IDs that are used in point-to-point Layer 2 VPNs.

BR,

Mohammed Mahmoud.

6 REPLIES

Re: EoMPLS and VPLS on 7600

Hi,

No problem for them to coexist but take care of a critical point though, because point-to-point and VPLS Layer 2 VPNs share the same Pseudowire ID space (since targeted LDP is used for both), you need to ensure that VPN IDs that are used in VPLS do not overlap with Pseudowire IDs that are used in point-to-point Layer 2 VPNs.

BR,

Mohammed Mahmoud.

Bronze

Re: EoMPLS and VPLS on 7600

Hi Mahmoud,

Thanks for the feedback. When u mention Pseudowire IDs for p2p L2VPN, you are actually referring to the VCID? (xconnect 1.1.2.2 encapsulation mpls)

Also, do you have any good links or recommended readings for setting up carrier ethernet at the edge with 1xUPE-2xNPE redundancy scenarios with loop prevention mechanisms? I have run through the following:

http://www.cisco.com/en/US/docs/ios/zz_trash/mp_hvpls_npe_red_ps6922_TSD_Products_Configuration_Guide_Chapter.html

but am looking for more detailed readings on this kind of setup and integrating between REP and MSTP for H-VPLS.

Re: EoMPLS and VPLS on 7600

Hi Hon Wah Tse,

You are very welcomed, yes the pseudowire ID is the VCID stated in the xconnect command, it is just a generic convention.

I haven't practically tested a VPLS multihomed scenario, but a nice case study that I've seen was in the Layer 2 VPN Architecture book, Case Study 15-5: Multihoming.

BR,

Mohammed Mahmoud.

Bronze

Re: EoMPLS and VPLS on 7600

Hi Mahmoud,

Thanks a lot. You've been very helpful! Appreciate it.

Re: EoMPLS and VPLS on 7600

Hi,

You are very welcomed, enjoy :)

BR,

Mohammed Mahmoud.

New Member

Re: EoMPLS and VPLS on 7600

One can have both VSI & sub-interface based EoMPLS & VPLS if the uplinks is ES-20/SIP-600 and OSM cards.

One can only support sub-interface based based EoMPLS if uptime is anything other than the ones stated above

1918
Views
5
Helpful
6
Replies
CreatePlease to create content