Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

H-VPLS with MPLS in access

Hi NetPros

We use some 3rd party and xDSL based aggregation networks for Ethernet services.

They often have some L2CP and other transparency limitations or at least quite different behaviour.

Due to that fact I'm thinking of using MPLS in the access as most 3rd party aggregation networks are transparent for MPLS ethertpyes.

In our lab I already did some first tests with P2P which worked fine (beside throughput with small packets).

Now I tried to create MP2MP services. H-VPLS with MPLS access is'nt working so far.

As N-PE we use 7600+RSP720+ES20, IOS version 15.2(1)S1 (core and access links on ES20)

As U-PE (or PE-CLE) we tried with ISR G2 (2921), ASR1001, 892F and 888E.

Does someone maybe have a working configuration with similar setup?

Maybe someone could share a more detailed sample configuration for ME-H-VPLS?

Routing is fine; LDP is up; but N-PE complains about no local binding

N-PE lab config:

mpls label protocol ldp

mpls ldp discovery targeted-hello accept

mpls ldp router-id Loopback0 force

!

l2 vfi rd-party-test manual

vpn id 10

! remote N-PE:

neighbor 192.168.0.3 encapsulation mpls

! U-PE:

neighbor 192.168.0.45 100 encapsulation mpls no-split-horizon

!

interface Loopback0

ip address 192.168.0.4 255.255.255.255

!

interface GigabitEthernet1/0/4

description interface facing to U-PE

service instance 100 ethernet

  encapsulation dot1q 100

  rewrite ingress tag pop 1 symmetric

  bridge-domain 100

!

!

interface Vlan100

ip address 192.168.1.1 255.255.255.0

mpls ip

U-PE lab config:

mpls label protocol ldp

mpls ldp discovery targeted-hello accept

mpls ldp router-id Loopback0 force

!

interface Loopback0

ip address 192.168.0.45 255.255.255.255

!

interface GigabitEthernet0/1

description interface facing to customer

xconnect 192.168.0.4 100 encapsulation mpls

  mtu 1500

!

interface GigabitEthernet0/0.100

description interface facing to N-PE

encapsualtion dot1q 100

ip address 192.168.1.45 255.255.255.0

mpls ip

On N-PE:

Apr 15 23:32:12.096 cet-sum: AToM LDP[192.168.0.45]: Session is up

Apr 15 23:32:12.096 cet-sum: %LDP-5-NBRCHG: LDP Neighbor 192.168.0.45:0 (8) is UP

Apr 15 23:32:12.100 cet-sum: AToM LDP[192.168.0.45, 100]: LDP open

Apr 15 23:32:12.100 cet-sum: AToM LDP[192.168.0.45, 100]: Signaling peer-id of VC changed to 192.168.0.45

Apr 15 23:32:12.100 cet-sum: AToM LDP[192.168.0.45, 100]: LDP UP

Apr 15 23:32:12.100 cet-sum: AToM[192.168.0.45, 100]: Evt ldp up, provisioned -> ldp ready

Apr 15 23:32:12.100 cet-sum: AToM[192.168.0.45, 100]: . Take no action

Apr 15 23:32:12.104 cet-sum: AToM LDP[192.168.0.45]: Peer address change, add 192.168.0.45

Apr 15 23:32:12.104 cet-sum: AToM LDP[192.168.0.45]: Peer address change, add 10.0.37.1

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45]: Received label mapping msg, id 10500 GR 8 vc type 4, cbit 1,

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45]:   vc id 100,

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45]:   group id 0, vc label 16,

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45]:   status 0x7/LDP 0x1/ADJ 0x0,

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45]:   mtu 1500, peer vlan id 0   , vc handle 0x3600000A

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45]:   VCCV cc flags 0x3 cv flags 0x2

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45, 100]: Receive label adv

Apr 15 23:32:12.108 cet-sum: AToM LDP[192.168.0.45, 100]: Signaling peer-id of VC changed to 192.168.0.45

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: Evt remote ready, ldp ready -> remote ready

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: . Receive remote vc label binding, instance 8

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: . Adjacency : No fault

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .. S:Evt ADJ up in LndRnd

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .. S:Evt dataplane clear fault in LndRnd

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: . Check if remote connected

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .. Remote label is ready

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .... S:Evt remote ready, LndRnd -> LndRrd

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .... S:Evt remote up, LndRrd -> LndRru

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .... S:Act send SSS(UP)

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .....  [no service]

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .... S:Evt ADJ up in LndRru

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .... S:Act send SSS(UP)

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .....  [no service]

Apr 15 23:32:12.108 cet-sum: AToM[192.168.0.45, 100]: .. Yes, connected

show mpls l2transport vc vcid 100 detail

Local interface:   down

  Interworking type is Ethernet

  Destination address: 192.168.0.45, VC ID: 100, VC status: down

    Output interface: none, imposed label stack {}

    Preferred path: not configured

    Default path: no route

    No adjacency

  Create time: 00:42:48, last status change time: 00:02:29

  Signaling protocol: LDP, peer 192.168.0.45:0 up

    Targeted Hello: 212.161.178.225(LDP Id) -> 192.168.0.45, LDP is UP

    Status TLV support (local/remote)   : enabled/supported

      LDP route watch                   : enabled

      Label/status state machine        : remote ready, LndRru

      Last local dataplane   status rcvd: No fault

      Last BFD dataplane     status rcvd: Not sent

      Last local SSS circuit status rcvd: DOWN(not-forwarding)

      Last local SSS circuit status sent: Not sent

      Last local  LDP TLV    status sent: None

      Last remote LDP TLV    status rcvd: No fault

      Last remote LDP ADJ    status rcvd: No fault

    MPLS VC labels: local unassigned, remote 16

    PWID: 40988

    Group ID: local unknown, remote 0

    MTU: local unknown, remote 1500

    Remote interface description:

  Sequencing: receive disabled, send disabled

  Control Word: Off (configured: autosense)

  VC statistics:

    transit packet totals: receive 0, send 0

    transit byte totals:   receive 0, send 0

    transit packet drops:  receive 0, seq error 0, send 0

Everyone's tags (2)
2 REPLIES

H-VPLS with MPLS in access

umm , the below bit worries me. why have u got MTU 1500 under ur xconnect command on your U-PE. can u take it off and see what happens?

MTU: local unknown, remote 1500.

Also there could be smoething to do with the VC type. The N-PE is receiving a  vc type 4 from the U-PE. but its local vc type is 5(port based ethernet).

can you please paste the below on the U-PE and see if that helps.

pseudowire-class ip-interworking 

encapsulation mpls 

interworking ip

interface GigabitEthernet0/1

description interface facing to customer

xconnect 192.168.0.4 100 pw-class ip-interworking

HTH

Kishore

New Member

H-VPLS with MPLS in access

Hi Kishore

You brought me closer to a working configuration I guess.

First I changed configurations everywhere "vc-type 5" is used.

I also checked MTU is everywhere the same.

I also had to add a local SVI to the VFI on N-PEs.

After that N-PE full mesh VPLS is up and running.

But all spoke pseudowires and SVI interface on N-PE now flap constantly exactly every 15 seconds:

On N-PE:

Apr 17 09:28:37.531: %LINK-3-UPDOWN: Interface Vlan335, changed state to up

Apr 17 09:28:37.535: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan335, changed state to up

Apr 17 09:28:37.631: %LINK-3-UPDOWN: Interface Vlan335, changed state to down

Apr 17 09:28:37.635: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan335, changed state to down

Apr 17 09:28:52.624: %LINK-3-UPDOWN: Interface Vlan335, changed state to up

Apr 17 09:28:52.628: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan335, changed state to up

Apr 17 09:28:52.720: %LINK-3-UPDOWN: Interface Vlan335, changed state to down

Apr 17 09:28:52.724: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan335, changed state to down

Apr 17 09:29:07.808: %LINK-3-UPDOWN: Interface Vlan335, changed state to up

Apr 17 09:29:07.812: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan335, changed state to up

Apr 17 09:29:07.912: %LINK-3-UPDOWN: Interface Vlan335, changed state to down

On U-PE:

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC UP, VC state UP

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC DOWN, VC state DOWN

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC UP, VC state UP

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC DOWN, VC state DOWN

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC UP, VC state UP

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC DOWN, VC state DOWN

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC UP, VC state UP

%XCONNECT-5-PW_STATUS: MPLS peer 192.168.0.4 vcid 100, VC DOWN, VC state DOWN

Any idea what could cause flapping?

1999
Views
0
Helpful
2
Replies