Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

Half duplex on SFP ports - ME-3400EG-12CS-M

Hi everyone,

I'm wondering if anyone in the community has encountered this strange behaviour on a 3400EG-12CS.

Last night after upgrading the IOS on a few of these switch models, I noticed that ports with an SFP installed were coming up as 1000/half. At first I thought it may have been the IOS I was moving too (12.2.52se), but I reverted to several IOS versions to only get the same results.

Below is an example of the "show int status" of one of the switches:

vds4#show int status

Port Name Status Vlan Duplex Speed Type

Gi0/1 sem01_Port3 connected 464 half 1000 1000BaseSX SFP

Gi0/2 sem02_Port3 connected 464 half 1000 1000BaseSX SFP

Gi0/3 sem03_Port3 connected 464 full 1000 1000BaseSX SFP

Gi0/4 sem04_Port3 connected 464 full 1000 1000BaseSX SFP

Gi0/5 sem05_Port3 connected 464 half 1000 1000BaseSX SFP

Gi0/6 sem06_Port3 connected 464 half 1000 1000BaseSX SFP

Gi0/7 sep01r_Port1 connected 464 full 1000 1000BaseSX SFP

Gi0/8 FST-HEMI-01 Media connected 464 a-full a-1000 10/100/1000BaseTX

Gi0/9 mmc01_Port8 notconnect 464 auto auto Not Present

Gi0/10 notconnect 464 auto auto Not Present

Gi0/11 notconnect 464 auto auto Not Present

Gi0/12 MPEG Analyzer disabled 464 auto auto 10/100/1000BaseTX

Gi0/13 vds2_Gi0/1 connected trunk full 1000 1000BaseSX SFP

Gi0/14 vds2_Gi0/2 connected trunk full 1000 1000BaseSX SFP

Gi0/15 disabled 1 auto auto Not Present

Gi0/16 disabled 1 auto auto Not Present

Po1 connected trunk full 1000

Fa0 OOB Management (VM connected routed a-full a-100 10/100BaseTX


vds4#show run int g0/1

Building configuration...

Current configuration : 110 bytes


interface GigabitEthernet0/1

description sem01_Port3

switchport access vlan 464

media-type sfp



Some of the switches have an Port-Channel and they would come up in suspend. I'm suspecting due a duplex mismatch.

I also don't see any errors on the ports that are coming up as 1000/half which is weird.

The only way I am currently able to resolve this issue, is to move the sfps to a new port. Clearing the config/rebuild and re-seating the SFP doesn't seems to work.

Any thoughts would be greatly appreciated.

Thanks in advance

-- Dominique

New Member

Re: Half duplex on SFP ports - ME-3400EG-12CS-M

I do not have a soultion, but can say I just saw the same thing... We kept trying to change it but no luck.  This happened for us after an OS upgrade as well.  We also did not see any errors.. I know this is an old post, but gee it was interesting/annoying.

Cisco Employee

Re: Half duplex on SFP ports - ME-3400EG-12CS-M

Hi Dominique and Stuart,

the issue looks like  CSCtf71229    "ME-3400E: SFP negotiating at half duplex "



When ME-3400E reload or Optical cable re-insert, SFP negotiating at half duplex(suspended)


                                  Gi0/1                                Gi0/51


                                  Gi0/2                                Gi0/52

  * These switches connected with Optical cable + SFP

  * This issue occurs:

     -IOS version : 12.2(53)SE, 12.2(50)SE3

     -ME-3400 E series only.

     -speed nonegotiate(1000/Full Hardcoded)

   * This issue NOT occur:

     -speed and duplex is 1000/auto

     -ME-3400(*NOT* E series)



  -speed and duplex is 1000/auto.


It is solved in  12.2(55)SE / 12.2(52)EY and will be solved in 12.2(58)SE too


New Member

Re: Half duplex on SFP ports - ME-3400EG-12CS-M

I am having the same problem with several ME-3400EG-12CS-M's running IOS 12.2(54)SE as well. The suggested fix to CSCtf71229 listed on is to set duplex auto and speed auto however you cannot do this while the media type is set to sfp. If you change the media type to auto or remove the sfp type the link still comes up at half duplex, so it looks like I will be upgrading to 12.2:55)SE to attempt to resolve this.

New Member

Half duplex on SFP ports - ME-3400EG-12CS-M

Looks like ME3400 is foster child for Cisco - so many bags.

This bag CSCtf71229 you mentioned is not 100% correct:

If you setup media to SFP you CAN NOT define speed & duplex on interface - your only option is "speed nonegotiate" or to remove it.

At the same time it looks like cosmetic issue - our ISP has 1000/full and we don't have any errors/collisions (its why we will probably keep rinning current 12.2.54SE till other major issue comes up):

GigabitEthernet0/1 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is b4a4.e3ce.9681 (bia b4a4.e3ce.9681)

  Description: ""

  MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 7/255, rxload 23/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Half-duplex, 1000Mb/s, link type is force-up, media type is 1000BaseLX SFP

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 93627000 bits/sec, 11102 packets/sec

  5 minute output rate 29837000 bits/sec, 7361 packets/sec

     17372242746 packets input, 16939562380170 bytes, 0 no buffer

     Received 119066 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     12673148915 packets output, 6709051282693 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

     Transmit GigabitEthernet0/1              Receive

    317362230 Bytes                        231526071 Bytes                   

   4083206873 Unicast frames               192273207 Unicast frames          

        16718 Multicast frames                     0 Multicast frames        

          481 Broadcast frames                119066 Broadcast frames        

            0 Too old frames               223905847 Unicast bytes           

            0 Deferred frames                      0 Multicast bytes         

            0 MTU exceeded frames            7620224 Broadcast bytes         

            0 1 collision frames                   0 Alignment errors        

            0 2 collision frames                   0 FCS errors              

            0 3 collision frames                   0 Oversize frames         

            0 4 collision frames                   0 Undersize frames        

            0 5 collision frames                   0 Collision fragments     

            0 6 collision frames      

            0 7 collision frames          2600442110 Minimum size frames     

            0 8 collision frames          1541479797 65 to 127 byte frames   

            0 9 collision frames           886205270 128 to 255 byte frames  

            0 10 collision frames          679557526 256 to 511 byte frames  

            0 11 collision frames          577137202 512 to 1023 byte frames 

            0 12 collision frames         2497504960 1024 to 1518 byte frames

            0 13 collision frames                  0 Overrun frames          

            0 14 collision frames                  0 Pause frames            

            0 15 collision frames     

            0 Excessive collisions                 0 Symbol error frames     

            0 Late collisions                      0 Invalid frames, too large

            0 VLAN discard frames                  0 Valid frames, too large 

            0 Excess defer frames                  0 Invalid frames, too small

   2758289607 64 byte frames                       0 Valid frames, too small 

    135451202 127 byte frames         

    536748413 255 byte frames                      0 Too old frames          

    386693070 511 byte frames                      0 Valid oversize frames   

    685003659 1023 byte frames                     0 System FCS error frames 

   3876005417 1518 byte frames                     0 RxPortFifoFull drop frame

            0 Too large frames        

            0 Good (1 coll) frames    

            0 Good (>1 coll) frames   

I upgraded to Version 12.2(55

I upgraded to Version 12.2(55)SE9, it's not solve. I will try to change OFC or transceiver.

CreatePlease to create content